Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast routing with HP Procurve switches

Arjan Anthonisse
Occasional Contributor

Multicast routing with HP Procurve switches

Hi,

I have configured several HP Procurve switches with VLANs and IGMP routing, but somehow imaging with ZENWorks (using multicast) does not work.

ZENWorks used 231.168.146.151 as multicast address. I saw this address on both switches on VLAN 1, but it did not get routed.

The configuration of the switches is as follows:

------
Branch Office 2626M
------
Running configuration:

; J4900B Configuration Editor; Created on release #H.08.106

hostname "BOALSW01"
time timezone 1
time daylight-time-rule Western-Europe
sntp server 192.168.101.1
ip routing
timesync sntp
sntp unicast
logging 192.168.101.148
vlan 1
name "LICHTENVOORD"
untagged 1-24
ip address 192.168.131.254 255.255.255.0
ip helper-address 192.168.101.1
no untagged 25-26
ip igmp forward 12
exit
vlan 2
name "GlasBackBone"
ip address 192.168.252.4 255.255.255.0
tagged 25-26
ip igmp forward 25-26
exit
ip route 0.0.0.0 0.0.0.0 192.168.252.1
ip ssh
password manager

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

-------------
Central Office 3400CL
-------------

Running configuration:

; J4905A Configuration Editor; Created on release #M.10.20

hostname "BOAWSW01"
time timezone 1
time daylight-time-rule Western-Europe
interface 22
name "Lichtenvoorde"
exit
interface 23
name "Groenlo"
exit
interface 21
name "NDIX"
exit
ip default-gateway 192.186.101.254
sntp server 192.168.101.1
ip routing
timesync sntp
sntp unicast
logging 192.168.101.148
vlan 1
name "WINTERSWIJK"
untagged 1-20,24
ip address 192.168.101.252 255.255.255.0
no untagged 21-23
ip proxy-arp
ip igmp forward 1
exit
vlan 2
name "GlasBackBone"
ip address 192.168.252.1 255.255.255.0
tagged 21-23
ip igmp forward 21-23
exit
ip route 192.168.61.0 255.255.255.0 192.168.252.2
ip route 192.168.141.0 255.255.255.0 192.168.252.3
ip route 192.168.131.0 255.255.255.0 192.168.252.4
ip route 192.168.72.0 255.255.255.0 192.168.252.3
ip route 192.168.151.0 255.255.255.0 192.168.252.3
ip route 192.168.161.0 255.255.255.0 192.168.252.3
ip route 0.0.0.0 0.0.0.0 192.168.101.254
spanning-tree
ip dns domain-name "boa.lan"
ip dns server-address 192.168.101.1
ip multicast-routing
ip ssh
router pim
exit
vlan 1
ip pim all
exit
vlan 2
ip pim all
exit
password manager

The branch office switch is one of many, I figure that if it works with one, it works with all of them.

Can someone explain why multicast does not work?
3 REPLIES
Matt Hobbs
Honored Contributor

Re: Multicast routing with HP Procurve switches

Hi Arjan,

In this instance it looks like it is not working because the 2600 does not support multicast routing. All the traffic on the 2600 is on VLAN1, which is then routing through to VLAN2 on the same switch correct?

What you need to do is make the 3400 the only router. Disable 'ip routing' on the 2600 and tag both VLANS 1 and 2 back to the 3400. On the 3400 you'll need to also match the VLAN tagging.

Once the 3400 is the only router involved then it should work. Alternatively if you replace the 2600 with another 3400 that should also do the trick.

Please assign points to replies that help you.

Matt
Arjan Anthonisse
Occasional Contributor

Re: Multicast routing with HP Procurve switches

I set it up like that in the first place, but then I had problems with DHCP. The broadcast would go through before the ip-helper picked it up. This resulted in unpredictable behaviour regarding the ip address that a workstation would get.

Matt Hobbs
Honored Contributor

Re: Multicast routing with HP Procurve switches

It sounds like your clients were on the same broadcast domain as your DHCP server, which in that instance you don't need to specify the ip helper-address.