Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast slowdowns

SOLVED
Go to solution
RobB_8
Advisor

Multicast slowdowns

I seem to be seeing a issue on our network when our techs try to use ghost from our ghostcast server to do a multcast image of multiple machines. All our network and VoIP traffic shows latancy related issues.
We are using a 6400 with 10GB as the core, 3 3400s uplinked to the 6400 at 10GB and 2600's uplinked to the 3400's at 1000T. Our firmware is up to date on all switches, we have qos on the voice vlan (qos dscp 101110), and I have on all the ports on the 6400 broadcast throttling (broadcast-limit 30).
The network monitors do not seem to show the bandwidth maxing out, it is high, but no where near maxed.
Any ideas on how to manage this so it does not take down the entire network?
Thanks
5 REPLIES
Matt Hobbs
Honored Contributor

Re: Multicast slowdowns

Hi Rob,

With the broadcast limiting it also limits multicast traffic, so the first thing I would test would be removing that.

With it enabled, I suspect the CPU is shooting up which is causing your latency issues. Before disabling the broadcast-limit you could keep an eye on the CPU usage of the switches and try ghosting again to verify.

Don't forget to assign points to any replies you get, even if they don't solve your problem immediately you should assign at least a few points for the persons effort.

Matt
Jonathan Axford
Trusted Contributor

Re: Multicast slowdowns

Hi, Do you have IGMP enabled on the switches?
We use Ghost a lot and noticed that due to the nature of the system, Ghost was trying to multicast all of its communication but because we didn;t have IGMP enabled the multiocast was being treated as a broadcast and causing the network to slow down.

It was interesting to look at, our port utilization would shoot up as soon as the ghost sessions was started...
Where there is a will there is a way...
Matt Hobbs
Honored Contributor

Re: Multicast slowdowns

Good catch, I just assumed IGMP was enabled..
RobB_8
Advisor

Re: Multicast slowdowns

I checked the config... IGMP is not in the config, so I assume the default is OFF.
If I enter the command igmp delayed-flush nnn where nnn is a number from 0-255... does anyone recommend a good value to try... since it is our core switch and 58 sites go thru it to reach the internet, I would like to proceed with caution before changing anything on it.
Thanks
Matt Hobbs
Honored Contributor
Solution

Re: Multicast slowdowns

The delayed-flush option is really only beneficial on the 2600's as it does IGMP snooping, whereas the others support data-driven IGMP (better). You probably don't need to use this command, but if you find that you do, I would set it to the maximum value.

Have a read through this thread:

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1008022

I'm going to say you should assign some points to replies again even though the message doesn't seem to be getting through.