Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple Internet connections using Procurve 2610 and Cisco router

Brian Ganaway
Occasional Visitor

Multiple Internet connections using Procurve 2610 and Cisco router

I need help configuring my VLANs to support 3 internet connections for reduntant connections.

The router will manage all of the IP address and routing.

Thank you

2 REPLIES
Brian Ganaway
Occasional Visitor

Re: Multiple Internet connections using Procurve 2610 and Cisco router

Here is the list of how I plane to use the ports.
The Cisco will manage te primary connection on its own interface.

Ports 1-23; internal network
Port 24; Internal interface of Cisco router
Port 25; 2nd internet connection
Port 26; 3rd internet connection

I will need the router to have access to all VLANs.

I and the internal network will only have access to the Cisco router.



Pieter 't Hart
Honored Contributor

Re: Multiple Internet connections using Procurve 2610 and Cisco router

So you need to create three vlan's
(let's say 10, 20, 30)
The switch only needs an ip-adress in vlan-A for management as it will not do any routing itself.
The port connected to the router must pass all vlan's.

vlan 10
ip address 192.168.10.254 255.255.255.0
untagged 1-23
tagged 24
vlan20
untagged 25
tagged 24
vlan30
untagged 26
tagged 24

on the cisco router on the physical interface connected to port 24 of the switch
(let's say interface Gig0/1)
you must create a subinterface for each vlan
interface Gig0/0.1
ip address 192.168.10.1 255.255.255.0
vlan 10
interface Gig0/0.2
ip address 192.168.20.1 255.255.255.0
vlan 20
interface Gig0/0.3
ip address 192.168.30.1 255.255.255.0
vlan 30

and offcourse the external routes