Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Multivlan on ports 5412 zl

SEMLALI EL MOUNTASSIR
Occasional Visitor

Multivlan on ports 5412 zl

Hi,
i have 4 switch's 5412 zl, and i will do a vlan peer switch.

and i want stop the brodcast between vlan's
ans the vlan's dont have the same address broadcast.

how can i do that ?

Thanks
6 REPLIES
Pieter 't Hart
Honored Contributor

Re: Multivlan on ports 5412 zl

if you only create two vlan's, then you've got two separate networks, that don't communicate with each other at all.
all traffic including broadcast stay within a vlan and won't be forwarded to the other vlan.

you don't want the same broadcast address?
then use different subnets, each has it own broadcast address
like 192.168.1.0/24 -> range 192.168.1.1 to 192.168.1.254; broadcast 192.168.1.255
and 192.168.2.0/24 -> range 192.168.2.1 to 192.168.2.254; broadcast 192.168.2.255

or 192.168.1.0/25 -> range 192.168.1.1 to 192.168.1.126; broadcast 192.168.1.127
and 192.168.1.128/25 -> range 192.168.1.129 to 192.168.1.254; broadcast 192.168.1.255

if you want the networks to communicate with eachother you need to configure one of the switches as a router (or a dedicated router).
routers don't forward broadcasts, so the broadcasts stay isolated in their own vlan.
on a switch
- for each vlan configure an vlan interface and assign it a ip-address
- enable ip routing
in each vlan configure the clients to use the switch as the default-gateway.
SEMLALI EL MOUNTASSIR
Occasional Visitor

Re: Multivlan on ports 5412 zl

Can you please suggest me a model config for a multi vlan in the core switch.
and how can i do a switch as router to permit communication between differents VLAN
Tijl van der Steeg
Valued Contributor

Re: Multivlan on ports 5412 zl

You can use the command "ip routing" to enable routing. Other than that. Just put ports in vlans like this. In this example I made a trunked interswitchlink, those ports should be tagged

vlan 2
name "Pretty good VLAN"
untagged 1-8
tagged 21-22
no ip address
exit
vlan 4
name "This one's not bad either"
untagged 8-16
tagged 21-22
no ip address
exit
Pieter 't Hart
Honored Contributor

Re: Multivlan on ports 5412 zl

Not sure if I read your diagram right.
I think the divice top-centre is your core?
Why use both vlan3 and vlan215 for voice?

on the core switch do :
vlan 2
tagged H1-H4
exit
vlan 3
tagged H1-H4
exit
on the edge switches do :
vlan 2
tagged H1
exit
vlan 3
tagged H1
exit
connect H1 on all these switches with H1-H4 on the coreswitch.
and :
vlan 2
untagged H2-H24
exit
vlan 3
tagged H2-H24
exit
for the edgeports

configure routing on the core
ip routing
vlan 2
ip address 10.0.0.1 255.255.255.0
exit
vlan 3
ip address 10.29.0.1 255.255.255.0
exit

Does this cover the question?

Pieter
SEMLALI EL MOUNTASSIR
Occasional Visitor

Re: Multivlan on ports 5412 zl

Can i use other Vlan in the same ports ?
for exemple if i want add Vlan 831 whit other ip address and Vlan 841 also withe other ip address.
i try to add this vlan's in the core switch and edge switch and routing voice trafic, but this not work :(
Pieter 't Hart
Honored Contributor

Re: Multivlan on ports 5412 zl

>>> Can i use other Vlan in the same ports ? <<<

basically you can.
but on a single port:
- only one vlan can be untagged
- other vlans must be tagged
- the device connected must be able to handle tagged packets.

digging deeper into the last line :
- switches and routers can handle tagged packets and so transport multiple vlans on the same port .
- most Pc's normally only handle untagged packets.
- to handle multiple vlan's on a single NIC on a PC or Server you may need to install a vlan-aware NIC driver. (HP proliants with teaming software can).