Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

NLB +LACP & STP issues

SOLVED
Go to solution
Trevor Commulynx
Regular Advisor

NLB +LACP & STP issues

Hi,

I have recently setup 2 P5308XL's with 4 VLANs providing my DMZ's, APP, VoIP and Data Lans. I have a 2 port Trunk between the two with LACP disabled on these ports. I have my Web farm and Database servers all connected via dual nics running Load Balancing with each split across the two switches for redundncy. My problem is, whenever I plug a new switch into any of the Vlans, STP kicks in and blocks all the NLB server ports on both switches which disconects all servers.

I have attached the logs and the configs if anyone can shed some light as I am totally confused as to why this is happening.

Cheers. Trev.
5 REPLIES
Preston Gallwas
Valued Contributor

Re: NLB +LACP & STP issues

What STP Version are you using? RSTP?

Also, the on sites which we run RSTP, when a port comes online it is blocked by STP, but then unblocked (and this does not appear in the log)

If you do a show span I assume it is still being blocked, as you say it disconects all server ports.

The link to the config manual is here: ftp://ftp.hp.com/pub/networking/software/59906050-0105b.pdf
Page 252 may be of help.

Trevor Commulynx
Regular Advisor

Re: NLB +LACP & STP issues

yes we are running RSTP. When I plugged a new switch in last night three entrys were logged. it blocked the port I had just plugged in by STP then ublocked it as you said, but then it blocked a port that I have linked into one of my optus Ethernet service which is a single link. The only thing that is common is the uplink port that was blocke is a tagged member of the VLAN that I plugged the new switch into.

Cheers fro replying. Trev.
Preston Gallwas
Valued Contributor
Solution

Re: NLB +LACP & STP issues

Sorry I can't be of more help, but I do recall reading somewhere in the manual asying that spanning tree operates on a per port not per vlan basis - that may or may not be right (heh sorry! ) its just been a few months since I read it.


Preston Gallwas
Valued Contributor

Re: NLB +LACP & STP issues

Reggie,

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=992571

This thread above mentions that HP switches do not have per-VLAN STP.
Trevor Commulynx
Regular Advisor

Re: NLB +LACP & STP issues

Thankyou for your reply. I have been in touch with HP and it appears that my code is a few revisions behind. Obviously for continued support I need to update it on both devices but they also eluded to STP bug in the version of code that is currently running. I will update this thursday and I will repost the results. cheers once again for your assistance Preston, I will read the GVRP link in that previous thread your presented. ;-)