Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

PC Using a ALT gateway to internet at a different site/vlan

APJ
Occasional Contributor

PC Using a ALT gateway to internet at a different site/vlan

This is going to be harder to explain than to solve me thinks.. but here goes.
I have 3 sites joined by wireless links.
Site1(4208) â Site2(2610) â Site3(2610)
Site1 has a firewall (10.0.10.1)with a second interface to the internet. basically all users use that to get to internet. their DGW is the Site1 switch address and that switch has an IP ROUTE 0.0.0.0 0.0.0.0 10.0.10.1 forcing traffic to the firewall and out.
I have a small router @ Site3 with it's own Internet interface.. public pc's use that as their DGW to get to the internet. I want to be able to setup 1 or 2 (PCâ s)ie: switch ports at Site1 so that those pcâ s go out the DGW at Site3 to the internet. Problem is â vlanâ at each site is routed from site to site over the wireless and Iâ m not sure how to configure to allow emanating and returning traffic between the PC and Site3 router to work.
Here is the 3 sites cut-down configs and a diagram of whatâ s what..
Site1
interface A1
name "Link to Site2"
exit
vlan 1
name "PC"
untagged A5-A23,B1-B12,B21-B24,C1-C24,E1-E24,F1-F21
ip address 10.0.1.254 255.255.255.0
ip helper-address 10.0.10.7
no untagged A1-A4,A24,B13-B20,D1-D24,F22-F24
exit
vlan 203
name "Site3_LINK"
untagged A1
ip address 172.16.3.254 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 10.0.10.5
ip route 10.3.0.0 255.255.0.0 172.16.3.253
ip route 10.1.0.0 255.255.0.0 172.16.3.253
ip route 172.16.1.0 255.255.255.0 172.16.3.253

Site2
hostname "Site2"
ip routing
vlan 203
name "Site1_LINK"
untagged 25
ip address 172.16.3.253 255.255.255.0
exit

vlan 201
name "Site3_LINK"
untagged 26
ip address 172.16.1.254 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 172.16.3.254
ip route 10.1.0.0 255.255.0.0 172.16.1.253

Site3

hostname "Site3"
max-vlans 200
ip routing
vlan 1
name "PC"
untagged 1-23,27-28
ip address 10.1.1.254 255.255.255.0
ip helper-address 10.0.10.7
no untagged 24-26
exit

vlan 201
name "Site2_LINK"
untagged 26
ip address 172.16.1.253 255.255.255.0
exit
vlan 80
name "Public_LIB"
untagged 24
ip address 192.168.0.254 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 172.16.1.254

all the PCâ s basically go back to site1 then out to the internet via the firewall as 0.0.0.0 picks up all the return traffic and sends it back there!
The PCâ s on the public router have their DGW set to the routers address.. so go out itâ s internet link by default.
I need to configure a PC at site1 and the switches in between so that it makes itâ s way to the site3 router and back without upsetting all the rest.. adding routes to the router and/or the firewall at some stage of configuration could help â just thinking ahead..
Any ideas?
AJ