Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

PCM 2.0+ Not scanning configs

SOLVED
Go to solution
Jonathan Axford
Trusted Contributor

PCM 2.0+ Not scanning configs

HI Guys,

I have just got PCM 2.0+ installed, everything seems fine, but i can't get it to scan for configurations.
I get a 'Failure to SCAN Timeout error' everytime i try.

I have checked and double checked both the SNMP details and the Telnet details and all are correct.

Anyone got any idea's on this???

Cheers
Where there is a will there is a way...
12 REPLIES
Mohamed Hamedi
Respected Contributor

Re: PCM 2.0+ Not scanning configs

Hi Jonathan,

-Make sure that your telnet session does nto default to menu. It should be to CLI mode.
try that.
Jonathan Axford
Trusted Contributor

Re: PCM 2.0+ Not scanning configs

Hi,

I am not quite sure what you mean, Where would this be specified?

Cheers
Where there is a will there is a way...
Jonathan Axford
Trusted Contributor

Re: PCM 2.0+ Not scanning configs

When i open a CLI seesion and ask it to do the Show run command, then capture the config after sending commands, I get the sho run output on the screen followed by the following error:

< successful="">
< 10.100.20.12="">
ERROR: com.hp.nis.doloader.CfgMgrException: SNMP Timeout: Accessing TFTP mode: SNMP Get Failure: java.io.IOException: getLong failed
< 10.100.20.12=""> Successful

When i SCAN the device for config, i get the following error :

Starting scan...
Failure: Timeout <10.100.20.12 (10.100.20.12)>
Scan complete.
Where there is a will there is a way...
Mohamed Hamedi
Respected Contributor

Re: PCM 2.0+ Not scanning configs

ok,
-from the prompt run 'menu'
-goto option 8 'Run Setup'
-change Logon Default to 'CLI'



Mohamed Hamedi
Respected Contributor

Re: PCM 2.0+ Not scanning configs

Can you tell us what device this is?
Jonathan Axford
Trusted Contributor

Re: PCM 2.0+ Not scanning configs

Hi again,

Yes, It's set to logon to CLI.
I was unaware that that menu existed to be honest! All of the configs i have done have just been using the CLI, so i am positive that all of the devices will be set to logon to the CLI by default,

Any other idea's????
Where there is a will there is a way...
Jonathan Axford
Trusted Contributor

Re: PCM 2.0+ Not scanning configs

The device i am testing is an HP 2848 qand an HP 9308

On the network we have a mixture of 9304, 9308, 5304,5308,4108,2624,2650,2524.

None of these switches will currently allow me to scan for configs, so there must be something in common with all of them that is causing the problems...

The 2848 i am testing is at software ver I.08.58


The 9308 is at ver 07.6.04cT53
Where there is a will there is a way...
Mohamed Hamedi
Respected Contributor

Re: PCM 2.0+ Not scanning configs

That error basically says that an SNMP get failed.
-I would check again that your SNMP community settings are correct. Try doing get using another tool.
-The telnet setting are also correct. Remember to leave the user in PCM telnet settings to blank. (Config uses telnet)
Mohamed Hamedi
Respected Contributor
Solution

Re: PCM 2.0+ Not scanning configs

One more thing, make sure your community name has Manager access.
So for example : Private/Manager
Jonathan Axford
Trusted Contributor

Re: PCM 2.0+ Not scanning configs

Ok,

Have checked SNMP strings, they are definately ok, I have run the communication test and attached the output, It says that all is successful.

Where there is a will there is a way...
Jonathan Axford
Trusted Contributor

Re: PCM 2.0+ Not scanning configs

OK, Sorted,

The snmp-server was set to operator unrestricted and not manager unrestricted.

Thanks for your help, I just have to go through all the other switches and change them now.....

Cheers!
Where there is a will there is a way...
Jonathan Axford
Trusted Contributor

Re: PCM 2.0+ Not scanning configs

I have successfully managed to get all of the devices working, except for the 9300 series.

I have configured the community strings on them, but they don't allow you to specify whether to use 'manager' or 'operator' access. Only if you want the string to be read-only or read-write.

How do i configure the 9300 switches to scan for configs?
Where there is a will there is a way...