Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

PXE boot to Acronis Server across VLANs

simon crelling
Occasional Contributor

PXE boot to Acronis Server across VLANs

Hi,

I have a working DHCP server at 10.10.250.120/24 and an Acronis Snap Deploy PXE server at 10.10.250.21/24, both in the Servers VLAN (10).

My client PC is in the Hosts VLAN (2)(172.16.2.0/24) and is able to get DHCP and operate normally on the network. I'm testing out Acronis but I cannot PXE boot with my client. (The PXE and DHCP servers are seperate as the PXE server is a demo and is being tested and the DHCP server is also a domain controller, so I want to keep any 3rd part software away).

I've added a second ip helper-address entry to the Hosts VLAN with no effect.

STP is enabled.

Partial 5400zl config:

ip routing
snmp-server community "public" Unrestricted
snmp-server host 172.16.1.10 "public"
vlan 2
name "HOSTS"
ip helper-address 10.10.250.120
ip helper-address 10.10.250.21
ip address 172.16.2.1 255.255.255.0
tagged B13,B15,B17,B19,B21-B24,E2
exit
vlan 10
name "SERVERS"
untagged A1-A2,A4,A7-A8,A11,A13,A15,A22,A24,B5,B7,C1,C3,C5,C10,C12-C13,C16,C18,C20-C21,C24,D7,D9
ip address 10.10.250.1 255.255.255.0
tagged E2
exit

Simon
7 REPLIES
Olaf Borowski
Respected Contributor

Re: PXE boot to Acronis Server across VLANs

enable "dhcp-relay" globally?
Kevin.Meany
Advisor

Re: PXE boot to Acronis Server across VLANs

I haven't use an Acronis PXE boot before but I have used this for both WDS servers and Altiris PXE servers. The PXE server needs to see all the DHCp requests as well as port 69 which is also tftp, plus port 4011 So I have these lines added for my PXE boots. The .60 ip is the PXE server, the .31 is the regular dhcp server.

ip helper-address 192.168.1.31
ip helper-address 192.168.1.60
ip forward-protocol udp 192.168.1.60 tftp
ip forward-protocol udp 192.168.1.60 4011
Mark Wibaux
Trusted Contributor

Re: PXE boot to Acronis Server across VLANs

simon crelling
Occasional Contributor

Re: PXE boot to Acronis Server across VLANs

Thanks for the responses,

dhcp-relay is enabled globally.

I've added:
ip forward-protocol udp 10.10.250.21 tftp
ip forward-protocol udp 10.10.250.21 4011
to VLAN 2, but the problem remains.

I moved the Acronis PXE server in to VLAN 2 to confirm PXE booting is working and it does. I don't want to remove the broadcast limit on the interfaces (set to 5) as I don't want to risk broadcasts overwhelming the switch.
Mark Wibaux
Trusted Contributor

Re: PXE boot to Acronis Server across VLANs

Just checking. The default gateway for your DHCP server is the switch? (Just so it knows how to get back to the client VLAN).

Another thing to look at might be to add the relevant DHCP options to your scope so that clients are forced to the PXE server.
Here's one link that might help you
http://www.freewysemonkeys.com/modules.php?name=News&file=article&sid=69&mode=thread&order=0&thold=0
but do a google search for
dhcp pxe option
and you find other articles that might also help you.
Trevor Commulynx
Regular Advisor

Re: PXE boot to Acronis Server across VLANs

Have you done a Wireshark trace to see the differrence between normal PXE operation and the vlan you are having issues on?

MJBMCP
Occasional Visitor

Re: PXE boot to Acronis Server across VLANs

I have same problem.