Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Please Help.. CONFUSED :( cisco 2811 router and PC 2824 and VLANS

Jeff Pancrazio_1
Occasional Visitor

Please Help.. CONFUSED :( cisco 2811 router and PC 2824 and VLANS

Hello all.. I feel so stupid.. I dont know WHAT I am doing wrong... I have a 2821 router with a multlink (3 t1's) that goto seperate locations, and also want to use this router to connect to our normal LAN, and new VLANS that I am working on creating with the procurve.. I have vlan 1 2 3 4, i can from a laptop on 192.168.2.6 i can ping 192.168.2.2 and 2.1 and 1.1 and 1.2 or 3.1/3.2 and 4.1/4.2 BUT not on to the regular network, which the 2821 can ping.. I have also enclosed the config
!
interface Multilink1
description $ETH-WAN$
ip address XX.XX.XX.XX XX.XX.XX.XX
ip nbar protocol-discovery
ip flow ingress
ip flow egress
ppp multilink
ppp multilink group 1
!
interface FastEthernet0/0
description $ETH-LAN$
ip address 192.168.0.31 255.255.255.0
ip mask-reply
no ip redirects
ip policy route-map internet-map
duplex auto
speed auto
standby 10 ip 192.168.0.254
standby 10 preempt
!
interface FastEthernet0/1
description NOT USED!
no ip address
no ip split-horizon
duplex auto
speed auto
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/1.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/1.3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/1.4
encapsulation dot1Q 4
ip address 192.168.4.1 255.255.255.0
!
interface Serial0/0/0
no ip address
encapsulation ppp
service-module t1 timeslots 1-24
service-module t1 remote-alarm-enable
service-module t1 fdl ansi
ppp multilink
ppp multilink group 1
!
interface Serial0/1/0
no ip address
encapsulation ppp
service-module t1 timeslots 1-24
service-module t1 remote-alarm-enable
service-module t1 fdl ansi
ppp multilink
ppp multilink group 1
!
no ip address
interface Serial0/2/0
encapsulation ppp
service-module t1 timeslots 1-24
service-module t1 remote-alarm-enable
service-module t1 fdl ansi
ppp multilink
ppp multilink group 1
!


HP PROCURVE 2824 Config

; J4903A Configuration Editor; Created on release #I.08.98

hostname "VLAN_CORE"
ip default-gateway 192.168.0.31
ip routing
timesync sntp
sntp broadcast
snmp-server community "public" Unrestricted
vlan 1
name "VLAN 1"
untagged 1-6,8-20,22-24
ip address 192.168.1.2 255.255.255.0
tagged 7,21
exit
vlan 2
name "VLAN 2"
untagged 7
ip address 192.168.2.2 255.255.255.0
tagged 1-6,8-24
exit
vlan 3
name "VLAN 3"
ip address 192.168.3.2 255.255.255.0
tagged 1-24
exit
vlan 4
name "VLAN 4"
tagged 21
exit
gvrp
management-vlan 1








Thanks in advance..

2 REPLIES
cenk sasmaztin
Honored Contributor

Re: Please Help.. CONFUSED :( cisco 2811 router and PC 2824 and VLANS

hi jeff please see my example config
router ethernet interface config
this interface connect switch

interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.4
encapsulation dot1Q 4
ip address 192.168.4.1 255.255.255.0

we make 4 sperate sub interface on router lan interface this interface connect procurve switch


procurve switch config

vlan 1
name "DEFAULT_VLAN"
untagged 1-9,21-24
ip address 192.168.1.2 255.255.255.0
no untagged 10-20
exit
vlan 2
name "VLAN2"
untagged 10-12
tagged 24
no ip address
exit
vlan 3
name "VLAN3"
untagged 13-15
tagged 24
no ip address
exit
vlan 4
name "VLAN4"
untagged 16-20
tagged 24
no ip address
exit

vlan 1 ip address only switch managemet
vlan's untag port must have connect vlan member pc interface 24 must have connect router ethernet port

also very important your pc ip configuration
for example
vlan 2 member pc
ip address 192.168.2.10
subnet mask 255.255.255.0
default gateway address 192.168.2.1 !!!!!

so your main routing device must have cisco router procurve switch running only L2 operation with vlan all vlan reach internet or other vlan have to go router with 802.1q

cenk

Pieter 't Hart
Honored Contributor

Re: Please Help.. CONFUSED :( cisco 2811 router and PC 2824 and VLANS

I've some remarks and questions

= i assume the router is connected to switchport 21?

= What device dou you want to do the routing between subnets?
at this time both router and switch could do the job, both have adresses in all vlan's.

= How are the devices connected?
your switches "default-gateway" point to routers interface fa0/0, but your vlans seems to be connected to Fa0/1.
Or are both connected? if so to what switchports

when on the switch when "ip routing" is enabled. the statement " ip default-gateway 192.168.0.31" is ignored!
you can remove this and replace with the statemen"ip rout 0.0.0.0 0.0.0.0 ".
but see remark above about Fa0/0 and Fa0/1
the switch has no ip-address in 192.168.0.0/24 subnet!

the routers config :
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
doesn't match the switches :
vlan 1
name "VLAN 1"
untagged 1-6,8-20,22-24
ip address 192.168.1.2 255.255.255.0
tagged 7,21
exit
-> router "native" should match switch "untagged".
(assumed the router fa0/1 is connected to switchport 21)

i don't see "ip routing" in the routers config, but maybe you only show part of the routers config, as i also see no details of the "ip policy route-map internet-map"?