Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Poor performance on Procurve 2848

SOLVED
Go to solution
Robert Van De Weghe
Occasional Visitor

Poor performance on Procurve 2848

I have been working with small networks for a few years but recently one of the companies I do work for has increased in size. I currently have a 2650 and 2848 stacked.
Not having dealt with managed switches very much I find myself in need of some assistance.
I should mention we have 100% Apple user base. G5 towers, Powerbooks and eMacs.
Through testing I have noticed a large performance difference when copying files from the server (connected to 2848) by machines connected to the 2848. A folder holding 300 MB of data takes 10-12 minutes on the 2848, but if I switch the same machine to a port connected to the 2650 the data transfers in less than a minute. This issue is re-creatable on multiple machines. It only happens with machines having 100T NICs not the G5 or G4's with 1000T NICs. I have also recreated the issue with a PowerBook G4 directly connected to the 2848 on multiple ports. I have tried setting both the PowerBook and 2848 to static 100T/ full duplex to see if there was an issue with auto negociation but the performance issue still exists.
If anyone has some idea how to next approach this I would appreciate the assistance.

Thank you
5 REPLIES
Jason Scott
Regular Advisor

Re: Poor performance on Procurve 2848

This doesn't really help with your problem, but we've got 2 2848s in our server cabinets with servers multi-homed between them. Each 2848 connects back to a 5308 and 9308 via gbit fibre and we've noticed no performance issues.

Are your switches also doing routing?
Matt Hobbs
Honored Contributor
Solution

Re: Poor performance on Procurve 2848

Try using the 'qos-passthrough-mode' command on the 2800's, it should make a significant difference.
Robert Van De Weghe
Occasional Visitor

Re: Poor performance on Procurve 2848

No IP routing
I will try the qos-passthrough-mode command

Thank you for the timely advice
Robert Van De Weghe
Occasional Visitor

Re: Poor performance on Procurve 2848

Great

The qos-passthrough-mode command solved the problem.
I guess if I had done a little more digging I would have found the buffer issue mentioned in a couple of other threads.

Thanks again
Les Ligetfalvy
Esteemed Contributor

Re: Poor performance on Procurve 2848

It also helps not to mix speeds on that model. Put only gig NICs on it and relegate it to a closet that doesn't matter.

I have a 2848 that I had big plans for and now it mostly collects dust.