Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Poor perfrmance between Procurve 5400 and EMC NS20

ssAPT
Occasional Advisor

Poor perfrmance between Procurve 5400 and EMC NS20

Hi

We have a 5400zl in our core that is attached to both an EMC NS20 SAN as well as Apple Mac Servers. File transfers to the MAC are twice as fast as to the NS20. Each has a 2 gig trunk to the switch using load balancing. The NS20 is CIFS and the Mac is AFP.. File sizes are between 500meg and 1 gig as we're a marketing/advertising company.

Is there anything on the 5400 that I can configure to improve performance to the NS20 ? We are not running any special configs on the switch. Just the standard stuff

Thanks
3 REPLIES
Patrick Terlisten
Honored Contributor

Re: Poor perfrmance between Procurve 5400 and EMC NS20

Hello,

this could be protocol related. CIFS is not the fastest protocol. With 1 GbE a good CIFS implementation should get up to 70 MB/s.

What kind of trunking is used with the NS20? LACP or static trunk? Sure that the NS20 is using both links and not one active link and one standby?

Best regards,
Patrick
Best regards,
Patrick
ssAPT
Occasional Advisor

Re: Poor perfrmance between Procurve 5400 and EMC NS20

below is the config of the 5400. The trunk in use is a HP static trunk. Not sure on the NS20 as this was setup by an EMC partner but I assume static as well

All ports in the trunk show as being up so I am not sure if both ports are indeed being used. Is there a command on the 5400 that I can run to see if both ports in the trunk are passing traffic ?

thanks your help


module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
module 4 type J8702A
module 5 type J8705A
module 6 type J8705A
module 12 type J8706A
interface B1
name "To_Block1_1st"
exit
interface B2
name "To_Block1_1st"
exit
interface B3
name "To_Block1_1st"
exit
interface B4
name "To_Block1_1st"
exit
interface L1
name "To_Block3"
exit
interface L2
name "To_Block3"
exit
interface L3
name "To_Block3"
exit
interface L4
name "To_Block3"
exit
interface L5
name "To_Block2_Grnd"
exit
interface L6
name "To_Block2_Grnd"
exit
interface L7
name "To_Block2_Grnd"
exit
interface L8
name "To_Block2_Grnd"
exit
interface L9
name "To_Block4"
exit
interface L10
name "To_Block4"
exit

trunk B1,B4 Trk1 Trunk
trunk L1,L4 Trk2 Trunk
trunk L5,L8 Trk3 Trunk
trunk L9,L10 Trk4 Trunk
ip routing
no timesync
vlan 1
name "Data"
untagged A7-A24,B5-B24,C1-C24,D1-D24,E1-E24,F1-F24,L11-L24,Trk1-Trk4
ip helper-address 10.132.16.39
ip helper-address 10.132.16.34
ip address 10.132.16.1 255.255.252.0
no untagged A1-A6
exit
vlan 160
name "Voice"
untagged A1-A6
ip helper-address 10.132.116.2
ip address 10.132.116.1 255.255.252.0
tagged A7-A24,B5-B24,C1-C24,D1-D24,E1-E24,F1-F24,L11-L24,Trk1-Trk4
exit
no fault-finder bad-driver
no fault-finder bad-transceiver
no fault-finder bad-cable
no fault-finder too-long-cable
no fault-finder over-bandwidth
no fault-finder broadcast-storm
no fault-finder loss-of-link
no fault-finder duplex-mismatch-HDx
no fault-finder duplex-mismatch-FDx
dhcp-snooping
dhcp-snooping authorized-server 10.132.16.34
dhcp-snooping authorized-server 10.132.16.39
dhcp-snooping vlan 1
ip route 0.0.0.0 0.0.0.0 10.132.16.3
interface C1
dhcp-snooping trust
exit
interface C2
dhcp-snooping trust
exit
interface C3
dhcp-snooping trust
exit
interface C4
dhcp-snooping trust
exit
interface C5
dhcp-snooping trust
exit
interface C6
dhcp-snooping trust
exit
interface C7
dhcp-snooping trust
exit
interface C8
dhcp-snooping trust
exit
interface C9
dhcp-snooping trust
exit
interface C10
dhcp-snooping trust
exit
interface C11
dhcp-snooping trust
exit
interface C12
dhcp-snooping trust
exit
interface C13
dhcp-snooping trust
exit
interface C14
dhcp-snooping trust
exit
interface C15
dhcp-snooping trust
exit
interface C16
dhcp-snooping trust
exit
interface C17
dhcp-snooping trust
exit
interface C18
dhcp-snooping trust
exit
interface C19
dhcp-snooping trust
exit
interface C20
dhcp-snooping trust
exit
interface C21
dhcp-snooping trust
exit
interface C22
dhcp-snooping trust
exit
interface C23
dhcp-snooping trust
exit
interface C24
dhcp-snooping trust
exit
interface L11
dhcp-snooping trust
exit
interface L12
dhcp-snooping trust
exit
interface L13
dhcp-snooping trust
exit
interface L14
dhcp-snooping trust
exit
interface L15
dhcp-snooping trust
exit
interface L16
dhcp-snooping trust
exit
interface L17
dhcp-snooping trust
exit
interface L18
dhcp-snooping trust
exit
interface L19
dhcp-snooping trust
exit
interface L20
dhcp-snooping trust
exit
interface L21
dhcp-snooping trust
exit
interface L22
dhcp-snooping trust
exit
interface L23
dhcp-snooping trust
exit
interface L24
dhcp-snooping trust
exit
interface Trk1
dhcp-snooping trust
exit
interface Trk2
dhcp-snooping trust
exit
interface Trk3
dhcp-snooping trust
exit
interface Trk4
dhcp-snooping trust
exit
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
spanning-tree priority 1 force-version RSTP-operation

Patrick Terlisten
Honored Contributor

Re: Poor perfrmance between Procurve 5400 and EMC NS20

Hello,

you should check the trunking on the NS20. Are there any errors on the ports to the NS20?

Best regards,
Patrick
Best regards,
Patrick