Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Port disabled at one end shows link status up at the other

SOLVED
Go to solution
Aarón
Frequent Advisor

Port disabled at one end shows link status up at the other

Hi everyone,

I've testeded disabling and enabling the link between two totally different 5412zl. The links are 10GbE-LR type. When I disabled it in one end, the other one still gave link and keept the vlan 'enabled'. It happened on all the 10GbE links I tried it on.

I tried enabling UDLD, but the link is still up. It just disabled the vlan in that port showing this entry log:

I 03/19/09 11:31:39 00832 udld: Link state on port 'B1' is changed to 'failure'
state.
I 03/19/09 11:31:39 00435 ports: port B1 is Blocked by UDLD
I 03/19/09 11:31:39 00002 vlan: DEFAULT_VLAN virtual LAN disabled

Is this 'keep the "up" status of the link even if it's not enabled at the other end' normal?

Thank you very much in advance

Aaron
5 REPLIES
Pieter 't Hart
Honored Contributor

Re: Port disabled at one end shows link status up at the other

it's the same like whwn you connect the network port on a pc that's "powered-down"
you will see the link-led is on.

on physical level the link is up (connected, power aplied) allthough nobody is listening/talking (port = shutdown).
so at the other switch (port enabled) also the link is up, but no data will be coming in.
you may see difference in "link-state" (up)and "protcol-state" (down).
On an active port both states will be up.

Aarón
Frequent Advisor

Re: Port disabled at one end shows link status up at the other

First, thank you for answering so fast. I know some computers keep an up link-state when are off but, how come that only happens with 10GbE links?It doesn't happen with 1GbE fiber links:/

Anyway, I just wanted to know if it's a normal behaviour or not. So if it is, at least we know what to expect in the log when we see the link down.

Thank you again ;)
Matt Hobbs
Honored Contributor
Solution

Re: Port disabled at one end shows link status up at the other

I don't think this is normal. Get a 'show tech transceivers' and contact HP support. If I recall correctly there may have been a certain batch that had this problem. Otherwise make sure you have the latest firmware installed as it may have also resolved this issue.
Aarón
Frequent Advisor

Re: Port disabled at one end shows link status up at the other

Thank you both. I just opened a case with Procurve support and they will look into it.

Take care,

Aarón
Aarón
Frequent Advisor

Re: Port disabled at one end shows link status up at the other

Closing thread