Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Port mirroring

SOLVED
Go to solution
Geofry Glenn
Occasional Visitor

Port mirroring

I have configured port mirroring on an HP Procurve 2524 switch, but am experiencing technical difficulties.

When I tell the mirror-port to mirror port 1, it ALSO sets up mirroring on VLAN 1 (at least, that is what it shows in the configuration log). And using the command 'no vlan 1 mirror' has no effect. When I remove the mirroring of port 1, the VLAN mirror disappears simultaneously.

Secondly, although this is the port that connects my firewall to the main network switch, all the traffic appearing on the mirroring port seems to be UDP only.

Can anyone tell me if there is some configuration issue that I'm not aware of that might be causing these issues?

Thanks,

Geofry
3 REPLIES
Geofry Glenn
Occasional Visitor

Re: Port mirroring

sorry, I mis-wrote the command, it is 'no vlan 1 monitor', not 'no vlan 1 mirror'
Mohammed Faiz
Honored Contributor
Solution

Re: Port mirroring

Hi,

Could you tell us what firmware you're running on the 2524?
Also, from your description I'm assuming you're using VLAN monitoring, can you try using port monitoring instead?
It might be useful if you could post your config up to.
Geofry Glenn
Occasional Visitor

Re: Port mirroring

It looks like I've figured out a workaround.

I'm sorry it wasn't clear from my earlier post, probably from my reiterating the 'no vlan...' command.

I was/am *trying* to do a single port mirror, but vlan mirroring was happening defacto at the same time, and I couldn't turn off the vlan mirroring.

The problem (which, if this isn't the latest firmware, may have been fixed?) is apparently that if you have a vlan numbered the same as a port number (not an ideal setup, I know, but I did not configure this switch), and you mirror that port, it will also mirror the vlan.

I fixed the issue by moving the port to connect to my firewall to a port that did not have a matching numbered vlan.

Firmware version is release #F.05.22, BTW. I'm going to go check and see if it is up to the latest version now.

Thanks for the response!