Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Port tagged and untagged at the same time....

SOLVED
Go to solution
Jonathan Axford
Trusted Contributor

Port tagged and untagged at the same time....

Hi Guys,

After having much success in the field of Procurve networking i am trying to get my head around the Cisco side of things!

Can a port be a tagged member of one VLAN and an Untagged member of another VLAN?

As far as i know it can. I know with an HP box you assign the ports to VLANs whereas on Cisco, you assign VLANS to ports. (If that makes sense...)

HP...

Vlan 100
tagged 1
Vlan 200
untagged 1

Cisco ????

int fa0/1
switchport access vlan 1
switchport mode trunk?
switchport trunk encap dot1q?

Does this look any good??

Any help much appreciated..

Cheers
Where there is a will there is a way...
3 REPLIES
Mohieddin Kharnoub
Honored Contributor
Solution

Re: Port tagged and untagged at the same time....

Hi

Its not a vendor thing Jonathan, its a networking technique.

Lets talk about some Certain rules regaring 802.1q:

- A port can be untagged to MAX one Vlan and at least one Vlan :)
- A port can be tagged to multiple Vlans at the same time.
- A port can't be tagged and untagged to the same Vlan.

Now in ProCurve:
----------------

Untagging: SW(config)#Vlan 10 untag 1
Tagging: SW(config)#Vlan 10 tag 1

In Cisco:
---------
Untagging:

SW(config)#interface fa 0/1
SW(config-if)#Switchport mode access
SW(config-if)#switchport access vlan 1

Tagging: (Cisco recommends to shut down the interface before starting 802.1q configuration, then enable it at the end)

SW(config)#interface fa 0/1
SW(config-if)#shut
SW(config-if)#switchport trunk encapsulation dot1q
SW(config-if)#switchport trunk allowed vlan 1
Switch(config-if)#switchport mode trunk
SW(config-if)#no shut

Also:
Configure the trunking native VLAN number for 802.1Q links. This number must match at both ends of an 802.1Q uplink

So if uplink between ProCurve and Cisco, the Native Vlan on Cisco should match the Default_Vlan on ProCurve (default to one).
the command to change it is:
SW(config-if)#switchport trunk native vlan (default_Vlan ID).

Good Luck !!!

Science for Everyone
Jonathan Axford
Trusted Contributor

Re: Port tagged and untagged at the same time....

Excellent, thanks for the Info.

I knew it would work, but i just couldn't get my head round the config!

Many thanks
Where there is a will there is a way...
Jonathan Axford
Trusted Contributor

Re: Port tagged and untagged at the same time....

Just one more thing on this subject...

Using the config above, i am guessing it is possible to route certain VLANS over that interface whilst continuing to Trunk others at Layer 2???

Basically, we are introducing OSPF switches into what is, at the moment, a single Layer 2 network. We can split most of it out into VLANS and use the routers no problem, but there are about 4 VLANS that have to stay the same (I.e IP addresses etc) and these span all sites.

I am thinking that i need to configure VLANs as the routing interfaces and 'untag' the physical interface in this VLAN for the route connection and then 'tag' the Layer 2 VLANS on the same interface for the trunked connections??

Does this make sense???

Cheers all
Where there is a will there is a way...