Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

ProCurve - 2 ports to one machine

SOLVED
Go to solution
Rocky Pritchard
Occasional Contributor

ProCurve - 2 ports to one machine


I've "teamed up" the two network cards on a Proliant ml 350, Windows Server 2003 R2, using the HP Network configuration tool. I'm doing this for faster data transfer and fault tolerance. I set my team type to TLB and my TLB method to TCP connection. Then assigned the team a static ip.

I am now trying to set up the HP J4819A Procurve Switch 5308xl so that it will take advantage of both these ports going to the same ip. (Am I on the right track? Is this needed?) I read about trunking but can't quite seem to "get it".

I've browsed for how to's or examples but can't find anything that's clicking for me.

Help?


3 REPLIES
Olaf Borowski
Respected Contributor
Solution

Re: ProCurve - 2 ports to one machine

Rocky,
the 5300 can do static or LACP trunks. What this will give you is "one pipe" consisting of multiple links. If you want to use LACP, you need to enable that on the switch and server. It is a protocol that negotiates the trunk.
If you didn't configure a trunk on the switch, just configure the two ports going to the server with the same VLAN. I believe configuring the server with team and TLB doesn't trunk the interfaces. They will still have 2 seperate MAC addresses. The server will do the load balancing. If you configure LACP on the server, you also need to configure it on the switch.

Hope this helps.
Rocky Pritchard
Occasional Contributor

Re: ProCurve - 2 ports to one machine

Thanks for the suggestions Olaf. After quite a bit more reading around I think I may have got the solution I was looking for. I'll post a little walkthrough in case anyone else is trying this(Or in case I'm completely off basis and someone wants to correct me)

Basically on my HP Proliant I went to HP Network Config Utility. Select all of the nics you want to include and press the team button. Choose the newly created team and press properties. Under team type selection I chose 802.3ad Dynamic with Fault Tolerance(This is the only option that would work for me in order to get both cards sending and receiving). Under Transmit load balancing method I left it alone at Automatic allthough other sources I read suggested to choose TCP Connection.
Press OK and it will configure the nics.

On the Procurve. I logged on via Telnet.
1. Type 'config' to get to that menu
2. From here I typed "trunk 4, 5, Trk1 lacp".
(4 and 5 were the port #'s on my test switch, Trk1 is what you want to call your trunk, and I'll be honest I'm not sure what lacp does but all the articles I read use it)
3. Type vlan 3 name vlan_3
4. vlan 3 tagged Trnk1
5. Then exit the switch saving changes.

I'm still not sure why the vlan has to be created. It may not be... Regardless now under my monitors It shows that both of my cards on my machine are sending and receiving. Correctly showing 2 gb up and down.

Olaf Borowski
Respected Contributor

Re: ProCurve - 2 ports to one machine

Rocky,
You don't have to put the trunk in a different VLAN and you probably don't want to do that anyway. By default, all ports are in VLAN 1 untagged. You probably want the trunk in VLAN 1 untagged. Unless the server supports "tagging" and you need multiple subnet/VLANs on the server, don't use it. The tag basically tells the system which VLAN the packet belongs to. The server probably only has one VLAN (VLAN 1 untagged) on it anyways. Unless you want the server on a different subnet (VLAN), use VLAN 1. If you want the server on a different subnet (VLAN), you have to route somewhere in your network so the different VLANs (sbunets) can communicate with each other.
So config should be:

1. Type 'config' to get to that menu
2. From here I typed "trunk 4, 5, Trk1 lacp".
3. vlan 1 untag Trnk1
4. Then exit the switch saving changes.