Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

ProCurve 2524 Port Trunking

GrahamMW
Occasional Contributor

ProCurve 2524 Port Trunking

I am trying to configure Port Trunking for a server with two nic's in it. I have set the intel adapters to adaptive load balancing and I am getting loads of errors on the 2524. I am also runnning 2 VLANs (one for voice and one for data). What do I need to do to get this working. I've read some the pdf's but it confusing me a bit. Do I create a trunk group (through the cli) and then add the two ethernet ports to that trunk group??

I am also receiving LACP errors on the one of the ports of this server. Below is the error from the event log.

ports: port 9 is now off-line
ports: port 9 is Blocked by LACP
lacp: Port 9 is in Half Duplex - set to Individual
ports: port 9 is now on-line
FFI: port 9-High collision or drop rate. See help.

Cheers

Graham
8 REPLIES
Ron Kinner
Honored Contributor

Re: ProCurve 2524 Port Trunking

Let's fix the easy thing first. The errors are most likely caused by a duplex mismatch. The other side is probably set to 100 full and the switch port is running autonegotiate. This configuration will always result in a mismatch since the autonegotiate spec requires it to use half duplex if the other side does not autonegotiate. Set both ends to full or let both ends do autonegotiate and that should solve your error problem.

Reading Intels blurb on Adaptive Load Balancing www.intel.com/network/connectivity/resources/ technologies/load_balancing.htm

I see that unless you have a Cisco switch running Fast Ether Channel or Gigbit Ether Channel the traffic flow is in on one port and out on all. This would make any switch happy since the Intel would always give a single MAC (that of the 2 way port) in response to an ARP for the IP address of the server. No trunking or other fancy stuff is required. You don't even have to tag the packets. In your setup for the switch just tell it you want the data VLAN to appear untagged on the ports going to the server. The ports should be programmed like any port feeding a dumb PC without a phone. These are not interswitch trunks and the server doesn't need to answer the phone. I don't know offhand if HP switches support the Cisco protocols but I would go ahead and set it up like I told you first and get it to working and then look into what you have to do to get it to do the channel stuff.

Ron
Shane_33
Frequent Advisor

Re: ProCurve 2524 Port Trunking

If the Intels can use Cisco FEC (Fast EtherChannel) the 2524's can do that too. You will need to follow the manual to enable FEC and disable LACP to do this.

HP ProCurve is the only tier 1 vendor other than Cisco that I believe supports FEC in its switches - although the industry standard LACP is much preferred.

Regards,
Shane.
GrahamMW
Occasional Contributor

Re: ProCurve 2524 Port Trunking

Thanks guys for giving me things to try.

The cards are set to Auto Detect and they are connected at 100Mb FD.

I disabled LACP I set the team to FEC and set the two ports on the swtich to trk1 and FEC. I was still getting the error of excessive late collisions. I was also unable to connect to others devices in the stack - only servers on the same swtich. The Intel Pro Set says everything is configured OK.

I then re-enabled LACP just on the two ports and put them in a trunk group and the Intel software was still complaining that it is configured wrong.

Any other ideas.

Cheers

Graham
Ron Kinner
Honored Contributor

Re: ProCurve 2524 Port Trunking

I would suggest setting both the ports on the switch and the server to Full Duplex manually. The fact that the switch is complaining about collisions is a good sign that the port 9 is not really at 100 full since the collision detection is usually turned off in Full duplex mode. (If it is at 100Half then the switch cannot do LACP (if the Intel supports it which was not clear from the blurb)). The fact that the Intel seemed happier with it at FEC is a good indication that it doesn't.

Seems to me that you were much closer to getting it to work when you set it to FEC. If you can talk to the other servers then your link is good and you probably have VLAN or interswitch trunking problems. Which VLANs does the server support? Which VLANs do the other servers support? For that matter does the server's operating system support VLANs? Which VLANs can the server not reach. Are these on the same switch or another switch?

Is there any routing involved? Are the servers perhaps all in the same subnet and the hosts in a different one?

Ron

Nabi
Occasional Visitor

Re: ProCurve 2524 Port Trunking

Hi;
I have a problem for HP 5108 switch family...
what is "blocked by LACP" error???
Shane_33
Frequent Advisor

Re: ProCurve 2524 Port Trunking

Nabi,

"Blocked by LACP" is just a message stating that LACP is checking to see if this port should be made part of a trunk. If not, it then opens the port. The message in essence is more of a courtesy - except it can fill your logs pretty quickly as it happens every time someone initially connects a device to a switch port.

It is part of the IEEE 802.3ad standard and is the main culprit in issues where protocols (such as Appletalk) do not handle the sub second delay this introduces. In normal practice an IP network will handle this fine.

The IEEE 802.3ad spec actually requires this to be enabled by default as it automates the trunking process. If you are not using trunks, then you can turn it off if you'd like, but I wouldn't unless it causes you specific issues (such as with Appletalk I mentioned above).

Regards,
Shane.
SCOOTER
Esteemed Contributor

Re: ProCurve 2524 Port Trunking

NABI,

To dissable LACP on all ports use the commands below. If you need to configure LACP tunking only activate this on the ports included in the LACP trunk. The rest of the ports will not be blocked by LACP

In the CLI type the following:

Switch53xx# config t
Switch53xx(config)# no interface all lacp
Switch53xx(config)# write mem
Switch53xx(config)# show lacp

The reply is "No LACP ports found".


Regards,

SCOOTER
Balázs Zalavári
Occasional Visitor

Re: ProCurve 2524 Port Trunking

Scooter,

can i execute "no interface all lacp" command in the daytime carefree?
Cause any care this message: "port x is now off-line" and then "port x is now on-line".
What happen on the client side?

Balazs