Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

ProCurve 2626

SOLVED
Go to solution

ProCurve 2626

hostname "ProCurve Switch 2626"
snmp-server contact "Robert Peirce"
time timezone 1
mirror-port 24
interface 1
no lacp
exit
trunk 1 Trk1 Trunk
ip default-gateway 204.68.155.248
ip routing
no timesync
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 4-26,Trk1
ip address 204.68.155.44 255.255.255.0
no untagged 2-3
exit
vlan 2
name "Sys_Admin"
untagged 2-3
ip address 172.168.70.1 255.255.255.0
exit
interface 25
monitor
exit
ip authorized-managers 204.68.155.135 255.255.255.0
ip authorized-managers 204.68.155.102 255.255.255.0
ip authorized-managers 204.68.155.121 255.255.255.0
ip authorized-managers 204.68.155.109 255.255.255.0
primary-vlan 2
spanning-tree Trk1 priority 4
password manager
password operator



I am having an issue ping the far side of a Cisco router from an HP2626 VLAN_ID 2 (172.168.70.x). The default VLAN_ID 1 on the 2626 has an IP of 204.68.155.44. I am able to ping from the 172.168.70.x (VLAN_ID 2) to all other 204.68.155.x IPs. This includes 204.68.155.x addresses connected directly to the ProCurve 2626 and ones which are connected to another switch.

Our router to the public side has an internal interface of 204.68.155.248, which I am able to ping from 172.168.70.x (VLAN_ID 2). However, I cannot ping the far side of the Cisco (63.138.237.40).

Does anyone know why this would be?



2 REPLIES
Joel Belizario
Trusted Contributor
Solution

Re: ProCurve 2626

I see you have both a default gateway as well as IP routing enabled - from memory the software doesn't allow both to be enabled at the same time even though they both seem to be present in the config.

Try doing a "show ip route" and see what info comes back. It should tell you whether IP routing is enabled / disabled and what default gateway is defined.

Workaround I've used before is to setup a static route to mirror the default gateway function and leave IP routing enabled.

Perhaps NAT rules on your router are preventing the traffic from being routed back?

Re: ProCurve 2626

That was the issue. I took out the entry for the default gateway in the initial setup and entered a static route on the ProCurve for 0.0.0.0 0.0.0.0 204.68.155.0 This did the trick. I am very surprised that it does not give you some type of error when IP routing is enabled that it overrides the default gateway.

Anyway, thanks for your answer. It was very helpful.