Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

ProCurve 2650 - J4899B - VLAN routing problem

NicholasH
Occasional Visitor

ProCurve 2650 - J4899B - VLAN routing problem

The switch is running firmware H.08.86.
4 VLANS are defined and were working splendidly until today.
Today, for some reason, I can hit all of the VLAN addresses from a remote subnet, but I cannot ping any of the nodes on VLANs 2 & 3.
Communication to VLANs 1 & 8 are fine.
A node on VLAN 1 cannot even ping a node on VLAN 2, even though both are connected to the same physical switch.
From the switch, I can ping all of the nodes on any VLAN.
It appears as though the switch has suddenly decided to stop routing packets (ip routing is enabled).
I've tried dropping and re-creating the VLANs to no avail.
At this point, I'm seriously considering erasing the startup config and starting over.
Anyone ever run into this type of problem before?

2 REPLIES
Guido Ruhnau
Advisor

Re: ProCurve 2650 - J4899B - VLAN routing problem

first: ping every ipaddress local from the switch, if you cannot ping any interface, maybe a layer1-problem.
second: If you have problems with clients in a special vlan. check the default-gatewayentry of the clients.
third: check speed and autoneg of the switchports and the clients

fourth: fine stable runnig now?

cu
Guido
NicholasH
Occasional Visitor

Re: ProCurve 2650 - J4899B - VLAN routing problem

Clients on each VLAN could ping their respective default gateways.
All nodes and switchports were set to 100-full except 49 & 50 which were set to auto-1000 and were configured as a static trunk.

All nodes on VLANs 2 & 3 were DHCP-enabled and were receiving the correct configuration from the DHCP server on VLAN 1.

From the switch itself, I could ping any host and get a response. Nodes on the same VLAN could ping each other, but could intermittently ping nodes on other VLANS. On average, I was seeing 50% packet loss on the switch.
Cables were swapped with known good ones, but the porblem persisted.

I erased the startup config and rebuilt the configuration. Still no go.
As a last ditch effort, I performed the factory default reset. This also didn't quite work right. The switch retained the manager password I had assigned in the previous configuration.

I've received another 2650 J4899B switch and configured it to take the place of the offending switch and haven't encountered any problems.

The intermittently functional switch is being replaced today.