Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

ProCurve 2650 SNMP Link Up/Down

SOLVED
Go to solution
Mats P
Occasional Contributor

ProCurve 2650 SNMP Link Up/Down

Hi!

Before anything, i just wanted to say that i've searched this forum before this post and found some solutions i thought would help, but they are strangely not working for me.

I wan't to turn off the notifications about link up/down via SNMP.

In one post on this forum it was suggested that another person with the same problems should do:

setmib 1.3.6.1.2.1.16.9.1.1.3.76 -i 1
setmib 1.3.6.1.2.1.16.9.1.1.3.77 -i 1

but that didn't work for me, it still sends traps with link up/down. when i did a "walkmib eventdescription" i found:
eventDescription.333 = port %s - Loss of Link

so i tried a "setmib 1.3.6.1.2.1.16.9.1.1.3.333 -i 1" but that didn't work either. I also tried to "write memory" after the changes, and when i do "getmib" on thoose events i get:

Falu Switch 3(config)# getmib 1.3.6.1.2.1.16.9.1.1.3.76
eventType.76 = 1
Falu Switch 3(config)# getmib 1.3.6.1.2.1.16.9.1.1.3.77
eventType.77 = 1
Falu Switch 3(config)# getmib 1.3.6.1.2.1.16.9.1.1.3.333
eventType.333 = 1

so everything seems right so far.

Any suggestions on what might be wrong?

Mats
3 REPLIES
Matt Hobbs
Honored Contributor
Solution

Re: ProCurve 2650 SNMP Link Up/Down

I think you need to disable the generic link up/down trap:

Append the below OID with the ifIndex # of the port that you do not
want to generate the generic link up/down traps.

Name:â ¢ifLinkUpDownTrapEnable
Type:â ¢OBJECT-TYPE
OID:â ¢1.3.6.1.2.1.31.1.1.1.14
Full path:â ¢iso(1).org(3).dod(6).internet(1).mgmt(2).mib-
2(1).ifMIB(31).ifMIBObjects(1).ifXTable(1).ifXEntry(1).ifLinkUpDownTrapEnable(14)
Module:â ¢IF-MIB
Parent:â ¢ifXEntry
Prev sibling:â ¢ifHCOutBroadcastPkts
Next sibling:â ¢ifHighSpeed
Numerical syntax:â ¢Integer (32 bit)
Base syntax:â ¢INTEGER
Composed syntax:â ¢INTEGER
Status:â ¢current
Max access:â ¢read-write
Value list:â ¢1: enabled(1)
â ¢2: disabled(2)


So for port 1:

setmib 1.3.6.1.2.1.31.1.1.1.14.1 -i 2
Mats P
Occasional Contributor

Re: ProCurve 2650 SNMP Link Up/Down

Thank you Matt!

That did the trick!

Mats
Mats P
Occasional Contributor

Re: ProCurve 2650 SNMP Link Up/Down

I'm closing the thread now!