Switches, Hubs, and Modems

ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

 
SOLVED
Go to solution
Ulf_K
Occasional Advisor

ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

Greetings Forum.

I know - this problem has been found on the internet but most comments were made some time ago...

I am unable to log on to a 2810-24G using the web-interface. The browser (Edge or Firefox) displays the same error message: Java is not installed or blocked. It has to do with security. Solutions on the intenet suggests to use an older version of JAVA but these are all blocked for end user without a service contract by Oracle. It is IMO not an acceptable solution. Adding the assigned web-address in JAVA's security tab does not work be it "http://192.168...." or "https://192.168....". (Been there. Tried that. Did not get the T-shirt). The firmware in the switch is not the latest one but HP/HPE does not mention anything about this being fixed in V 11.78. Using the console with a terminal emulator is possible but    t  e  d  i  o  u  s ...

So the question is if any further attempts to access the web-interface are futile or if there is a fix for this?

8 REPLIES 8
akg7
HPE Pro

Re: ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

Hello @Ulf_K ,

As a workaround can you try to add the URL into JAVA exception list.?

Below article for Procurve 2610 switch but issue is similar to yours:

https://support.hpe.com/hpesc/public/docDisplay?docId=sf000049238en_us&docLocale=en_US

https://www.java.com/en/download/help/exception_sitelist.html

https://www.java.com/en/download/help/java_blocked.html

 

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
Ulf_K
Occasional Advisor

Re: ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

I did find that very document when searching for a possible solution. And that was what I tried which failed. Having spoken to a friend in the networking business, he confirmed that the JAVA problem is indeed a problem.

Managing one single switch one single time using CLI is doable butIMHO: HPE should be concerned about this.

akg7
HPE Pro

Re: ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

Hello @Ulf_K ,

 

Can you share tje device product number 'JXXXXX" and running software version?

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
Ulf_K
Occasional Advisor

Re: ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

Sorry - I don not have that switch anymore. It was returned to the seller and replaced with a V1910-24G (PoE disabled). But: then, I was unable to configure it for trunk with the 1820-48G. (Layer 2 to Layer 3...)

I have my office on the top floor where the fire wall and the internet providers fiber to ethernet modem is located. and the servers in the basement. I wanted to setup 4 trunk lines not wanting to have the Proliant servers next to my desk. It was doable and worked, but the old Zyxel GS-2024 power supply in the basement gave up.

The internet providers modem is the gateway and DHCP server at 192.168.1.1 Scope for the entire installation is 255.255.255.0 with DHCP enabled for all computers except the servers (including ILO), firewall and the switches. Static address range between 192.168.1.1 and 192,168.1.10, dynamic above.

The Firewall is a Zyxel ZyWall5 at 192.168.1.2 (Bridge mode - No DHCP!)

The HP 1820-48G is at 192.168.1.3

The HP 1910-24G was set to 192.168.1.4

Having tested DHCP relay on/off, different VLAN names for both switches and tagged/untagged ports assigned for the intended trunks. The servers at the basement could see the V1910 and use the web interface to it. The computers in my office could see and use the 1820 interface. No combination of settings could enable an internet connection tho the outside world. Sometimes, pinging across the network returned 1 out of 4 returns with a high latency. As soon as the basement switch got connected, all internet was lost.

I searched the internet for a solution in vain. Not being an IT professional, I gave up around midnight yesterday and now  I am stuck...

akg7
HPE Pro

Re: ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

Hello @UIf_K,

 

Have you checked the layer 1 status, like cables and ithers are fine?

What is the distance between FW,1910 & 1820?

Are they at feasible dustance?

 

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
Ulf_K
Occasional Advisor

Re: ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

I returned the V1910 today. Waiting for a suggestion from the vendor. If none, I would gladly take back the CLI-only switch. Although not web-configurable I have learned my lesson...

Cables are 4 x 15 meters of CAT6A (All == length). I ran a loopback test on the V1910. The internal one succeeded (of course). The external failed with an error message "Invalid configuration" (as could be expected). NB that the 4 cable trunk worked with the previous two models of switches.

The question is: What sort of Layer2 switch should I look for? With a limited budget, I always purchase second hand parts that are not to old.

The 1820-48G was easy to setup and works like a charm but the vendor I purchase from did not have any such left. I need ~ 24 ports for trunk lines, teamed NIC's and spares. It is very much desirable that the switch should be Web-configurable. No need for a serial CLI port (although I actually have the special DB9-RJ45 cable used) or separate management ETH port.

 

 

akg7
HPE Pro
Solution

Re: ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

Hello,

 

I believe Aruba 2530 or 2540 are more suitable layer 2.

 

https://www.arubanetworks.com/en-au/products/switches/access/

 

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
Ulf_K
Occasional Advisor

Re: ProCurve 2810-24G: WebGUI access denied because of JAVA incompatibility (V8-Upd301)

I managed to find another 1820-48G on the surplus market. It was successfully configured and added to my home network.  Your suggestion is added to the list of possible future purchases.

Nice to know that there are alternatives.

Thanks!