Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

ProCurve and Cisco VLANs

SOLVED
Go to solution
John Tandy
Occasional Visitor

ProCurve and Cisco VLANs

I have an HP 5304XL ProCurve switch. This switch connects to 8 Cisco 2950 switches. I have four VLANS. The Network is running Novell. The servers are connected to the procurve. All workstations can ping, and authenticate to the Servers and each other. However the VLANs cannot get a DHCP address if they are connected to the Cisco switches. If they connect directly to the HP it's fine.
Any Ideas?

Thank you,

John
6 REPLIES
Matt Hobbs
Honored Contributor

Re: ProCurve and Cisco VLANs

This may help:

http://www.hp.com/rnd/itmgrnews/technical_tips.htm

Otherwise if you could attach your running config from the 5300 and one of the 2950's (remove any sensitive info first), I'm sure someone can help you find out what's going wrong.
John Tandy
Occasional Visitor

Re: ProCurve and Cisco VLANs

2950#sh run
Building configuration...

Current configuration : 4435 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2950

ip subnet-zero
no ip finger
cluster enable mdf01 0
!
!
!
interface FastEthernet0/1
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/3
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/6
switchport trunk native vlan 2
switchport mode trunk
!
interface FastEthernet0/7
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/8
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/12
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/22
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/23
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/24
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/25
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/26
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/27
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/28
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/29
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/30
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/31
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/32
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/33
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/34
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/35
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/36
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/37
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/38
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/39
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/40
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/41
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/42
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/43
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/44
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/45
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/46
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/47
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/48
switchport access vlan 3
spanning-tree portfast
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
switchport mode trunk
!
interface Vlan1
ip address 10.25.25.241 255.255.255.0
no ip route-cache
!
ip default-gateway 10.25.25.1
ip http server
!


2950#
John Tandy
Occasional Visitor

Re: ProCurve and Cisco VLANs

Below is the config for the HP ProCurve:

5304# sh run



Running configuration:

; J4850A Configuration Editor; Created on release #E.10.23

hostname "5304"
max-vlans 25
ip access-list extended "110"
deny tcp 192.168.83.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.58.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.59.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.60.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.65.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.68.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.69.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.70.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.72.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.73.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.74.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.80.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.81.0 0.0.0.255 192.168.71.0 0.0.0.255
deny tcp 192.168.82.0 0.0.0.255 192.168.71.0 0.0.0.255
permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
module 3 type J4878B
module 2 type J4878B
module 1 type J4878B
module 4 type J4820A
interface C1
name "Townhall/PD"
exit
interface A1
name "High School"
exit
interface A2
name "Jacobs school"
exit
interface A3
name "Sewer"
exit
interface A4
name "Fire Dept. Alt."
exit
interface B1

-- MORE --, next page: Space, next line: Enter, quit: Control-C
name "Senior Center"
exit
interface B2
name "School Admin"
exit
interface B3
name "Light Plant"
exit
interface B4
name "Highway Dept"
exit
ip default-gateway 10.25.25.4
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A1,C1-C4,D2-D5,D7-D11,D13-D21
ip address 10.25.25.1 255.255.255.0
no untagged A2-A4,B1-B4,D1,D6,D12,D22-D24
ip access-group "110" in
exit
vlan 10

-- MORE --, next page: Space, next line: Enter, quit: Control-C
name "VLAN10"
untagged B1
ip address 192.168.60.1 255.255.255.0
exit
vlan 4
name "VLAN4"
untagged A4
ip address 192.168.66.1 255.255.255.0
tagged A1
exit
vlan 5
name "VLAN5"
untagged D1,D24
ip address 192.168.70.1 255.255.255.0
tagged A2,C1,D7
exit
vlan 6
name "VLAN6"
untagged A3,B3-B4
ip address 192.168.59.254 255.255.255.0
exit
vlan 11
name "VLAN11"

-- MORE --, next page: Space, next line: Enter, quit: Control-C
untagged A2
ip address 192.168.69.1 255.255.255.0
exit
vlan 12
name "VLAN12"
ip address 192.168.58.1 255.255.255.0
exit
vlan 13
name "VLAN13"
untagged B2
ip address 192.168.68.1 255.255.255.0
exit
vlan 3
name "Student"
untagged D12,D22-D23
ip address 192.168.73.254 255.255.255.0
tagged D2-D3,D7-D9,D13,D24
exit

vlan 2
name "Teacher"
untagged D6
ip address 192.168.72.254 255.255.255.0
tagged D2-D3,D7-D9,D13
exit
vlan 14
name "ADMIN_SER"
ip address 192.168.74.254 255.255.255.0
tagged D2
exit
ip authorized-managers 10.25.25.0 255.255.255.0
ip authorized-managers 10.55.55.0 255.255.255.0
ip authorized-managers 192.168.57.0 255.255.255.0
ip authorized-managers 192.168.72.0 255.255.255.0
gvrp
ip route 0.0.0.0 0.0.0.0 10.25.25.4
ip route 192.168.81.0 255.255.255.0 10.25.25.50
ip route 192.168.82.0 255.255.255.0 10.25.25.50
ip route 192.168.83.0 255.255.255.0 10.25.25.50
ip route 192.168.80.0 255.255.255.0 10.25.25.55
password operator

5304#
Mohieddin Kharnoub
Honored Contributor
Solution

Re: ProCurve and Cisco VLANs

Hi

What you need is to include the command:
IP helper-address a.b.c.d (DHCP server IP) , in each Vlan you have configured.

Good Luck !!!
Science for Everyone
John Tandy
Occasional Visitor

Re: ProCurve and Cisco VLANs

That did it. Thank you!!!!
John Tandy
Occasional Visitor

Re: ProCurve and Cisco VLANs

Mohieddin Kharnoub Aug 28, 2006 17:08:16 GMT 10 pts

--------------------------------------------------------------------------------
Hi

What you need is to include the command:
IP helper-address a.b.c.d (DHCP server IP) , in each Vlan you have configured.

Good Luck !!!