Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem setting up a VLAN

SOLVED
Go to solution
J. Rubinstein
Occasional Advisor

Problem setting up a VLAN

I am new to switch management and I have a network with over 500 machines. Currently we are running a flat network using the address range
10.82.0.0 - 10.82.7.255

We have been experiencing broadcast storms, currently being stopped by the switches broadcast-limits. I have been advised to segment the network using vlans to stop the issue.

I have begun setting this up. The current setup
; J4899B Configuration Editor; Created on release #H.10.29

hostname "ProCurve Switch 2650"
snmp-server location "Laptop Room"
web-management management-url "http://10.82.5.40:8040/rnd/device_help"
ip default-gateway 10.82.0.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-50
ip address 10.82.7.225 255.255.248.0
ip helper-address 10.82.0.2
ip proxy-arp
exit
vlan 2
name "ILA"
ip address 172.16.1.1 255.255.255.0
ip helper-address 10.82.0.2
tagged 17-32
ip proxy-arp
exit
management-vlan 1
spanning-tree
no spanning-tree 49 edge-port
no spanning-tree 50 edge-port
password manager

As a starting point I have tried pinging addresses within management console.

10.82.7.225 replies but 172.16.1.1 produces the message "Network is unreachable on this vlan".

What have I done wrong?

Thanks for any help
12 REPLIES
J. Rubinstein
Occasional Advisor

Re: Problem setting up a VLAN

Apologies for this but having reviewed an earlier thread I realise that the system doesn't activate the vlan until I connect a device to it.

The system now responds. No doubt I'll be posting other queries as I go.

Apologies for wasting peoples' time.
J. Rubinstein
Occasional Advisor

Re: Problem setting up a VLAN

Sorry to be a pain but although I can now ping 172.16.1.1 from within the management console of the switch, I have now tried to connect an XP machine to one of the vlan ports. The machine has a static ip address
172.16.1.3 subnet 255.255.255.0 default gateway 172.16.1.1. This machine cannot ping 172.16.1.1 nor, not suprisingly, anything else.

I'm sure I'm missing something simple.

Thanks for any help
Thomas Joebstl
Frequent Advisor
Solution

Re: Problem setting up a VLAN

Unless your XP machines nic is configured to use VLAN 2 as tagged VLAN you have to set the switchport to VLAN 2/untagged.
J. Rubinstein
Occasional Advisor

Re: Problem setting up a VLAN

Thanks very much for this. I have done this and now the xp machine can ping 172.16.1.1. However I now, if you have the patience got a further problem.

We have a core switch, a 5300. I have now set up the vlan on the edge switch and the core switch and can now ping from the xp machine to both the edge and core switch adresses (172.16.1.2 - edge, 172.16.1.1 - core). I have enabled ip routing on the core switch and tagged one of the server connections. However the server on 10.82.0.2 cannot ping the xp machine on 172.16.1.3. I have set up a static route on the server which enables it to ping 172.16.1.1 successfully. This suggests that the core switch is not actually doing the IP routing.

Once again thanks for any help.
Thomas Joebstl
Frequent Advisor

Re: Problem setting up a VLAN

I unfortunately never had access to anything larger than a 4140 but unless it has some "special features" (one might call them bugs) I guess the basic steps are the same:

1) setup the required VLANs and assign IP addresses on the switch
2) enable ip routing on the switch
3) configure a default gateway and any necessary static routes on the switch
4) configure each station to use the appropriate vlan ip of the switch as their default gateway
5) tell your router/firewall/whatever connects you to the internet how to reach the new subnets by adding a route back to the switch for those
J. Rubinstein
Occasional Advisor

Re: Problem setting up a VLAN

I've configured the switch as you say. The sub switch has vlan id 2 with 172.16.1.2, the core switch has ip routing enabled and 172.15.1.1. They can talk to each other without a problem on any of their ip addresses.

I don't get to configure the router although I will have to get control or get someone else to set up the routes for general connection. However for this test configuration I have set up a static route on the server so it know that to get to any address on the 172.16.1.x it goes to the core switch's 10.82.x.x address. As a result the server can ping 172.16.1.1 and get a reply. However it gets to no other 172.16.1.x addresses. Using tracert when trying to ping 172.16.1.2 it correctly goes first to the core switch, but then the signal is dropped. As far as I can see this can only be because the core switch is not routing, although it says that this is enabled.

Thomas Joebstl
Frequent Advisor

Re: Problem setting up a VLAN

Could you post/upload the configurations of both switches as well as a description which ports are used to connect them and the systems you're doing your tests with?
J. Rubinstein
Occasional Advisor

Re: Problem setting up a VLAN

The edge switch configuration is shown above except that the IP routing is now disabled and the "ILA" address is now 172.16.1.2

The core switch configuration is as follows.

hostname "Walton High Core Switch"
broadcast-limit
time daylight-time-rule None
cdp run
module 6 type J4821A
module 7 type J4821A
module 3 type J4821A
module 4 type J4821A
module 5 type J4821A
module 1 type J4878A
module 2 type J4878A
interface F1
lacp Active
exit
interface F2
lacp Active
exit
interface F3

-- MORE --, next page: Space, next line: Enter, quit: Control-C
lacp Active
exit
interface F4
lacp Active
exit
interface G1
no lacp
exit
interface G2
no lacp
exit
interface G3
no lacp
exit
interface G4
no lacp
exit
interface C1
no lacp
exit
interface C2
no lacp
exit

-- MORE --, next page: Space, next line: Enter, quit: Control-C
interface C
no lacp
exit
interface C4
no lacp
exit
interface D1
lacp Active
exit
interface D2
lacp Active
exit
interface D3
lacp Active
exit
interface D4
lacp Active
exit
interface E1
no lacp
exit
interface E2
no lacp

-- MORE --, next page: Space, next line: Enter, quit: Control-C
exit
interface E3
no lacp
exit
interface E4
no lacp
exit
interface A1
no lacp
exit
interface A2
no lacp
exit
interface A3
no lacp
exit
interface A4
no lacp
exit
interface B1
no lacp
exit
interface B2

-- MORE --, next page: Space, next line: Enter, quit: Control-C
lacp Active
exit
interface B3
no lacp
exit
interface B4
no lacp
exit
sntp server 194.66.157.12
ip routing
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
snmp-server host 10.82.1.218 "public" Not-INFO
snmp-server host 10.82.1.218 "public"
snmp-server host 10.82.5.40 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A4,B1-B2,B4,C1-C4,D1-D4,E1-E4,F1-F4,G1-G4
ip address 10.82.7.254 255.255.240.0
tagged B3
exit
vlan

-- MORE --, next page: Space, next line: Enter, quit: Control-C
name "ILA"
ip address 172.16.1.1 255.255.255.0
ip helper-address 10.82.0.2
tagged A1-A4,B1-B4,C1-C4,D1-D4,E1-E4,F1-F4,G1-G2
exit
spanning-tree
no spanning-tree A1 edge-port

Walton High Core Switch#
no spanning-tree A2 edge-port

no spanning-tree A3 edge-port

no spanning-tree A4 edge-port
no spanning-tree B1 edge-port
no spanning-tree B2 edge-port
no spanning-tree B3 edge-port
no spanning-tree B4 edge-port
no spanning-tree D1 edge-port
no spanning-tree D2 edge-port
no spanning-tree D3 edge-port
no spanning-tree D4 edge-port
no spanning-tree F1 edge-port
no spanning-tree F2 edge-port
no spanning-tree F3 edge-port
no spanning-tree F4 edge-port
no spanning-tree G1 edge-port
no spanning-tree G2 edge-port
no spanning-tree G3 edge-port
no spanning-tree G4 edge-port
spanning-tree priority 7
password manager
password operator

Thanks again for taking the time to look at this.

Jay
Thomas Joebstl
Frequent Advisor

Re: Problem setting up a VLAN

Which ports are used on each side to connect those 2 switches?
OLARU Dan
Trusted Contributor

Re: Problem setting up a VLAN

what subnet masks (SNM) do you use for your big 10.0.0.0 [255.0.0.0?] network?
J. Rubinstein
Occasional Advisor

Re: Problem setting up a VLAN

Thanks for all your help guys.

I'm going to close the thread because I have got the solution. The downstream switch was not configured to look to the core switch as it's default gateway on the 10.82.0.0 network.
J. Rubinstein
Occasional Advisor

Re: Problem setting up a VLAN

Thanks to all for their help.