Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with interconnect Vlans

Fullsuporte RR
Occasional Contributor

Problem with interconnect Vlans

Hi,

i'm trying to configure a 5406zl switch but i'm missing some step and need some help.
The config is this:
hostname "B1_CORE"
...
module 1 type J9534A
module 2 type J9535A
interface A1
name "SW1_B1_1"
...
trunk A1-A2,B1-B2 Trk1 LACP
...
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A20,A23-A24,B20,B24
ip address 201.0.0.253 255.255.255.0
tagged B21-B23,Trk1-Trk15
no untagged A21-A22
exit
vlan 10
name "WIFI_INTERNO"
untagged A21
ip address 192.168.10.254 255.255.255.0
tagged A20,B21-B23,Trk1-Trk15
exit
vlan 99
name "SWITCH_MANAGE"
untagged A22
ip address 192.168.99.254 255.255.255.0
tagged B21-B23,Trk1-Trk15
exit
ip route 0.0.0.0 0.0.0.0 201.0.0.254
...
spanning-tree
spanning-tree Trk1 priority 4
...
management-vlan 99
...

and i can't ping from A21 to A22, with the PC's in the subnet of each vlan and with the gateway of each vlan.
I use to config switch from other manufactor so i'm confused, how to put ports on VLAN's.

Can anybody help me. Why i can't ping between A21 and A22?
7 REPLIES
Ali
HPE Pro

Re: Problem with interconnect Vlans

Hi there,

check page 15 for vlan configuration
http://h40060.www4.hp.com/procurve/uk/en/pdfs/application-notes/AN-M1_ProCurve%20A4_Mobility%20Template_071608.pdf

thanks,
Aftab
I work for HP
Looking for a quick resolution to a technical issue for your HP Enterprise products? HP Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
Fullsuporte RR
Occasional Contributor

Re: Problem with interconnect Vlans

The document you sent, only shows information about wireless and ends in page 12.
Jeff Carrell
Honored Contributor

Re: Problem with interconnect Vlans

First, get this CLI ref guide, it shows how to configure HP ProVision, HP Comware5 and Cisco switches for lots of different functions, in a side-by-side comparison, so if you know one CLI, you see how to do it in a different CLI:
http://h10144.www1.hp.com/docs/training/HP-Networking-and-Cisco-CLI-Reference-Guide_June_10_WW_Eng_ltr.pdf

Next, your switch config should work on those 2 ports if the gateways on the PC's are the IP addr of the vlans on the switch and the PC's are not configured for 802.1Q (HP = tagged, Cisco/others = trunk) which I assume they probably are not.

One thing, you have a "management-vlan" config which means that if you try to ping/telnet/snmp, etc to the switch on any VLAN ohter than vlan 99, the switch will never respond. The switch will only respond on vlan 99 connected devices.

hth...Jeff
Fullsuporte RR
Occasional Contributor

Re: Problem with interconnect Vlans

Thank you for your answer.

On my search's i have found that document. I'm reading it fast cause i've to put this config, working tomorrow.

The pc's are exactly like you said, gateways to the VLAN ip address. They don't ping.

Yes the management-vlan is vlan 99, but between PC's on diferente VLAN's (i.e. vlan 1 and vlan 10) i should ping between them (pc 2 pc) without RACL's or VACL's or shouldn't?

Jeff Carrell
Honored Contributor

Re: Problem with interconnect Vlans

Fullsuporte RR said: "Yes the management-vlan is vlan 99, but between PC's on different VLAN's (i.e. vlan 1 and vlan 10) i should ping between them (pc 2 pc) without RACL's or VACL's or shouldn't?"

Yes they should. Hmmm...you might try disabling the 'management-vlan 99' function and see if anything changes.

At that point any PC on any vlan should be able to ping the switch on its connected vlan as well.

As you know, this is a very plain config, I'm not sure why it's not working for you.

hth...Jeff
PCurver
Advisor

Re: Problem with interconnect Vlans

That's true, you can never route into or out of a management VLAN. That's the beauty and security of a management VLAN.
Fullsuporte RR
Occasional Contributor

Re: Problem with interconnect Vlans

Everything solved!
The managemente vlan was the problem.
Thank you to all!