Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with ports blocked by STP and/or LACP (ProCurve 2800)

SOLVED
Go to solution
jamesps
Regular Advisor

Problem with ports blocked by STP and/or LACP (ProCurve 2800)

Hello everyone,

I have a problem with some of my ProCurve ports being blocked by STP. Is there an explanation for this?

Here's my setup: I have 4 ProCurve 2800 switches. Switch A and B are LACP active trunked. Switch C and D are also LACP active trunked. Switch A and C are linked via 1000SX. Switch B and D are also linked via 1000SX. My loop is completed. I have enabled STP on all of them with the default settings. Everything seems to work ok until a certain point where some of the ports are getting blocked by STP and/or LACP. These ports all go in a router.

Any ideas on how to eliminate this?

Thanks in advance!
3 REPLIES
jamesps
Regular Advisor

Re: Problem with ports blocked by STP and/or LACP (ProCurve 2800)

I forgot to add that all the switches are identical, same OS, same Boot ROM. They are configured as a stack.
Thomas Bianco
Honored Contributor
Solution

Re: Problem with ports blocked by STP and/or LACP (ProCurve 2800)

STP, or Spanning Tree Protocol, is designed to eliminate switching loops by making sure each switch has only one path to every other switch. LCAP, or Link Aggregation Control Protocol, is designed to create redundant aggregate connections between switches and servers. these are mutually exclusive goals

the method goes a bit like this: each switch sends an STP announcement on all ports. clients ignore the STP packet, where as other switches count the various packets and determine if there are 2 paths to the same switch via any ports. if there is a loop, the switch will disable one of these ports* to prevent packets being sent in an infinite loop. if you've enabled STP on a LACP link, one of the ports will be Blocked, as it is a redundant connection.

you'll want to disable STP for the ports involved in the LCAP link.

*if i remember correctly, the highest cost, longest distance, or most recently connected port is disabled, in that order of preference.
There have been Innumerable people who have helped me. Of course, I've managed to piss most of them off.
jamesps
Regular Advisor

Re: Problem with ports blocked by STP and/or LACP (ProCurve 2800)

It makes sense. I have not touched the STP settings. I believe I can't do it anyway since I am using a dynamic LACP trunk. I would have to convert it to static and disable the STP advertising on trunk's ports afterwards. I will give that a try.

Thanks!
james