Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 2848 Vlan a routing

Noel De Sousa
Occasional Advisor

Procurve 2848 Vlan a routing

I have two procurve 2848. We trunked 4 ports together and now would like to create vlans that will segment our network.

my default segment is 192.168.120.0/24 the router is on 192.168.120.254.

we like to have 4 more Vlans 192.168.121.0/24 (for wireless), 192.168.122.0/24 (for client acces), 192.168.123.0/24 (for client access), and 192.168.124.0/24 ( for Voip)

how do i setup the routing? Also, the 192.168.121.0/24 should only have access to the internet.
10 REPLIES
Mohammed Faiz
Honored Contributor

Re: Procurve 2848 Vlan a routing

Hi,

The steps are :

- Create the VLANs

- Add an IP to each of the VLANs on the switch e.g. "vlan 2 ip add 192.168.121.1/24"

- Add the helper address for your DHCP server to the VLAN : "vlan 2 ip helper address 192.168.xxx.xxx"

- enable routing : "ip routing"
Noel De Sousa
Occasional Advisor

Re: Procurve 2848 Vlan a routing

should each vlan have a gateway for its segment?

Example, IP: 192.168.121.1/24 Sub Net: 255.255.255.0 Gateway: 192.168.121.254

Mohammed Faiz
Honored Contributor

Re: Procurve 2848 Vlan a routing

Hi,

I'm not quite sure on what you mean, so I'll give you both answers :)

Each VLAN will have a default gateway which will be the IP that you assign to the switch on that VLAN.
e.g.
Host_A = 192.168.121.20 (VLAN 2)
Default Gateway for Host_A = 192.168.121.254
Switch has "vlan 2 ip add 192.168.121.254/24"

If you are talking about the default gateway on the switch then no, you can only assign one default gateway to the switch (and it doesn't live in the VLAN context). The default gateway on the switch should be the for the management IP on the switch, i.e. if the IP that you manage the switch on was 192.168.121.10 you would set "ip default-gateway 192.168.121.254"
Mohammed Faiz
Honored Contributor

Re: Procurve 2848 Vlan a routing

Oh and to do this:

> Also, the 192.168.121.0/24 should only have
> access to the internet.

you will need an ACL on that VLAN.
Noel De Sousa
Occasional Advisor

Re: Procurve 2848 Vlan a routing

for the Voip segment how do I set it up for all the client access ports?
Noel De Sousa
Occasional Advisor

Re: Procurve 2848 Vlan a routing

OK
nothing is working now!!!!!!

this is what I have 2 procurve 2848.

they are setup on 192.168.120.5/24 and 192.168.120.6/24.

We need to trunked 6 ports together.
Port 39-44

We need IP routing enable

We need DHCP helper

we need the follow:
Server = VLAN 1 "192.168.120.0/24"
port 1 = router unlink switch 1
port 2-33 switch 1
port 1-33 switch 2

Wireless = VLAN 121 "192.168.121.0/24"
port 34 switch 1
poer 34 switch 2

Client1 = VLAN 122 "192.168.122.0/24"
Port 35 switch 1
Port 35 switch 2

Client2 = VLAN 123 "192.168.123.0/24"
Port 36 switch 1
port 36 switch 2

Service = VLAN 124 "192.168.124.0/24"
Port 37 switch 1
Port 37 switch 2

Voip = VLAN 125 "192.168.125.0/24"
Port on port 35 - 36 switch 1
Port on port 35 - 36 switch 2

I need ACL on the
Wireless = VLAN 121 "192.168.121.0/24"
port 34 switch 1
poer 34 switch 2
to only go to the internet
Mohammed Faiz
Honored Contributor

Re: Procurve 2848 Vlan a routing

Hi,

It would be quicker to post up you current configs and we can take a look at those.
Noel De Sousa
Occasional Advisor

Re: Procurve 2848 Vlan a routing

config on sw 1
hostname "########"
time timezone -5
interface 39
flow-control
speed-duplex auto-1000
no lacp
exit
interface 40
flow-control
speed-duplex auto-1000
no lacp
exit
interface 41
flow-control
speed-duplex auto-1000
no lacp
exit
interface 42
flow-control
speed-duplex auto-1000
no lacp
exit
interface 43
flow-control
speed-duplex auto-1000
no lacp
exit
interface 44
flow-control
speed-duplex auto-1000
no lacp
exit
trunk 39-44 Trk1 Trunk
ip default-gateway 192.168.120.254
ip routing
snmp-server community "######" Unrestricted
vlan 1
name "Server"
ip address 192.168.120.6 255.255.255.0
tagged 1-38,45-48,Trk1
vlan 121
name "Wireless"
untagged 45-46
ip address 192.168.121.254 255.255.255.0
exit
vlan 122
name "Client1"
ip address 192.168.122.254 255.255.255.0
exit
vlan 123
name "Client2"
ip address 192.168.123.254 255.255.255.0
exit
vlan 125
name "VOIP"
ip address 192.168.125.254 255.255.255.0
exit
vlan 124
name "Service"
ip address 192.168.124.254 255.255.255.0
exit
stack commander "CORE"
stack member 1 mac-address 00156041f3c0
spanning-tree Trk1 priority 4
Noel De Sousa
Occasional Advisor

Re: Procurve 2848 Vlan a routing

config sw 2
hostname "@@@@@@@"
time timezone -5
interface 39
flow-control
speed-duplex auto-1000
no lacp
exit
interface 40
flow-control
speed-duplex auto-1000
no lacp
exit
interface 41
flow-control
speed-duplex auto-1000
no lacp
exit
interface 42
flow-control
speed-duplex auto-1000
no lacp
exit
interface 43
flow-control
speed-duplex auto-1000
no lacp
exit
interface 44
flow-control
speed-duplex auto-1000
no lacp
exit
trunk 39-44 Trk1 Trunk
ip default-gateway 192.168.120.254
ip routing
snmp-server community "@@@@@@" Unrestricted
vlan 1
name "Server"
ip address 192.168.120.5 255.255.255.0
no untagged 1-38,45-48,Trk1
exit
vlan 121
name "Wireless"
untagged 1-38,45-48,Trk1
ip address 192.168.121.253 255.255.255.0
exit
vlan 122
name "Client1"
ip address 192.168.122.253 255.255.255.0
tagged Trk1
exit
vlan 123
name "Client2"
ip address 192.168.123.253 255.255.255.0
tagged Trk1
exit
vlan 124
name "Service"
ip address 192.168.124.253 255.255.255.0
tagged Trk1
exit
vlan 125
name "VOIP"
ip address 192.168.125.253 255.255.255.0
tagged Trk1
exit
stack join 001560018300
spanning-tree Trk1 priority 4
Noel De Sousa
Occasional Advisor

Re: Procurve 2848 Vlan a routing

this is the configuration from both Switches:
Running configuration:

; J4904A Configuration Editor; Created on release #I.10.77

hostname "NJHQSWSVR1"
time timezone -5
console baud-rate 115200
interface 37
no lacp
exit
interface 38
no lacp
exit
interface 39
no lacp
exit
interface 40
no lacp
exit
interface 41
no lacp
exit
interface 42
no lacp
exit
interface 43
no lacp
exit
interface 44
no lacp
exit
trunk 37-44 Trk1 LACP
ip default-gateway 192.168.120.254
ip routing
snmp-server community "GloryHQ" Unrestricted
vlan 1
name "Server"
untagged 1-36,45-48,Trk1
ip address 192.168.120.5 255.255.255.0
ip helper-address 192.168.120.213
exit
vlan 121
name "Wireless"
ip address 192.168.121.254 255.255.255.0
ip helper-address 192.168.120.213
tagged 32,Trk1
exit
vlan 122
name "Client1"
ip address 192.168.122.254 255.255.255.0
ip helper-address 192.168.120.213
tagged 33,Trk1
exit
vlan 123
name "Client2"
ip address 192.168.123.254 255.255.255.0
ip helper-address 192.168.120.213
tagged 34,Trk1
exit
vlan 125
name "VOIP"
ip address 192.168.125.254 255.255.255.0
ip helper-address 192.168.120.213
tagged 33-34,36,Trk1
exit
vlan 124
name "Service"
ip address 192.168.124.254 255.255.255.0
ip helper-address 192.168.120.213
tagged 35,Trk1
exit
stack commander "CORE"
stack auto-grab
stack member 1 mac-address 00156041f3c0
spanning-tree Trk1 priority 4


******

Running configuration:

; J4904A Configuration Editor; Created on release #I.10.77

hostname "NJHQSWSRV2"
time timezone -5
interface 37
no lacp
exit
interface 38
no lacp
exit
interface 39
no lacp
exit
interface 40
no lacp
exit
interface 41
no lacp
exit
interface 42
no lacp
exit
interface 43
no lacp
exit
interface 44
no lacp
exit
trunk 37-44 Trk1 LACP
ip default-gateway 192.168.120.254
ip routing
snmp-server community "GloryHQ" Unrestricted
vlan 1
name "Server"
untagged 1-36,45-48,Trk1
ip address 192.168.120.6 255.255.255.0
ip helper-address 192.168.120.213
exit
vlan 121
name "Wireless"
ip address 192.168.121.253 255.255.255.0
ip helper-address 192.168.120.213
tagged 32,Trk1
exit
vlan 122
name "Client1"
ip address 192.168.122.253 255.255.255.0
ip helper-address 192.168.120.213
tagged 33,Trk1
exit
vlan 123
name "Client2"
ip address 192.168.123.253 255.255.255.0
ip helper-address 192.168.120.213
tagged 34,Trk1
exit
vlan 124
name "Service"
ip address 192.168.124.253 255.255.255.0
ip helper-address 192.168.120.213
tagged 35,Trk1
exit
vlan 125
name "VOIP"
ip address 192.168.125.253 255.255.255.0
ip helper-address 192.168.120.213
tagged 33-34,36,Trk1
exit
stack join 001560018300
spanning-tree Trk1 priority 4