Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 2848 routing?

Mark E Wilson
Occasional Visitor

Procurve 2848 routing?

We have two buildings connected via fibre. Each building has two Procurve 2848’s. Currently there are two Vlans set-up (one for each building), and everything seems to be working properly.

However, I would like to create a third Vlan in building #2. This Vlan would need to access all network resources in both buildings, but would have a separate internet connection. The two existing Vlans share a T1 connection (located in building #1), and I would like a third Vlan to use a cable connection located in building #2. I have an extra 2848 that could be used, but I would prefer not to use the additional switch.

Any suggestions on the “best” way to accomplish this would be greatly appreciated.

Building # 1 Switch:

cdp run
mirror-port 1
interface 38
no lacp
exit
interface 45
no lacp
exit
interface 46
no lacp
exit
trunk 45-46 Trk1 Trunk
ip default-gateway 192.168.1.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "TFC"
untagged 1-44,47,Trk1
ip address 192.168.1.1 255.255.255.0
ip helper-address 192.168.1.22
tagged 48
ip proxy-arp
exit
vlan 2
name "CORP"
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.1.22
tagged 48
ip proxy-arp
exit
interface 2-44,47-48
monitor
exit
fault-finder bad-driver sensitivity low
fault-finder bad-transceiver sensitivity low
fault-finder bad-cable sensitivity low
fault-finder too-long-cable sensitivity low
fault-finder over-bandwidth sensitivity low
fault-finder broadcast-storm sensitivity low
fault-finder loss-of-link sensitivity low
fault-finder duplex-mismatch-HDx sensitivity low
fault-finder duplex-mismatch-FDx sensitivity low
ip route 0.0.0.0 0.0.0.0 192.168.1.2
no stack
spanning-tree Trk1 priority 4
ip ssh version 1-or-2
password manager
password operator

TFC2848one# show ip rout

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
0.0.0.0/0 192.168.1.2 1 static 1 1
127.0.0.0/8 reject static 0 250
127.0.0.1/32 lo0 connected 0 0
192.168.1.0/24 TFC 1 connected 0 0
192.168.2.0/24 CORP 2 connected 0 0


building #2 switch:

cdp run
interface 17
speed-duplex 100-half
exit
interface 45
no lacp
exit
interface 46
no lacp
exit
trunk 45-46 Trk1 Trunk
ip default-gateway 192.168.2.1
snmp-server community "adex" Unrestricted
vlan 1
name "TFC"
ip address 192.168.1.3 255.255.255.0
tagged 48
no untagged 1-44,47,Trk1
exit
vlan 2
name "CORP"
untagged 1-44,47,Trk1
ip address 192.168.2.3 255.255.255.0
tagged 48
exit
no stack
spanning-tree Trk1 priority 4
ip ssh version 1-or-2
password manager
password operator

corp2848one# show ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
0.0.0.0/0 192.168.2.1 2 static 0 250
127.0.0.0/8 reject static 0 250
127.0.0.1/32 lo0 connected 0 0
192.168.1.0/24 TFC 1 connected 0 0
192.168.2.0/24 CORP 2 connected 0
1 REPLY
Pieter 't Hart
Honored Contributor

Re: Procurve 2848 routing?

- create the third vlan
- tag the vlan on the ports that connect the two switches.
- DON't give the switch that does the routing an ip-adress in this vlan.
- untag a port in this vlan
- connect your separate internet router to this port
- untag ports for this vlan as necessary.

hth
Pieter