Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 2910 not learning mac addresses

Procurve 2910 not learning mac addresses

We have 2 stacked 2910 switches, ip routing is disabled and RSTP enabled. Problem we have is that the mac address tables are empty. No errors are logged on the switches.
16 REPLIES

Re: Procurve 2910 not learning mac addresses

We plan to update the firmware today to see if this makes any difference. Strange thing there are no mac addresses at all in the table.
zmichl
Advisor

Re: Procurve 2910 not learning mac addresses

What command do you use to show the arp table?

Re: Procurve 2910 not learning mac addresses

for the arp table, "show arp"
for the mac address list "show mac-address"
zmichl
Advisor

Re: Procurve 2910 not learning mac addresses

and a 'show mac-address all' gives you no mac-addresses?

Re: Procurve 2910 not learning mac addresses

yes, that's correct. we also experience some performance issues which I think are related.
zmichl
Advisor

Re: Procurve 2910 not learning mac addresses

This sounds strange, if the switch has not been misconfigured by someone...

However, you should ensure that learning mode is "continous" on all ports: ' port-security all learn-mode continuous'.

If that doesnt help, can you post the switch config?

Re: Procurve 2910 not learning mac addresses

I already checked the last, all are in continuous mode. I'll post the config.
zmichl
Advisor

Re: Procurve 2910 not learning mac addresses

You could also try to reset the arp-age setting back to the default: "ip arp-age 20"

Re: Procurve 2910 not learning mac addresses

I indeed changed the default arp age to 5 minutes. I'll change it back to 20, to test, but can you please explain why I should change it back?

Re: Procurve 2910 not learning mac addresses

both arp and mac age were configured to 5 minutes. I have changed them back to defaults, let you know the results
zmichl
Advisor

Re: Procurve 2910 not learning mac addresses

Sry, I always mix up arp-age and mac-age on the switches.
Of course I mean you should change mac-agetime instead of arp-age :)

Re: Procurve 2910 not learning mac addresses

ah, ok, mac age time was already on default value, only the arp age time was modified.

Re: Procurve 2910 not learning mac addresses

Here's the config of one of the switches;
; J9145A Configuration Editor; Created on release #W.14.38

hostname "####"
time timezone 60
time daylight-time-rule Western-Europe
module 1 type J9145A
module 2 type J9165A
module 3 type J9165A
stack commander "####"
stack auto-grab
stack member 1 mac-address 0024A8E302C0
##interface configs removed##
trunk A1,B1 Trk50 LACP
ip default-gateway ####
vlan 1
name "Management"
untagged 1
qos priority 7
ip address ####
tagged Trk50
no untagged 2-24
exit
vlan 16
name "###"
untagged 2-3,7,9-10,12,15-16,Trk50
ip address ####
tagged 4-5
exit
vlan 2
name "###"
untagged 20-24
tagged Trk50
no ip address
exit
vlan 4
name "###"
untagged 6,8,18-19
no ip address
exit
vlan 3
name "###"
no ip address
exit
vlan 5
name "DMZ"
tagged 4-5,11,13-14,17,Trk50
no ip address
exit
vlan 1016
name "###"
tagged 4-5,11,13-14,17,Trk50
no ip address
exit
vlan 101
name "Temporary vlan"
no ip address
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
instrumentation monitor mac-moves med
instrumentation monitor mac-address-count med
instrumentation monitor learn-discards med
instrumentation monitor pkts-to-closed-ports med
instrumentation monitor ip-address-count med
instrumentation monitor arp-requests med
instrumentation monitor system-resource-usage med
instrumentation monitor login-failures med
instrumentation monitor port-auth-failures med
instrumentation monitor system-delay med
instrumentation monitor log
logging #####
qos queue-config 2-queues
timesync sntp
sntp unicast
sntp 60
sntp server priority 1 ####
ip timep manual #### interval 5
snmp-server community "public" unrestricted
snmp-server host #### "public" all
snmp-server host #### "public" all
snmp-server trap-source ####
snmp-server contact ###
spanning-tree
no spanning-tree 1 auto-edge-port
spanning-tree 1 root-guard
spanning-tree Trk50 priority 4
spanning-tree priority 1 force-version rstp-operation
primary-vlan 16

Re: Procurve 2910 not learning mac addresses

reloaded the switches on firmware 14.49 solved the issue. Thanks for all reply's
zmichl
Advisor

Re: Procurve 2910 not learning mac addresses

I updates from .38 to .49 a few days ago, but I never had these problems. However, there is some strange behaviour on procurve stuff sometimes :)

Re: Procurve 2910 not learning mac addresses

Yeah I agree with that, hopefully it does not happen again, don't like switches converting to a hub ;-). Thanks for your support.