Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 4000M not setting clock

SOLVED
Go to solution
Ben Hardman
Occasional Contributor

Procurve 4000M not setting clock

I have an issue with several 4000M's that will not set their clock. They are still showing 1990. Any ideas? Thanks in advance
6 REPLIES
Ron Kinner
Honored Contributor
Solution

Re: Procurve 4000M not setting clock

I assume you are talking about automatically via NTP or timep and not manually?

What version of code are you running?

These beasts like to use something called timep to find the time instead of NTP so you either need to have one of their funky timep servers or you need to have the newer code so you can tell it to use NTP (they call it SNTP which is a simple version of NTP but works with NTP servers). See page 42 & 43 of ftp://ftp.hp.com/pub/networking/software/59692375-e4.pdf
which says you need C.09.xx to run SNTP. You can get the latest code at:

http://www.hp.com/rnd/software/switches.htm


Ron
Stuart Teo
Trusted Contributor

Re: Procurve 4000M not setting clock

Ben,

4000m has both timep and sntp implemented. You can use either one of the protocol to get time for the switch. Do you have a server set up to vend time?
If a problem can be fixed, there's nothing to worry. If a problem can't be fixed, worrying ain't gonna help. Bottom line: don't worry.
Ben Hardman
Occasional Contributor

Re: Procurve 4000M not setting clock

Yes, our domain controller is running as the NNTP server. The 4000's all have the latest firmware. However I do not see a setting in the telnet menu for setting a NNTP server or manually setting the time. Am I just blind?
Ron Kinner
Honored Contributor

Re: Procurve 4000M not setting clock

From the Main Menu
2. Switch Management...
1.IP Configuration
E
Use Spacebar to select SNTP then the down arrow to get to the SNTP Mode field. Then the Spacebar to select Unicast then the right arrow key to the Server Address field. Type int he Server Address.

The manual says you have to first set the Time mode to SNTP UNICAST before it will give you the option of setting a server.

Press Enter then S to save your changes.


To set the Time manually you have to go to the command line..Page 4-14 (68 0f 304) in the basic manual ftp://ftp.hp.com/pub/networking/software/59692320.pdf

Main Menu
5. Diagnostics
4. Command Line

the command is:

time 12:55:00
(Expect it uses a 24 hour clock)
or
date 05/26/04
exit

Ron



Ron Kinner
Honored Contributor

Re: Procurve 4000M not setting clock

forgot to mention. You should probably set the time and date manually so that it is very close to the server's time. Sometimes ntp will not work if the delta is too great.

Ron
Stuart Teo
Trusted Contributor

Re: Procurve 4000M not setting clock

AFAIK, the 4000m's ntp implementation works even though the time delta is great. :)
If a problem can be fixed, there's nothing to worry. If a problem can't be fixed, worrying ain't gonna help. Bottom line: don't worry.