Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 4104GL DHCP Relay Problem

SOLVED
Go to solution
Richard Horton G3XWH
Occasional Advisor

Procurve 4104GL DHCP Relay Problem

Have VLAN1 using IP subnet 192.168.0.0 mask 255.255.252.0 and VLAN2 subnet 10.0.0.0 mask 255.255.255.0 with VLAN1 port on switch to Windows 2003 DHCP server IP 192.168.3.2 which has a DHCP scope for each range. On switch have set up CLI commands ip routing, dhcp-relay, vlan1 helper-address 192.168.3.2 and vlan2 the same helper address. On the 10.0.0.0 subnet I can only get an address via dhcp if I add a link from a VLAN2 port to a second card on the server with a 10.0.0.240 address. What am I missing please?
17 REPLIES
cenk sasmaztin
Honored Contributor

Re: Procurve 4104GL DHCP Relay Problem

unnecessry second ethernet card on server

your dhcp server have 192.168.3.2 address and connect vlan 1 untagged interface

ip routing enable on switch
and ip helper command necessary only vlan 2

your dhcp server default gateway address must have vlan 1 ip address for dhcp relay

please send me sh run print
cenk

Richard Horton G3XWH
Occasional Advisor

Re: Procurve 4104GL DHCP Relay Problem

Thanks cenk. Here is the output:-
Running configuration: ; J4887A Configuration Editor; Created on release #G.07.99 hostname " HP Procurve" snmp-server contact "Richard Horton G3XWH" time daylight-time-rule Western-Europe cdp run mirror-port C9 module 3 type J4892A module 1 type J4908A module 4 type J4893A module 2 type J4893A interface C1 no lacp exit interface C2 no lacp exit interface C3 no lacp exit interface C4 no lacp exit interface C5 no lacp exit interface C6 no lacp exit interface C7 no lacp exit interface C8 no lacp exit interface C9 no lacp exit interface C10 no lacp exit interface C11 no lacp exit interface C12 no lacp exit interface A1 no lacp exit interface A2 no lacp exit interface A3 no lacp exit interface A4 no lacp exit interface A5 no lacp exit interface A6 no lacp exit interface A7 no lacp exit interface A8 no lacp exit interface A9 no lacp exit interface A10 no lacp exit interface A11 no lacp exit interface A12 no lacp exit interface A13 no lacp exit interface A14 no lacp exit interface A15 no lacp exit interface A16 no lacp exit interface A17 no lacp exit interface A18 no lacp exit interface A19 no lacp exit interface A20 no lacp exit interface A21 no lacp exit interface A22 no lacp exit interface D1 no lacp exit interface D2 no lacp exit interface D3 no lacp exit interface D4 no lacp exit interface D5 no lacp exit interface D6 no lacp exit interface B1 no lacp exit interface B2 no lacp exit interface B3 no lacp exit interface B4 no lacp exit interface B5 no lacp exit interface B6 no lacp exit sntp server 192.168.3.2 ip routing timesync sntp sntp unicast snmp-server community "public" Unrestricted snmp-server host 192.168.3.1 "public" snmp-server host 192.168.3.6 "public" vlan 1 name "MAIN_VLAN" forbid A4 untagged A1-A3,A5,A7-A13,A17-A22,B1-B6,C1-C12,D1-D6 ip address 192.168.1.6 255.255.252.0 ip helper-address 192.168.3.2 no untagged A4,A6,A14-A16 exit vlan 2 name "TS" forbid A5,A8 untagged A4,A6,A14-A16 ip helper-address 192.168.3.2 tagged A1,A9-A10,A20,B2,B4-B5,C2,C10,D1-D4 exit fault-finder bad-driver sensitivity high fault-finder bad-transceiver sensitivity high fault-finder bad-cable sensitivity high fault-finder too-long-cable sensitivity high fault-finder over-bandwidth sensitivity high fault-finder broadcast-storm sensitivity high fault-finder loss-of-link sensitivity high password manager
cenk sasmaztin
Honored Contributor

Re: Procurve 4104GL DHCP Relay Problem

hi Richard

please send me correctly written sh run print
cenk

Richard Horton G3XWH
Occasional Advisor

Re: Procurve 4104GL DHCP Relay Problem

Hi,

I am not sure what you mean by a "correctly written sh run print". I follwed the instructions in my manual to produce this. Am not an expert on switches so you will have to help me to produce what you need by perhaps giving some syntax?

Thanks,

Richard
cenk sasmaztin
Honored Contributor

Re: Procurve 4104GL DHCP Relay Problem

connect switch hyper terminal or terminal emulator program for example teraterm

and write

#show run

command

and copy and paste in wordpad doc your config files
cenk

Richard Horton G3XWH
Occasional Advisor

Re: Procurve 4104GL DHCP Relay Problem

Hope this is OK - Richard
HP J4887A ProCurve Switch 4104GL
Software revision G.07.99
Copyright (C) 1991-2006 Hewlett-Packard Co. All Rights Reserved.
RESTRICTED RIGHTS LEGEND
Use, duplication, or disclosure by the Government is subject to restrictions
as set forth in subdivision (b) (3) (ii) of the Rights in Technical Data and
Computer Software clause at 52.227-7013.
HEWLETT-PACKARD COMPANY, 3000 Hanover St., Palo Alto, CA 94303
Username: Administrator
Password:
HP Procurve# show run
Running configuration:
; J4887A Configuration Editor; Created on release #G.07.99
hostname " HP Procurve"
snmp-server contact "Richard Horton G3XWH"
time daylight-time-rule Western-Europe
cdp run
mirror-port C9
module 3 type J4892A
module 1 type J4908A
module 4 type J4893A
module 2 type J4893A
interface C1
no lacp
exit
interface C2
no lacp
exit
interface C3
no lacp
exit

interface C4
no lacp
exit
interface C5
no lacp
exit
interface C6
no lacp
exit
interface C7
no lacp
exit
interface C8
no lacp
exit
interface C9
no lacp
exit
interface C10
no lacp
exit
interface C11
no lacp

exit
interface C12
no lacp
exit
interface A1
no lacp
exit
interface A2
no lacp
exit
interface A3
no lacp
exit
interface A4
no lacp
exit
interface A5
no lacp
exit
interface A6
no lacp
exit
interface A7

no lacp
exit
interface A8
no lacp
exit
interface A9
no lacp
exit
interface A10
no lacp
exit
interface A11
no lacp
exit
interface A12
no lacp
exit
interface A13
no lacp
exit
interface A14
no lacp
exit

interface A15
no lacp
exit
interface A16
no lacp
exit
interface A17
no lacp
exit
interface A18
no lacp
exit
interface A19
no lacp
exit
interface A20
no lacp
exit
interface A21
no lacp
exit
interface A22
no lacp

exit
interface D1
no lacp
exit
interface D2
no lacp
exit
interface D3
no lacp
exit
interface D4
no lacp
exit
interface D5
no lacp
exit
interface D6
no lacp
exit
interface B1
no lacp
exit
interface B2

no lacp
exit
interface B3
no lacp
exit
interface B4
no lacp
exit
interface B5
no lacp
exit
interface B6
no lacp
exit
sntp server 192.168.3.2
ip routing
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
snmp-server host 192.168.3.1 "public"
snmp-server host 192.168.3.6 "public"
vlan 1
name "MAIN_VLAN"

forbid A4
untagged A1-A3,A5,A7-A13,A17-A22,B1-B6,C1-C12,D1-D6
ip address 192.168.1.6 255.255.252.0
ip helper-address 192.168.3.2
no untagged A4,A6,A14-A16
exit
vlan 2
name "TS"
forbid A5,A8
untagged A4,A6,A14-A16
ip helper-address 192.168.3.2
tagged A1,A9-A10,A20,B2,B4-B5,C2,C10,D1-D4
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
password manager
HP Procurve#
EckerA
Respected Contributor

Re: Procurve 4104GL DHCP Relay Problem

hi,
for the dhcprelay to work, you need an ip address in vlan 2. Without an ip the routing doesn't work.
hth
alex
Richard Horton G3XWH
Occasional Advisor

Re: Procurve 4104GL DHCP Relay Problem

Hi Alex,

Thanks. I have now added a 10.0.0.252 IP address to this VLAN2 (TS) under the IP configuration tab but without the second 10. range card active in the server it still is not getting the 10. DHCP addresses allocated.

Richard
cenk sasmaztin
Honored Contributor

Re: Procurve 4104GL DHCP Relay Problem

which port connect your dhcp server
cenk

serpel
Trusted Contributor

Re: Procurve 4104GL DHCP Relay Problem

hi,
what is the dgw of the dhcp-server, it should be 192.168.1.6.
hth
alex
Richard Horton G3XWH
Occasional Advisor

Re: Procurve 4104GL DHCP Relay Problem

Hi Alex,

That did the trick and it is now working. Very many thanks for your patient help on this issue.

Richard
Richard Horton G3XWH
Occasional Advisor

Re: Procurve 4104GL DHCP Relay Problem

Alex,

Another question. Can I use a similar method to provide a DNS service over the 10. range from the 192. server?

Thanks,

Richard
Richard Horton G3XWH
Occasional Advisor

Re: Procurve 4104GL DHCP Relay Problem

Alex,

Found it in the scope options of DHCP and set it to the 192 DHCP adddress and its fine.

Richard
Richard Horton G3XWH
Occasional Advisor

Re: Procurve 4104GL DHCP Relay Problem

Alex,
We have just found a problem with making the switch the default gateway on the server. Before it was the ISA server 192.168.3.200 and now it is 192.168.1.6 with the default gateway on the switch 192.168.3.200 Two web applications on another server 192.168.3.6 now run VERY slowly but are fine when we set the FRDC gateway back to .200. Any ideas?

Thanks,

Richard
serpel
Trusted Contributor
Solution

Re: Procurve 4104GL DHCP Relay Problem

you need a static route like this:

ip route 0.0.0.0 0.0.0.0 192.168.3.200

hth
alex
Richard Horton G3XWH
Occasional Advisor

Re: Procurve 4104GL DHCP Relay Problem

Alex,

That works fine now. I thought the gateway address on the switch would do the same thing but clearly not. Many thanks again for your help.

Richard
serpel
Trusted Contributor

Re: Procurve 4104GL DHCP Relay Problem

hi,
if you enable routing the configuration of the default gateway remains, but has no meaning at all. the default gateway configuration is needed for the management of the switch from different subnets and only if the switch is L2 only.
hth
alex