Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 4104gl ip routing problem

Nikolaj Jøker
Occasional Advisor

Procurve 4104gl ip routing problem

hello,
I have difficulties getting the switch to do basic routing/L3 forwarding.

I just want the switch to route/forward traffic to subnet 10.1.28.0 255.255.252.0 via gateway 10.30.1.3 (a firewall)

The 0.0.0.0 route til 10.30.1.2 (firewall) works fine.

Both firewalls are on the 10.30.1.0/24 subnet.

I have made similar config on ProCurve 2848 switches, without any problems.

Help appreciated....

Config is this:

hostname "HP ProCurve Switch 4104GL"
snmp-server location "serverrum 5. sal"
cdp run
module 1 type J4862B
module 2 type J4862B
module 3 type J4908A
module 4 type J4908A
interface C6
speed-duplex auto-1000
exit
interface C15
speed-duplex auto-1000
exit
interface C21
speed-duplex 1000-full
exit
interface C22
speed-duplex 1000-full
exit

ip default-gateway 0.0.0.0
ip routing
snmp-server host 192.168.111.1 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B24,C1-C22,D1-D6,D8-D22
ip address 10.30.1.1 255.255.255.0
no untagged D7
exit
ip route 0.0.0.0 0.0.0.0 10.30.1.2
ip route 10.1.28.0 255.255.252.0 10.30.1.3
spanning-tree Dyn1 priority 4
password manager
password operator
3 REPLIES
RonniDK
Advisor

Re: Procurve 4104gl ip routing problem

As I understand you, the firewall is also the router?

If so you should be able to remove:
ip routing
ip default-gateway
ip route 0.0.0.0 ...
ip route 10.1.28.0 ...

Then on your firewall/router you should make the appropriate routes.

---- Off-topic in danish ----
Hvis routing er det eneste du mangler, ville jeg anbefale dig at kigge på din VLAN konfiguration. Normalt lægger man ikke noget som helst i VLAN 1 (Default VLAN), idet det swithces i software og ikke hardware. Ligeledes anvendes det af switchen selv til VTP, STP mm.
Nikolaj Jøker
Occasional Advisor

Re: Procurve 4104gl ip routing problem


I want the 4104gl switch to be default gateway for my LAN (10.30.1.0/24).
The two firewalls are gateways. One to Internet and one to 10.1.28.0/22 subnet.

I need the 4104 gl to do the routing, hence the 0.0.0.0 route to 10.30.1.2 and the 10.1.28.0/22 route to 10.30.1.3
Both gateways are on VLAN1.

Only the 0.0.0.0 route on 4104gl works. Traffic from LAN to 10.1.28.0 isn't forwarded to 10.30.1.3, it also ends up at 10.30.1.2 gateway.
RonniDK
Advisor

Re: Procurve 4104gl ip routing problem

Okey.

You have two default routes, which are not the same:
ip default-gateway 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.30.1.2

Making a route as 0.0.0.0 0.0.0.0 is the same as a default route/default gateway. Which one takes precedence I don't know. Anybody?
But you're not getting anything out of 0.0.0.0 as default-gateway.

Try removing:
no ip default-gateway 0.0.0.0
no ip route 0.0.0.0 0.0.0.0 10.30.1.2

Then add:
ip default-gateway 10.30.1.2

Then everything that theres no routes for should go to 10.30.1.2, while traffic for 10.1.28.0 should go to 10.30.1.3 according to your static route.