Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 5304xl vlan routing Internet routing

SOLVED
Go to solution
Geir Klevstad
Occasional Visitor

Procurve 5304xl vlan routing Internet routing

Hi!

What am i missing. There must be something missing.

I have added:
* ip adress for default vlan
* several vlans with Ip adresses in different subnets
* default gateway

Vlan routing is working, but Internet routing through our pfsense box is not working.

Tips?
----
Running configuration:

; J4850A Configuration Editor; Created on release #E.11.03

hostname "ProCurve Switch 5304XL"
module 4 type J4821A
module 2 type J4878A
module 1 type J4907A
ip default-gateway 192.168.99.10
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A2-A14,A16,B1-B4,D1-D4
ip address 192.168.11.1 255.255.255.0
no untagged A1,A15
exit
vlan 100
name "server"
untagged A15
ip address 192.168.1.1 255.255.255.0
exit
vlan 121
name "klient1"
ip address 192.168.121.1 255.255.255.0
exit
vlan 122
name "klient2"
ip address 192.168.122.1 255.255.255.0
exit
vlan 999
name "internet"
untagged A1
ip address 192.168.99.1 255.255.255.0
exit
vlan 400
name "virtmgt"
ip address 192.168.140.1 255.255.255.0
exit
vlan 88
name "dhcp"
ip address 192.168.88.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.99.10
2 REPLIES
cenk sasmaztin
Honored Contributor
Solution

Re: Procurve 5304xl vlan routing Internet routing

you write must have static routing command on internet router


for example

ip route 192.168.0.0 255.255.0.0 192.168.99.1

and all vlan member pc ip default gateway address must have vlan ip address

for example

vlan 122 member pc connect interface A12
ip address 192.168.122.2/24
default gateway address 192.168.122.1

dhcp server default gateway address 192.168.88.1 and connect interface A14

new config for you


hostname "ProCurve Switch 5304XL"
module 4 type J4821A
module 2 type J4878A
module 1 type J4907A
ip default-gateway 192.168.99.10
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A2-A10,A16,B1-B4,D1-D4
ip address 192.168.11.1 255.255.255.0
no untagged A1,A15
exit
vlan 100
name "server"
untagged A15
ip address 192.168.1.1 255.255.255.0

exit
vlan 121
name "klient1"
untagged A11
ip address 192.168.121.1 255.255.255.0
ip helper-address 192.168.88.1
exit
vlan 122
name "klient2"
untagged A12
ip address 192.168.122.1 255.255.255.0
ip helper-address 192.168.88.1
exit
vlan 999
name "internet"
untagged A1
ip address 192.168.99.1 255.255.255.0
ip helper-address 192.168.88.1
exit
vlan 400
name "virtmgt"
untagged A13
ip address 192.168.140.1 255.255.255.0
ip helper-address 192.168.88.1
exit
vlan 88
name "dhcp"
untagged A14
ip address 192.168.88.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.99.10
cenk

Geir Klevstad
Occasional Visitor

Re: Procurve 5304xl vlan routing Internet routing

Thank you answering.

I have now issued a static route on the LAN interface of our Internet router.
---------
Routing table:
IPv4
Destination Gateway Flags Refs Use Mtu Netif Expire
default 139.164.244.1 UGS 1 12468 1500 fxp1
127.0.0.1 127.0.0.1 UH 0 0 16384 lo0
139.164.244/27 link#2 UC 0 0 1500 fxp1
139.164.244.1 00:90:fb:24:a4:37 UHLW 2 6 1500 fxp1 1183
192.68.0/16 192.168.1.1 UGS 0 0 1500 fxp1
192.168.99 link#1 UC 0 0 1500 fxp0
192.168.99.1 00:1c:2e:cf:21:00 UHLW 1 1 1500 fxp0 534
192.168.99.5 00:1d:09:cd:b1:72 UHLW 1 1937 1500 fxp0 1200

---------------
I am now able to ping LAN and Internet locations from the core switch.
---------------
I now use a pc on my 122 vlan with IP adress 192.168.122.5 and default gateway 192.168.122.1. Result: I can ping all default gateways on my vlans, but no answer on my Internet gateway IP(192.168.99.10)
----------------
If i use a pc on my Internet vlan 999 and assigns 192.168.99.5 and default gateway 192.168.99.1 it works.

A traceroute confirms this
C:\Windows\system32>tracert vg.no

Sporer rute til vg.no [195.88.55.16]
over maksimalt 30 hopp:

1 1 ms 1 ms 1 ms 192.168.99.1
2 <1 ms <1 ms <1 ms 192.168.99.10
3 1 ms 1 ms <1 ms 139.164.244.1
4 1 ms 1 ms 1 ms 139.164.244.49
5 2 ms 1 ms 1 ms 139.164.130.33
------------------

Further tips?