Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 5308XL firmware update problem

Greg Kaisen
Occasional Visitor

Procurve 5308XL firmware update problem

Hello, I telneted to my switch and did:

Download OS
Reboot switch

out of 4 different switches, only one went smoothly. the others locked me out of the telnet session "sorry, the maximum number of active telnet session.....plese try again later" however they are still reachable via http sessions, but they still show the old version of firmware. I tried "reset device" from the http session, but that just froze me out of my browser and now I cannot reconnect in Internet explorer. The good news is that the devices are still pingable, but clearly the switch never rebooted. should I just pull the plug, or do something via the console port ?

thanks, Greg
5 REPLIES
Matt Hobbs
Honored Contributor

Re: Procurve 5308XL firmware update problem

What version did you update from and to what version are you going to (E.10.71?).

I would try connecting via the serial console and reloading from there, if that doesn't work hit the reset button on the front (this will keep your log files if further troubleshooting is required). As a last resort, pull the power.
Greg Kaisen
Occasional Visitor

Re: Procurve 5308XL firmware update problem

Hello, in 3 cases I was going from rev 07.34 to 07.40 (on my way up to rev 10.71) these are the 3 switches that failed to reboot. the 4th switch was already at 07.40 and I was able to download 10.71 and reboot successfully. The site is remote, which is why I was hoping to avoid going in and using the console port.

Thanks again, Greg
Greg Kaisen
Occasional Visitor

Re: Procurve 5308XL firmware update problem

Two Follow up questions:

1)If I do just pull the power and plug the switch back in, would you expect the switch to boot to the new 10.71 firmware which my Telnet session said was successfully downloaded? or do you think it would remain at the older version (07.40)?

2)Would you forsee any problem with the switch running as is (downloaded 10.71, but running 07.40) for say a week until I can get to it with my laptop and console port connection?

Thanks again, Greg
Matt Hobbs
Honored Contributor

Re: Procurve 5308XL firmware update problem

On those three switches, did you reboot them after the update from 07.34 to 07.40? And then did you try the update to E.10.71 which then seems to have hung the switches when trying to reload them? I just want to understand exactly the process you took to see this problem including the commands used and what versions of flash were in use, primary or secondary.

Normally you would:

1. If prior to E.07.34, copy over E.07.40
2. Reload switch with 'boot system flash ' Switch will take a bit longer to boot as it has to update the ROM.
3. Once running E.07.40 (show ver) - copy over E.10.71
4. Reload switch.

Depending on if the copy of E.10.71 is corrupted or not, pulling the power may boot it to that version. You should use the reset button on the front if at all possible though.

If it is corrupted, you may need to jump into the boot ROM to either boot to secondary flash or to copy the flash file again via xmodem. If this occurs you will probably need to contact support for assistance on this.

I don't see any particular problem in letting it run until you can physically get to the switch.
Greg Kaisen
Occasional Visitor

Re: Procurve 5308XL firmware update problem

Hi Matt, I did know that I had to be at minimum rev. 07.40 before jumping up to the 10.71 firmwware, so in 2 cases the switches were already at 07.40 and I downloaded 10.71, in a 3rd case the switch was at 09.03 - all 3 of these never completed their reboot. In the one successful case the switch was at 07.40 and went to 10.71 just fine (so I know the 10.71.swi file I downloaded is not likely to be corrupt)

My steps taken were:
1) Telnet to switch and login
2) Type Menu
3) Choose "Download OS"
4) Connected back to TFTP server and successfully downloaded the image.
5) Download was validated and written to flash
6) Choose Reboot switch from main menu

and thats where I lost my Telnet switch and the reboot never took place.

thanks again ! Greg