Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 5406 with Linux Ethernet Bonding

Steven McCoy
Valued Contributor

Procurve 5406 with Linux Ethernet Bonding

Hello,

We would like to use Linux (RHEL5.3) NIC bonding mode 4 (IEEE 802.3ad Dynamic link aggregation) on HP Blade BL460c's, but are having some trouble getting it working with a Procurve 5406. Mode 1 seems to work fine, but as soon as we switch to Mode 4 and reboot the server, we start seeing at least 50% packet loss to/from that server.

/etc/modprobe.conf:
alias bond0 bonding
options bond0 bonding mode=4 miimon=100 use_carrier=0
alias eth0 bnx2x
alias eth1 bnx2x

Switch config (important sections below):

interface B7
name "server001-trk7"
flow-control
lacp Passive
exit
interface A7
name "server001-trk7"
flow-control
lacp Passive
exit

trunk A7,B7 Trk7 LACP

vlan 10
untagged Trk7
ip address 10.10.10.10 255.255.255.0
exit

spanning-tree Trk7 priority 4
4 REPLIES
Pieter 't Hart
Honored Contributor

Re: Procurve 5406 with Linux Ethernet Bonding

according to : http://www.linuxhorizon.ro/bonding.html
did you check Pre-requisites:
- Ethtool support in the base drivers for retrieving the speed and duplex of each slave.
- also did you specify a mac-adress for the bond interface?
Steven McCoy
Valued Contributor

Re: Procurve 5406 with Linux Ethernet Bonding

Thanks for the reply, Pieter 't Hart.

Yes, both NICs support 'ethtool' (see below), and I am not using a MAC in the bonded config (see below):



# ethtool eth0|grep -i -e speed -e link
Supported link modes: 1000baseT/Full
Advertised link modes: 1000baseT/Full
Speed: 1000Mb/s
Link detected: yes

# ethtool eth1|grep -i -e speed -e link
Supported link modes: 1000baseT/Full
Advertised link modes: 1000baseT/Full
Speed: 1000Mb/s
Link detected: yes



# cat ifcfg-bond0
DEVICE=bond0
ONBOOT=yes
BOOTPROTO=static
IPADDR=10.10.10.25
NETMASK=255.255.255.0
GATEWAY=10.10.10.10
Steven McCoy
Valued Contributor

Re: Procurve 5406 with Linux Ethernet Bonding

Ahhh, lacp active with no trunking seems to have it working:

interface A13
name "server002-trk13"
flow-control
lacp Active
exit
interface C13
name "server002-trk13"
flow-control
lacp Active
exit

Then we just 'untagged' both ports into the VLAN we wanted, voila!
Steven McCoy
Valued Contributor

Re: Procurve 5406 with Linux Ethernet Bonding

lacp Active on each port, disabled trunking, and untagged each port in the proper vlan, works like a champ...