Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 5406zl - Physical Port Issue

VeritekICTSupport
Occasional Visitor

Procurve 5406zl - Physical Port Issue

Hi,

I have a Procurve 5406zl and am experiencing an issue with one of the physical ports in a module (Port 5, module A).

When I plug a cable into the physical port (which in turn plugs into my laptop) the laptop tries to get a DHCP address and does not get an address. If I set a static IP address on the card I cannot ping anything on the LAN.

If I plug the laptop into another physical port I can get a DHCP address fine and access the LAN.

The port which doesn't appear to be working is not part of a VLAN and is on the DEFAULT Vlan as per the port that is working.

If I try and set the port speed on the port which is not working (A5), my laptop picks up the change in speed (on the information of the local card), i.e 100 Full, etc, but still does not get an IP.

If I look at the lights on the physical port, the light on the right hand side does not flash at the same rate as the other ports which are working.

Looking at some logs it states (sometimes) that there are high collisions on port A5, but this doesn't always appear in the logs.

Does anyone have any ideas? Is it likely the physical port is broken?

Regards,
Simon.
1 REPLY
Pieter 't Hart
Honored Contributor

Re: Procurve 5406zl - Physical Port Issue

more setting then only speed add to this behaviour.
have you compared all port settings?
are the same type? (on the same card?)

>>>The port which doesn't appear to be working is not part of a VLAN <<<
this sounds strange, every port is member of at least one vlan.

most of these problems are caused by
- the DHCP request has timed out before the autonegotiate has done it's work
- the DHCP request has timed out before spanning-tree has set the port to forwarding
- autonegotiate resulted in a duplex mismatch
(high collision rate points to a duplex mismatch)

to resolve
- make sure the port is configured as an access port
- enable portfast
- check max speed of the port and that of the laptop
- with gigabit ports you'll need all 8-wires connected in the cable (1-on-1).
and both switch and laptop should be set to auto speed+duplex
- check length of the cables

apart from this, behaviour can differ between NIC brands (eg Intel/Broadcomm)