Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 5406zl

Alex Casanova
Occasional Visitor

Procurve 5406zl


I am currently interconnecting one Dell PowerConnect 5324 to an HP 5406zl Switch.

In the Dell 5324 the G23 port is in Trunk mode

In the 5406zl have 3 VLAN (VoIP, Servers, Default VLAN). I use the port A1 for Interconnect the 2 switches.

The 5406zl switch have the 10.0.0.96/16 ip address and 10.0.1.1 for Gateway.

I can´t ping from LAN (10.0.0.0/16) to a telephone in (10.1.0.0/255.128.0.0) but i can ping from switch to 10.0.0.75 or 10.0.1.1 (gateway) correctly. From VoIP VLAN i can ping the 10.1.0.1 gateway but i can´t ping other ip address outside the 5406zl switch.

This is the running-config
-----------------------------------
hostname "ProCurve Switch 5406zl"
module 1 type J8706A
module 2 type J8702A
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A1,A3-A24
ip address dhcp-bootp
no untagged A2,B1-B24
exit
vlan 2
name "SERVERS"
untagged B1-B24
no ip address
exit
vlan 3
name "VOIP"
untagged A2
ip address 10.1.0.1 255.255.128.0
tagged A1
exit
router rip
exit
snmp-server community "public" unrestricted
vlan 3
ip rip 10.1.0.1
ip rip 10.1.0.1 receive v1-only
ip rip 10.1.0.1 send v1-only
exit


Thks a lot for your time
Best Regards

Alex Casanova
7 REPLIES
Pieter 't Hart
Honored Contributor

Re: Procurve 5406zl

Hi Alex,
>>>
vlan 1
ip address dhcp-bootp
<<<

So on vlan-1 the switch has a dhcp-assigned addrss, not fixed.
Therefore hosts in vlan1 cannot be configured with this switch as default gateway!

this is the followed path
host -> vlan1 -> !!!vlan1-gateway!!! -> vlan3 -> phone -> -> vlan1 -> host

you better change the vlan1 address to a fixed address and configure this address as default gateway in the dhcp scope.
Alex Casanova
Occasional Visitor

Re: Procurve 5406zl


Thanks a lot for the answer. I try with a new configuration in my switch following your instructions.

Now the problem is: when i submit the config to the switch i can ping from VLAN VoIP any computer in other VLAN, but a few minutes later I start to loss pings, and i can´t ping from VoIP to any computer in Default_VLAN.

There is the config:

ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A1,A3-A24
ip address 10.0.1.18 255.255.0.0
tagged A2
no untagged B1-B24
exit
vlan 2
name "servidores"
untagged B1-B24
tagged A1
no ip address
exit
vlan 3
name "VoIP"
untagged A2
ip helper-address 10.0.1.20
ip address 10.1.0.1 255.255.128.0
tagged A1
exit
qos tcp-port ipv4 5060 priority 7
qos udp-port ipv4 5060 priority 7
qos udp-port ipv4 range 10000 20000 priority 7
router rip
exit
snmp-server community "public" unrestricted
vlan 3
ip rip 10.1.0.1
exit
Pieter 't Hart
Honored Contributor

Re: Procurve 5406zl

vlan 1
ip address 10.0.1.18 255.255.0.0
exit
vlan 2
vlan 3
ip helper-address 10.0.1.20
exit
router rip

I think this comes down to RIP version 1.
RIPv1 is not VLSM aware.
So it thinks all 10.x.x.x/8 adresses are on the same network segment.

Do you have any other routers in your network?
If not disable rip as it is only usefull when routing must dynamically change.
If so try changeing to RIPv2.
Alex Casanova
Occasional Visitor

Re: Procurve 5406zl


Thanks a lot for your answer.
With the last config all are ok, but a few minutes later I lost de connectivity with the VLAN VoIP from outside.

We don´t have any router outside, i only have de 5406zl switch and the GW to go outside the LAN across the Internet line.

Finally i will try to open a study case in HP, i think this issue its very strange.

Thanks a lot for your time and your answers
Best Regards

Alex Casanova

Pieter 't Hart
Honored Contributor

Re: Procurve 5406zl

>>> We don´t have any router outside, i only have de 5406zl switch and the GW to go outside the LAN across the Internet line. <<<

So you can remove the RIP configuration as there is no other RIP router to communicate with.


>>> and the GW to go outside the LAN across the Internet line <<<
Check this router has the correct network mask configured AND is configured for VLSM.
Alex Casanova
Occasional Visitor

Re: Procurve 5406zl




>>>>>So you can remove the RIP configuration as there is no other RIP router to communicate with.

RIP configuration removed.

This is the new configuration:

ProCurve Switch 5406zl(vlan-1)# sh run

Running configuration:

; J8697A Configuration Editor; Created on release #K.14.34

hostname "ProCurve Switch 5406zl"
module 1 type J8706A
module 2 type J8702A
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24
ip address dhcp-bootp
no untagged B1-B24
exit
vlan 2
name "servidores"
untagged B1-B24
tagged A1
no ip address
exit
vlan 3
name "VoIP"
ip helper-address 10.0.1.20
ip address 10.1.0.1 255.255.128.0
tagged A1
voice
exit
qos tcp-port ipv4 5060 priority 7
qos udp-port ipv4 5060 priority 7
qos udp-port ipv4 range 10000 20000 priority 7
snmp-server community "public" unrestricted


ProCurve Switch 5406zl(vlan-1)# sh ip

Internet (IP) Service

IP Routing : Enabled


Default TTL : 64
Arp Age : 20
Domain Suffix :
DNS server :

VLAN | IP Config IP Address Subnet Mask Proxy ARP
-------------------- + ---------- --------------- --------------- ---------
DEFAULT_VLAN | DHCP/Bootp 10.0.0.96 255.255.0.0 No No
servidores | Disabled
VoIP | Manual 10.1.0.1 255.255.128.0 No No


Many thanks again for your answer
Alex Casanova
Occasional Visitor

Re: Procurve 5406zl


More information. I enabled the STP, and when I check the log: I see that the port A2 and A2 are blocked by STP.

Log:

00435 ports: port A2 is Blocked by STP
00435 ports: port A1 is Blocked by STP
00839 stp: CST Root changed from 32768:0026f1-0ce400 to 32768:0015c5-2eab6b

Best Regards
Alex Casanova