Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve VLAN configuration

SOLVED
Go to solution
Gordon Curry
Occasional Advisor

Procurve VLAN configuration

Hi All.
I am setting up a new office and need some help with the configuration of our switches.
Basically we have a main office on one subnet and want the new site to have 2 seperate subnets for each floor.
I know this should be possible with VLAN's but once I've setup the trunk groups I get lost.
I've attached a picture of the setup to give a clearer idea of what we are trying to achieve.
Any help very much apprechiated.
Thanks.
12 REPLIES
serpel
Trusted Contributor
Solution

Re: Procurve VLAN configuration

Hi
this is quick and dirty!
--------------------------
Config 4202vl

vlan 1
ip address 192.168.50.1/24
untagged a2-a24,c1-c24, b1-b22
exit
vlan 10
ip address 192.168.20.1/24
tagged trk1
exit
vlan 20
ip address 192.168.3.1/24
untagged trk1 <--trunkb23,b24 zu 2650 ground floor
exit

vlan 30
ip address 172.16.100.2/24
untagged a1

ip routing
ip static route 0.0.0.0 0.0.0.0 172.16.100.1
------------------------------------------

Config default gateway 172.16.100.1

static route 192.160.50.0 255.255.255.0 172.16.100.2
static route 192.160.20.0 255.255.255.0 172.16.100.2
static route 192.160.2.0 255.255.255.0 172.16.100.2
-------------------------------------------
config 2848 1st floor

vlan 10
ip address ip address 192.168.20.3/24
untagged all
exit
ip default gateway 192.168.20.1

----------------------------------------
config 2650 ground floor

vlan 10
ip address ip address 192.168.20.2/24
untagged trk2 <--- trunk to 2848 first floor
tagged trk1
exit
vlan 20
ip address 192.168.3.2/24
untagged trk1, 1-40
exit
ip default gateway 192.168.3.1

------------------------------

and apply spanning tree on all switches.

i didn't test it, but i hope you get the idea.
with this setup every vlan can reach the other vlans
hth
Alex
Gordon Curry
Occasional Advisor

Re: Procurve VLAN configuration

Thank you Alex,
I'll give that a try and see how I get on.
Gordon Curry
Occasional Advisor

Re: Procurve VLAN configuration

Hi Alex
In this section;

Config default gateway 172.16.100.1

static route 192.160.50.0 255.255.255.0 172.16.100.2
static route 192.160.20.0 255.255.255.0 172.16.100.2
static route 192.160.2.0 255.255.255.0 172.16.100.2

Are you refering to setting these routes on the 172.16.100.1 device (Cisco router).

Thanks
Gordon.
serpel
Trusted Contributor

Re: Procurve VLAN configuration

hi
yes exactly.
those routes needs to be on your "default gateway".
and the default gateway for your clients is the .1 in there subnet
cheers
alex
Gordon Curry
Occasional Advisor

Re: Procurve VLAN configuration

Thanks again Alex,

I'm going to try this out on Monday evening so I'll let you know how it goes.

Gordon.
cenk sasmaztin
Honored Contributor

Re: Procurve VLAN configuration

for maximum routing performans only one route command

static route 192.160.0.0 255.255.255.0 172.16.100.2
cenk

cenk sasmaztin
Honored Contributor

Re: Procurve VLAN configuration

sory
for maximum routing performans only one route command

static route 192.160.0.0 255.255.0.0 172.16.100.2
cenk

Gordon Curry
Occasional Advisor

Re: Procurve VLAN configuration

Thanks cenk sasmaztin, I see what you mean.
Gordon Curry
Occasional Advisor

Re: Procurve VLAN configuration

Hi all,

I finally got time to try this out and it half worked. Unfortunatly I only had a small time slot for this so couldn't get much testing done.

I changed the routes on the default gateway to point to the 4204vl:

ip route 192.168.3.0 255.255.255.0 194.203.78.243
ip route 192.168.20.0 255.255.255.0 194.203.78.243
ip route 192.168.50.0 255.255.255.0 194.203.78.243

I also changed the default gateway in each DHCP scope to point to the respective IP of each VLAN on the 4204 switch.

Once done I connected a laptop to a port on in VLAN 20 on the ground floor switch and got a 192.168.3.x ip. Unfortunatly that's as far as I got. Connecting the laptop to a port on any other VLAN on the griund floor or first floor switches didn't give me an IP at all.

The configs I applied are:

4204vl:

hostname "BBP Procurve 4204vl"
snmp-server contact "Gordon Curry"
snmp-server location "BBP"
module 1 type J8768A
module 3 type J8768A
module 2 type J9033A
trunk B23-B24 Trk1 Trunk
ip default-gateway 194.203.78.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A4,B21-B22
ip address 194.203.78.243 255.255.255.0
no untagged A5-A24,B1-B20,C1-C24,Trk1
exit
vlan 10
name "VLAN10"
ip address 192.168.20.3 255.255.255.0
ip helper-address 194.203.78.12
tagged Trk1
exit
vlan 20
name "VLAN20"
untagged Trk1
ip address 192.168.3.3 255.255.255.0
ip helper-address 194.203.78.12
exit
vlan 30
name "VLAN30"
untagged A5-A24,B1-B20,C1-C24
ip address 192.168.50.3 255.255.255.0
ip helper-address 194.203.78.12
exit
ip route 0.0.0.0 0.0.0.0 194.203.78.1
spanning-tree Trk1 priority 4
password manager
password operator

--------------------------------------------

First Floor 2848:

hostname "Hank First Floor"
interface 45
no lacp
exit
interface 46
no lacp
exit
interface 47
no lacp
exit
interface 48
no lacp
exit
trunk 45-48 Trk2 Trunk
ip default-gateway 192.168.20.3
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
ip address 172.16.100.10 255.255.255.0
no untagged 1-44,Trk2
exit
vlan 10
name "VLAN10"
untagged 1-44,Trk2
ip address 192.168.20.4 255.255.255.0
exit
spanning-tree Trk2 priority 4
password manager
password operator

--------------------------------------------

Ground Floor:

hostname "Hank Ground Floor"
interface 43
no lacp
exit
interface 44
no lacp
exit
interface 45
no lacp
exit
interface 46
no lacp
exit
interface 47
no lacp
exit
interface 48
no lacp
exit
trunk 47-48 Trk1 Trunk
trunk 43-46 Trk2 Trunk
ip default-gateway 192.168.3.3
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
ip address 172.16.100.5 255.255.255.0
no untagged 1-42,Trk1-Trk2
exit
vlan 10
name "VLAN10"
untagged 22-42,Trk2
ip address 192.168.20.6 255.255.255.0
tagged Trk1
exit
vlan 20
name "VLAN20"
untagged 1-21,Trk1
ip address 192.168.3.8 255.255.255.0
exit
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4


Is there anything obviously wrong here or do you think the problem lies elsewhere.

We don't have a 172.16.100.x network but I used that for the default_vlan so that I could use the real IP addresses on VLAN 10 and 20. Would that cause an issue.

I'm going to have another go either later or tomorrow and I'll post if I find the problem.

thanks again.

Gordon.
Gordon Curry
Occasional Advisor

Re: Procurve VLAN configuration

Not to worry it's working now.

I had to make some changes to the configuration on the default gateway router.

thank you very much Alex for your help with this. Definitly saved my bacon.

I did need all three ip routes in th eend as we have other subnets in the 192.168 range which have different routes.
cpx_1
Occasional Visitor

Re: Procurve VLAN configuration

Hi could you show us the final configuration?
It would be usefull :D
Gordon Curry
Occasional Advisor

Re: Procurve VLAN configuration

Hi

The final configs are as above, the problem I had was with our default gateway router.

If you have a similar issue I'm happy to help where I can.