Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve redundant paths

Jonathan de Beere
Occasional Contributor

Procurve redundant paths

Hi Everyone,

I have inherited 3 Procurve 4208vl switches and a single Procurve 2824 (see attached schematic for connection details). I have 10 servers and a Sonicwall firewall connected to switch 1. There are about 130 PC's spread across the 4 switches. As far as I can see the switches are configured in a basic manner. Each has Spanning Tree enabled.

I've included the config of each switch:

; J8773A Configuration Editor; Created on release #L.11.12

hostname "Switch 1"
snmp-server location "LONDON"
module 1 type J8764A
module 2 type J8764A
module 3 type J8764A
module 4 type J8764A
module 5 type J8764A
module 6 type J8768A
interface A3
lacp Passive
exit
trunk A1,B1,C1,D1 Trk1 Trunk
ip default-gateway 192.168.111.10
sntp server 192.168.111.8
timesync sntp
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A2-A16,B2-B16,C2-C16,D2-D16,E1-E16,F1-F24,Trk1
ip address 192.168.111.13 255.255.255.0
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
spanning-tree
spanning-tree Trk1 priority 4


; J8773A Configuration Editor; Created on release #L.11.12

hostname "Switch 2"
snmp-server location "LONDON"
module 1 type J8764A
module 2 type J8764A
module 3 type J8764A
module 4 type J8764A
module 5 type J8764A
module 6 type J8776A
interface A3
lacp Passive
exit
interface E1
lacp Passive
exit
trunk A1,B1,C1,D1 Trk1 Trunk
trunk E15-E16 Trk2 Trunk
ip default-gateway 192.168.111.10
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A2-A16,B2-B16,C2-C16,D2-D16,E1-E14,F1-F4,Trk1-Trk2
ip address 192.168.111.14 255.255.255.0
exit
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4


; J8773A Configuration Editor; Created on release #L.11.12

hostname "Switch 3"
module 1 type J8764A
module 2 type J8764A
module 3 type J8764A
module 4 type J8764A
trunk D15-D16 Trk2 Trunk
ip default-gateway 192.168.111.10
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A16,B1-B16,C1-C16,D1-D14,Trk2
ip address 192.168.111.15 255.255.255.0
exit
spanning-tree
spanning-tree Trk2 priority 4


; J4903A Configuration Editor; Created on release #I.10.67

hostname "Switch 4"
ip default-gateway 192.168.111.10
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-24
ip address 192.168.111.222 255.255.255.0
exit
spanning-tree

I have a few questions about the configuration and how to improve it:

1. Ideally I want to provide complete redundancy between the switches, so if any switch fails the remaining switches will retain connectivity to the servers and the internet. I understand in this current configuration that if Switch 1 fails the rest of the network will lose connectivity to servers and internet, but I do realise that existing trunks do not provide enough redundancy. Will my existing and proposed trunks provide the maximum amount of redundancy in the current configuration?

2. The 2824 has a single fibre connection to Switch 3, can a fibre connection be trunked?

3. Switch 1 and 2 have LACP Passive commands in the config. I understand that one switch should run a LACP Active another switch LACP Passive command, but I'm not sure what LACP does for me. Can someone explain?

4. Switch 1 has fault-finder commands in the config. Is someone able to explain what fault-finder is? Should it be enabled on the other switches?

5. Has anything replaced HP Meshing that I could consider implementing?


Many Thanks in Advance

Jonathan
3 REPLIES
EckerA
Respected Contributor

Re: Procurve redundant paths

1.) go for it..
2.) yes fibre links can be trunked
3.) lacp is a dynamic protocol for link aggregation
4.) fault finder gives you more information in the log
5.) not that i know of

hth
alex
Jonathan de Beere
Occasional Contributor

Re: Procurve redundant paths

Hi Alex,

Thanks for your response, are you or someone else able to give me some additional answers:

1. Are the trunks and spanning tree commmands in the switch configs correct, especially the priority command. I'm not sure if I even need priority?

2. Are the LACP commands in the switch configs correct? I don't think they are but am not sure what they should be in order for LACP to work.

3. The current switch configuration doesn't give redundant links between all the switches and I believe there should be one. Can you reconfirm that my proposed diagram is correct and will work.

I'd really appreciate any experienced advice. My problem is that I a working on a live LAN and can't really afford to 'experiment' if you get my meaning.

Thank you

Jonathan
EckerA
Respected Contributor

Re: Procurve redundant paths

Hi Jonathan,

1.)the trunk command is just fine, but then it's not an lacp trunk but a manually trunk, and thats exactly how i would have done it (with the manualy trunk). i prefer the manual trunk between switches.
spanning tree is ok as well, the priority is added automatically, cos of the trunk. the only thing i would change is to not let sp choose it's root bridge on it's own, but should work just fine.
2.) i don't really use lacp, so i can't tell.
3.) yes.i alway build networks like that, which are working just fine. you need to be careful setting it up cos it will come to a recalculation of the spanning tree.

hth
alex