Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Qos For voip packets on 2610

marvan_1
Occasional Contributor

Qos For voip packets on 2610

I have configured a 2610-24 pwr switch for using avaya ip phones as well as pcs.Even i have configured vlans and qos as following my ipo 500 showing jitter and delay while making some outside calls.I would like to make sure my config is correct.Pls do suugest if any modification needed.

; J9087A Configuration Editor; Created on release #R.11.30



hostname "DulscoSW1"

max-vlans 50

time timezone 240

no qos-passthrough-mode

console baud-rate 9600

console inactivity-timer 15

ip routing

snmp-server community "public" Unrestricted

vlan 1

name "NMS"

untagged 25-28

ip address 192.168.0.1 255.255.255.0

qos priority 0

no untagged 1-24

exit

vlan 2

name "Data"

untagged 3-24

ip address 192.168.7.254 255.255.255.0

qos priority 0

tagged 25-28

exit

vlan 3

name "Voice"

untagged 1-2

ip address 192.168.3.254 255.255.255.0

qos priority 6

tagged 3-28

exit

qos type-of-service ip-precedence

ip route 0.0.0.0 0.0.0.0 192.168.7.1

spanning-tree

password manager



3 REPLIES
cenk sasmaztin
Honored Contributor

Re: Qos For voip packets on 2610

hi my create two config for you



my first config


with this config
packets have to port 5060 will be route with high priority

this is L3 priority

hostname "DulscoSW1"
max-vlans 50
time timezone 240
console baud-rate 9600
console inactivity-timer 15
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "NMS"
untagged 25-28
ip address 192.168.0.1 255.255.255.0
no untagged 1-24
exit
vlan 2
name "Data"
untagged 3-24
ip address 192.168.7.254 255.255.255.0
tagged 25-28
exit
vlan 3
name "Voice"
untagged 1-2
ip address 192.168.3.254 255.255.255.0
tagged 3-28
exit
qos tcp-port 5060 dscp 101110
qos udp-port 5060 dscp 101110
qos type-of-service diff-services
ip route 0.0.0.0 0.0.0.0 192.168.7.1
spanning-tree
password manager

-----------------------------------------------------------------
my second config

when connect ip phone 3-13 interface (must have vlan 3 taging interface and
complate tagging set on ip phone) this device packet have hight priority travel on network

this is L2 QoS

hostname "DulscoSW1"
max-vlans 50
time timezone 240
console baud-rate 9600
console inactivity-timer 15
interface 3
qos priority 7
exit
interface 4
qos priority 7
exit
interface 5
qos priority 7
exit
interface 6
qos priority 7
exit
interface 7
qos priority 7
exit
interface 8
qos priority 7
exit
interface 9
qos priority 7
exit
interface 10
qos priority 7
exit
interface 11
qos priority 7
exit
interface 12
qos priority 7
exit
interface 13
qos priority 7
exit
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "NMS"
untagged 25-28
ip address 192.168.0.1 255.255.255.0
no untagged 1-24
exit
vlan 2
name "Data"
untagged 3-24
ip address 192.168.7.254 255.255.255.0
tagged 25-28
exit
vlan 3
name "Voice"
untagged 1-2
ip address 192.168.3.254 255.255.255.0
tagged 3-28
exit
ip route 0.0.0.0 0.0.0.0 192.168.7.1
spanning-tree
password manager


each methot you can test and examine with wireshark packet analizer
cenk

marvan_1
Occasional Contributor

Re: Qos For voip packets on 2610

Dear Cenk,

Thanks for you reply.

I would like to ask you that yuor first configuration will be applicable for even single switch deployment.bcs i have only single switch and 22 ip phones are connected(port 3-24).and pcs are connected through ipphones.so i feel your first config will be suitable for me and second will not work out,since both are conected to same port?please correct me if am wrong...

hope no other config required apart form you suggested?

looking for kind reply.
cenk sasmaztin
Honored Contributor

Re: Qos For voip packets on 2610

hi

did you test any config ?

first config and secont config good for you

I realize you have single switch

first config for prioritize 5060 port (sip port) on your switch

secont config prioritize tagged interface
your ip phone connect switch interface this interface tagged for voip vlan and untagged data vlan for pc

L2 port priority already running on only tagged interface

please make test
cenk