Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

RIP Routing, Procurve 2910

XT James
Occasional Visitor

RIP Routing, Procurve 2910

This is just a basic RIP configuration question, since I'm obviously doing something wrong here. This is the first time I've even used HP routing switches, and while it LOOKS just like IOS, it's obviously not configuring like it.

Anyway, I'm trying to set up some VLAN's that will allow IP devices on one VLAN to be accessible to those on others (specifically Windows 2003 servers serving up AC, WINS, DHCP, DNS and file shares to workstations on the other VLAN's, VLAN's for VoIP, etc etc).

Unfortunately I can't even get basic routing working atm. For the purposes of this thread I'll list the basic configuration I'm trying to get working, and hopefully someone here can tell me what I'm doing wrong:

ip routing
router rip
vlan 1
untagged 1-12
tagged 45-48
ip address 192.168.0.20 /24
ip rip all
vlan 10
untagged 13-44
tagged 45-48
ip address 192.168.10.20 /24
ip rip all


I realize that if I want to do DHCP I need to put in the ip-helper address info (I THINK I have that syntax down, though obviously I haven't tested it yet). Right now I'm just trying for basic connectivity. Putting the above abbreviated config in the switch, I can plug in a work station into port 1 with an IP of 192.168.0.100 and ping the 0.20 interface no problem. Pinging the 10.20 interface gives me a reply (from 0.20) AND a 'destination unreachable'. The same goes from a workstation with an address of 192.168.10.100 plugged into port 13...it can ping the local VLAN address (10.20) but gets a reply and unreachable error when I try to ping (0.20). Also, neither workstation can ping the other.

Any help to resolve this would be appreciated...this really should be easy, but for some reason it seems beyond me.

-XT
5 REPLIES
XT James
Occasional Visitor

Re: RIP Routing, Procurve 2910

Another thing that is puzzling me here that perhaps someone answering the thread can explain is, when I do look at the config I see the following:

VLAN 1
IP RIP 192.168.0.20
EXIT
VLAN 10
IP RIP 192.168.10.20
EXIT

My question is...why the specific IP? Why not the network (i.e. 192.168.0.0 or 192.168.10.0)? Is this what I should be seeing?

Some additional info that may or may not be helpful: When I do a sh ip rip, I get:

RIP Protocol Enabled
Under RIP interface info, both 192.168.0.20 and 192.168.10.20 are shown (again, it's puzzling to me why they are showing the actual IP addresses and not the network addresses, but maybe this is what HP does)

-XT
cenk sasmaztin
Honored Contributor

Re: RIP Routing, Procurve 2910

hi james

if you want routing between vlan's and routing between other site and vlan's please read this link

no need rip config

http://forums13.itrc.hp.com/service/forums/questionanswer.do?threadId=1240414
cenk

XT James
Occasional Visitor

Re: RIP Routing, Procurve 2910

Yes, I had considered static routes both on the layer 3 switch and on the firewall. I had hoped to do this a bit more elegantly than a bunch of static routes, but I still can't seem to get the RIP routing to be functional...so, I'll probably go with plan B, which looks a lot like your second config there. I do appreciate the response. Perhaps after I get this project finished I'll return to this to see how to actually get something as seemingly simple as RIP routing to work on this HP equipment...it can't be that hard. :)

-XT
cenk sasmaztin
Honored Contributor

Re: RIP Routing, Procurve 2910

please send me sh run print
cenk

Pieter 't Hart
Honored Contributor

Re: RIP Routing, Procurve 2910

Hi XT,
I suppose other networking components are involved in your routing config.

If this switch is the only component that does the routing , you don't need RIP at all.
just assign an ip-adress to each vlan and enable "ip routing"
apart from this your workstation 192.168.0.100 must have default gateway 192.168.0.20 configured.
192.168.10.100 must have default gateway 192.168.10.20 configured.
If this doesn't it may be that the switch received (by RIP) other routing information so it redericts the packets to another router, instead of send this trafic out directly on the local interface.
(try "show ip route")

disable rip and see if you got routing working within this single switch.

ip routing
vlan 1
untagged 1-12
tagged 45-48
ip address 192.168.0.20 /24
vlan 10
untagged 13-44
tagged 45-48
ip address 192.168.10.20 /24