Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Rerouting a VLAN

Tom Hardy
Frequent Advisor

Rerouting a VLAN

Hello all,

I need to reroute vlan2 to go out through my router rather than 204.x.x.x.

Here is my setup:

hostname "vmdCore"
snmp-server location "nocRack"
module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
mirror-port C11
interface A9
power Critical
exit
ip default-gateway 192.168.30.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "dataVlan"
untagged A10-A24,B2-B24,C1-C24
qos priority 5
ip helper-address 192.168.30.90
ip address 192.168.30.2 255.255.255.0
no untagged A1-A9,B1
ip proxy-arp
exit
vlan 2
name "voiceVlan"
untagged B1
qos priority 7
ip helper-address 192.168.30.90
ip address 192.168.0.254 255.255.255.0
tagged B2-B23,C1-C24
ip proxy-arp
exit
vlan 4
name "trixbox"
untagged A1-A9
ip helper-address 192.168.30.90
ip address 192.168.10.1 255.255.255.0
voice
ip proxy-arp
exit
interface A24
monitor
exit
qos device-priority 204.14.39.36 priority 7
qos type-of-service diff-services
spanning-tree force-version RSTP-operation
ip route 0.0.0.0 0.0.0.0 192.168.30.1
ip route 204.x.x.x 255.255.255.255 192.168.0.1
password manager
password operator

=================

On my cisco router (192.168.30.1) which connects to the internet on wan side and connects to this hp on the lan side, has the following routes:

ip route 192.168.0.0 255.255.255.0 192.168.30.2
ip route 192.168.10.0 255.255.255.0 192.168.30.2
========================
I need to make my vlan2 go out the cisco router rather than go through 204.x.x.x.

With the current config on my cisco and hp, If i just delete the static route in my hp (ip route 204.x.x.x 255.255.255.255 192.168.0.1),
you think that would do it? or would i need to add another route somewhere.

Thanks

4 REPLIES
Evert Goor
Trusted Contributor

Re: Rerouting a VLAN

Sounds like source based routing. that is not possible at the moment. For that you need other hardware.
Tom Hardy
Frequent Advisor

Re: Rerouting a VLAN

Hmm thats wierd .... i dont see why i cant route all the 3 vlans out the same gateway (cisco router)?
Dmitry G. Spitsyn
Trusted Contributor

Re: Rerouting a VLAN

Hi, Tom !


Imagine you have a router inside your hp switch interfaces of which are configured with ip addresses of appropriate vlans.
On hp switch you should have a route from vlan 2 to host 204.x.x.x/255.255.255.255 via your cisco router and on your cisco router you should have a return route to vlan 2.
Your vlan 2 address is 192.168.0.254/24 and your cisco router address is 192.168.30.1 (we don't know the mask, suspect it is /24) - it means it is connected to vlan 1.
You do not need a default gateway in vlan 1 (your switch work as a router now):
no default-gateway 192.168.30.1
Then if you delete
ip route 204.x.x.x 255.255.255.255
192.168.0.1
on your hp, the traffic from hosts in vlan 2 to 204.x.x.x will go via 192.168.30.1.


Good luck,
Dmitry
Hazrat
Occasional Visitor

Re: Rerouting a VLAN

Tom,

All your traffic is going to your Cisco @ 192.168.30.1 with the exception of traffic destined to 204.x.x.x, where 204.x.x.x is a specific host since your subnet mask is 255.255.255.255 (as well as traffic between vlan 1, 3 and 4)

What are you trying to accomplish? the problem may be on the Cisco.

Basically your HP is configured for the three vlans, and it sends everything to your cisco because of:
ip route 0.0.0.0 0.0.0.0 192.168.30.1
with the exception of 204.x.x.x because of:
ip route 204.x.x.x 255.255.255.255 192.168.0.1 (and the other two directly connected vlans)

If you are trying to get something from VLAN 2 to talk to 204.x.x.x through the Cisco, then yes remove that line. (but make sure your Cisco can actually get to 204.x.x.x itself)

if you are trying to get vlan 2 to talk to a device other than 204.x.x.x (and the other two vlans) it is already going to the cisco, and the problem is most likely in the Cisco.
If what you provided are all the routes on the Cisco, it will send the vlan 2 traffic out to the internet.