Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Router on a Stick HP2554 vs. 1721

SOLVED
Go to solution
Charlie S.
Occasional Advisor

Router on a Stick HP2554 vs. 1721

I have a cisoc router 1721 i am using in a one armed routing configuraiton with an HP 2524 Switch. I have 1 port tagged with two vlans and of course the native. There is a decent amount of traffic, and the switch sits about 18% processor utilization.

Issue:
If i ping from a workstation behind the router 2 out of 3 pings drop consistantly, but the 3rd ping goes through with no probelm and with low latency.

If I ping from behind the switch across the router it pings consistantly.

The cisco router has almost no utiliztion and about 32 MB ram free.


Any ideas?
12 REPLIES
Carsten M
Regular Advisor

Re: Router on a Stick HP2554 vs. 1721

Hi Charlie
The Routerport to the SWITCH and the SWITCHport to the router are trunked?
One Router subnetz one VLAN.
The physical connection is ok, both ports has no errors?
cm60
Charlie S.
Occasional Advisor

Re: Router on a Stick HP2554 vs. 1721

1. its cisco trunked not hp trunked
two tagged, one untagged
2. on sub per vlan.
3. no errors, no duplex mismatch. speed hardcoaded, etc

New info, I was pinging from one machine last night, and it was going through fine, got to another and it drops every other ping. It's like the swtich/router can only handle so many sessions.

I found a duples mismatch on another port that was sending lots of multi-cast traffic. i waiting for traffic to ramp up so I can see if this was part of the issue.
***********

Hi Charlie
The Routerport to the SWITCH and the SWITCHport to the router are trunked?
One Router subnetz one VLAN.
The physical connection is ok, both ports has no errors?
Holger Hasenaug
Trusted Contributor

Re: Router on a Stick HP2554 vs. 1721

The Cisco may use same MAC address for all IP addresses in all VLANs on the Cisco trunk port. The ProCurve Switch 2524 has only one MAC-port address table for all VLANs as compared to the newer ones. Therefor the MAC entry in his table is toggling from VLAN to VLAN. You may either try to configure the Cisco 1721 to use diffrent MAC addresses if possible or use newer ProCurve switches like the 2600 series.
Charlie S.
Occasional Advisor

Re: Router on a Stick HP2554 vs. 1721

That would make a lot of sense... so...

I swapped out the switch with new 2600 series and it's appears to be doing the same thing.

Oh well, I'm just going to ditch the HP and buy a 4 port Fa wic for the 1721. I'll let you know if that fixes it.
Carsten M
Regular Advisor

Re: Router on a Stick HP2554 vs. 1721

The 2600 can even as if router act.
Your Cisco needs then only an interface/Subnet to the SWITCH with the other vlans/subnets.
That should be able be done.
Carsten
cm60
Matt Hobbs
Honored Contributor

Re: Router on a Stick HP2554 vs. 1721

Can you attach the config of the Cisco and the ProCurve here? What Holger said shouldn't really apply when using only the single tagged link, which is why the 2600 did not improve the situation. Check out the link below for more information on that.

http://www.hp.com/rnd/support/faqs/8000_4000_2424.htm#question27

You say that when you ping behind the router that is when you see the pings drop. When you ping behind the switch it is okay. To me this indicates that the config on the router and switch are okay on that side... possibly the issue is on that other side behind the router.

Have you tried doing any packet captures to see exactly where these first few packets are getting dropped? It sounds like the problem is occuring during ARP resolution, which is why the first few get dropped and presumably after that they all go through fine once the router has the correct ARP information.

Matt

If you submit a question or new topic and another member replies to it, you will see a dropdown menu of points next to the reply (you must be logged in to see the menu). Select the point value and then click the "submit points" button. Note that you can rate multiple replies and submit them at one time.
Charlie S.
Occasional Advisor

Re: Router on a Stick HP2554 vs. 1721

I cannot do packet captures easily as the site is in another state.

New info, it turns out the pings dropping have nothing to do with where you are pinging from. Sometimes you start a ping from a workstation and every one goes through quickly. Then you do it again a few min later and they will drop. Had another person ping and his were dropping while mine were flying through. This does smack of a mac or arp caching issue to me.

Switch:
; J4813A Configuration Editor; Created on release #F.05.17


hostname "xxxxxxxx"

snmp-server contact "someone@somewhere"

cdp run

console inactivity-timer 120

interface 21

speed-duplex 10-full

exit

ip default-gateway 175.16.162.1

sntp server 10.5.0.1

timesync sntp

sntp unicast

snmp-server community "public" Unrestricted

snmp-server community "something" Unrestricted

vlan 1

name "DEFAULT_VLAN"

untagged 1-20,22-26

ip address a*** ****

no untagged 21

[24;1H [2K-- MORE --, next page: Space, next line: Enter, quit: Control-C [24;1H [24;1H [2K [24;1H [1;24r [24;1H exit

vlan 2

name "VLAN2.349"

tagged 18

exit

vlan 3

name "VLAN3.349"

untagged 21

ip address b*** ****

tagged 18

exit

no aaa port-access authenticator active


############

ROuter:
interface FastEthernet0
description connected to Theater Local HP Switch
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
ip route-cache flow
ip policy route-map EIGRPdeny
speed auto
no keepalive
!
no interface FastEthernet0.1
description default VLAN$ETH-LAN$
encapsulation dot1Q 1 native
ip address a**** ****
ip access-group 110 in
ip access-group 110 out
ip helper-address ****
no snmp trap link-status
no cdp enable
!
no interface FastEthernet0.2 (disabled/currently unused)
description 802.1q port to Theater$FW_INSIDE$
encapsulation dot1Q 2
ip helper-address ****
shutdown
no snmp trap link-status
no cdp enable
!
no interface FastEthernet0.3
description 802.1q port to NCM DCN LAN$ETH-LAN$
encapsulation dot1Q 3
ip address b*** **** ip access-group 111 in
ip access-group 111 out
no ip redirects
no ip unreachables
no ip proxy-arp
ip inspect SDM_LOW out
ip ips sdm_ips_rule in
ip virtual-reassembly
ip policy route-map VSATEIGRPdeny
no ip mroute-cache
no snmp trap link-status
no cdp enable



P.S. the only thing on vlan 3 is one device doing a multicast stream. The 2600 i replaced the 2500 with locked up the other night. Swapped the 2500 back and its back to the normal not working systmes, meaning pings drop but the site is half functional, just slow.
Matt Hobbs
Honored Contributor

Re: Router on a Stick HP2554 vs. 1721

I assume you're doing most of your testing on VLAN1, since VLAN2 is currently shutdown on the router?

Possibly enable that VLAN and assign an untagged port on the 2524 to test with if you haven't done so already.

I'm starting to feel that there may be another device on the network that has the same IP address as the router's VLAN 1 interface. It would explain just about everything.

On the clients on that site, do a 'arp -a' and make sure that the Router IP address is matching to the correct mac-address. If you're remote you won't be able to see this yourself, you will need some onsite to check this. By the time that you would have connected through to the machine, the mac-address of the router would be in use.



Every response to your question is eligible to earn between 1-10 points. No need to worry about running out of points - when a truly awesome reply rolls in that deserves a 10, you will be able to assign it a 10! However, be careful to assign points based on the value that a reply truly provides. Use the following scale as a guideline:



o N/A: The answer was simply a point of clarification to my original question

o 1-3: The answer didn't really help answer my question, but thanks for your assistance!

o 4- 7: The answer helped with a portion of my question, but I still need some additional help!

o 8-10: The answer has solved my problem completely! Now I'm a happy camper!



Charlie S.
Occasional Advisor

Re: Router on a Stick HP2554 vs. 1721

Could moderator remove the email address and snmp strings in the config? I sent the wrong config and it contains a little too much information...
Solution

Re: Router on a Stick HP2554 vs. 1721

Edits done, hopefully ok?
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Charlie S.
Occasional Advisor

Re: Router on a Stick HP2554 vs. 1721

Yes thank YOU!
Sergej Gurenko
Trusted Contributor

Re: Router on a Stick HP2554 vs. 1721

Can you please provide "show process cpu history" and "show ip cef" (only several lines) from you cisco router?