Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Routing Between Two Subnets

CC_ICT
Occasional Visitor

Routing Between Two Subnets

We currently have two IP ranges as follows:
10.3.80/22
10.3.79.0/22

We need to setup a system to route between the two ranges as our previous SWGfL router was capped.

We have one HP ProCurve 2650 switch with IP of 10.3.11.253 and configured with the following VLANS:

VLAN 1 - DEAFULT_VLAN
IP: 10.3.11.253
Subnet: 255.255.252.0

VLAN 3 – SECONDARY
IP: 10.3.79.253
Subnet: 255.255.252.0

This switch has IP routing enabled and has one connection on port 50 which has been set to Tagged on both VLANs and connects to a HP ProCurve 2910al with IP of 10.3.11.248 via port 22 which also has been set to Tagged on both VLANs. The 10.3.11.248 switch has its default gateway set to 10.3.11.253.

We then have two laptops configured as follows:
IP: 10.3.11.20
Subnet: 255.255.252.0
Gateway: 10.3.11.253

10.3.79.250
Subnet: 255.255.252.0
Gateway: 10.3.79.253

When these laptops are connected directly to the 10.3.11.248 switch they can ping each other and all gateways fine.

Adding a HP ProCurve 2900 with IP of 10.3.11.247 and default gateway of 10.3.11.253 connected via port A3 (10GB) to port B1 (10GB) on 10.3.11.248 with both ports set to Tagged on both VLANs.

When the laptop with the 10.3.79.250 address is connected to the 10.3.11.247 switch it cannot ping the other laptop connected to 10.3.11.248 switch or any of the gateways. Swap the laptops around and they work ok.

It seems there is no route back for a device on the 10.3.76.0/22 range when connected to another switch other than the 10.3.11.248 one.

Routes on the main routing switch 10.3.11.253 are as follows:

ProCurve Switch 2650(config)# show ip route
IP Route Entries
Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
10.3.8.0/22 DEFAULT_VLAN 1 connected 0 0
10.3.76.0/22 SECONDARY 3 connected 0 0
127.0.0.0/8 reject static 0 250
127.0.0.1/32 lo0 connected 0 0

And the routes on the other switches are as follows:

NSR-MAIN-02(config)# show ip route
IP Route Entries
Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
0.0.0.0/0 10.3.11.253 1 static 250 1
10.3.8.0/22 DEFAULT_VLAN 1 connected 1 0
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0

Any ideas on what we are missing?
2 REPLIES
Marco A.
Esteemed Contributor

Re: Routing Between Two Subnets

could you add your running configs ..., just remove the auth info.

Marco
Just unplug and plug in again ....
CC_ICT
Occasional Visitor

Re: Routing Between Two Subnets

Hope this is right as a little new to switches.


; J4899B Configuration Editor; Created on release #H.10.45

hostname "ProCurve Switch 2650"
ip default-gateway 10.3.11.254
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-8,10-48
ip address 10.3.11.253 255.255.252.0
tagged 9,49-50
exit
vlan 3
name "SECONDARY"
untagged 9,49
ip address 10.3.79.253 255.255.252.0
tagged 7,50
exit
password manager





; J9145A Configuration Editor; Created on release #W.14.38

hostname "NSR-MAIN-03"
module 1 type J9145A
module 3 type J9149A
trunk 1-4 Trk1 LACP
trunk 11-12 Trk3 LACP
trunk 13-14 Trk4 LACP
ip default-gateway 10.3.11.253
vlan 1
name "DEFAULT_VLAN"
untagged 5-8,15-21,23-24,Trk3-Trk4
ip address 10.3.11.248 255.255.252.0
tagged 9,22,B1-B2,Trk1
no untagged 10
ip igmp
exit
vlan 2
name "Wireless"
untagged 10
tagged B1-B2,Trk1,Trk3-Trk4
no ip address
exit
vlan 3
name "SECONDARY"
untagged 9
tagged 22,B1-B2,Trk1
no ip address
exit
snmp-server community "public" unrestricted
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
no autorun
password manager





; J9049A Configuration Editor; Created on release #T.12.13

hostname "NSR-MAIN-02"
module 1 type J86xxA
module 3 type J90XXA
interface 5
lacp Passive
exit
interface 6
lacp Passive
exit
interface 7
lacp Passive
exit
interface 8
lacp Passive
exit
interface A2
name ".246 link"
exit
trunk 1-4 Trk1 LACP
ip default-gateway 10.3.11.253
snmp-server community "public" Unrestricted
snmp-server host 10.3.8.34 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 5-24,A1,A4,Trk1
ip address 10.3.11.247 255.255.252.0
tagged A2-A3
ip igmp
exit
vlan 2
name "Wireless"
tagged A1-A4,Trk1
no ip address
exit
vlan 3
name "SECONDARY"
tagged A2-A3
no ip address
exit
spanning-tree
spanning-tree Trk1 priority 4