Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Routing stops on 5304 after 5min.

SOLVED
Go to solution
Jacques Lemieux
Occasional Visitor

Routing stops on 5304 after 5min.

HP ProCurve Switch 5304XL(config)# show version
Image stamp: /sw/code/build/alpmo(w03)
Aug 13 2003 08:42:09
E.07.34
425
Boot Image: Primary

Scenario:
5304 has three vlans
The third vlan (CCS-backbone) is the
route to the internet via 11.1 router
5304 vlan-3 with IP .11.37
Routing stays on between the .9 and .38
vlans but stops after 5 min. from .9 or .38
to the .11.1 router although I can still ping
11.1 from the 5304.

The change over procedure:
Initially I have Sun box that acts as a router.
The 5304 switch has different IPs which I have to change.
Step. 1 Disconnect the Sun box
Step. 2 Give the 5304 the Sun box IPs for
vlan 1 to 3.
Step. 3 set up the static route paths as shown
below.
Works fine for approx. 5 minutes then stops routing. We tried this several time by trying
other protocols RIP,OSPF etc.

Thanks for any help.
Jacques

HP ProCurve Switch 5304XL(config)# show ip route

IP Route Entries

Destination Network Mask | Gateway Type Sub-Type Metric
--------------- --------------- + --------------- --------- ---------- ------
0.0.0.0 0.0.0.0 | 134.117.11.1 static 1
127.0.0.0 255.0.0.0 | reject static 0
127.0.0.1 255.255.255.255 | lo0 connected 0
134.117.9.0 255.255.255.0 | DOE connected 0
134.117.11.0 255.255.255.0 | CCS Backbone connected 0
134.117.38.0 255.255.255.0 | DOE connected 0

HP ProCurve Switch 5304XL# show ip ospf

OSPF Configuration Information

OSPF protocol : disabled
Router ID : 134.117.9.192

HP ProCurve Switch 5304XL(config)# show ip

Internet (IP) Service

IP Routing : Enabled


Default TTL : 64

VLAN | IP Config IP Address Subnet Mask Proxy ARP
------------ + ---------- --------------- --------------- ---------
DOE | Manual 134.117.9.192 255.255.255.0 No
| Manual 134.117.38.1 255.255.255.0
CCS Backbone | Manual 134.117.11.37 255.255.255.0 Yes
7 REPLIES
Ron Kinner
Honored Contributor

Re: Routing stops on 5304 after 5min.

Sounds like it is not updating its arp table for some reason. Try changing the arp timeout to 30 minutes and see if that makes a difference.

Could also be that you are getting an error disable on one of the ports. Have you checked their status to make sure they are enabled and that the duplex matches the other end?

Ron

Stuart Teo
Trusted Contributor

Re: Routing stops on 5304 after 5min.

Hi there,

Would you be interested in upgrading to the E.07.37 firmware? There's been some bugfixes since E.07.34. :)
If a problem can be fixed, there's nothing to worry. If a problem can't be fixed, worrying ain't gonna help. Bottom line: don't worry.
Markku Leinio
Valued Contributor
Solution

Re: Routing stops on 5304 after 5min.

Been there, done that. We have a 5304XL, which stops routing after a few minutes when upgraded to 07.34 or 07.37. The same applies to our spare device also, so it's not a single case. With 07.30, routing works. Only static routes, no dynamic routing.

HP is (finally!) inspecting this. (Don't hold your breath, though. SSH v2 problem is still unsolved after May.)

The switch is used as a border router, and there is something in the traffic that causes low response times for both management traffic and also for routed traffic. The situation started in the middle of October.
Markku Leinio
Valued Contributor

Re: Routing stops on 5304 after 5min.

One thing to be added to my post:

Not necessarily all the routing will be stopped (in the error situation), but some traffic may continue to be routed. Mostly stopped, however.
Jacques Lemieux
Occasional Visitor

Re: Routing stops on 5304 after 5min.

Thanks guys for the response,
I've upgraded to .37 which probably won't do much for this problem.
I've added a switch between the two routers.
(The 134.117.11.1 router which I don't have control of and the 5304.) This assures that
the 100MB, full, no Hand is maintained and not
disturbed. Routing is OK with the Sun machine
but when I do the changeover it dies again.
Should I assign a static ARP on the port where
the other router is hooked up. Is their a way
to flush the ARP table without rebooting the
switch?

Thanks
Ron Kinner
Honored Contributor

Re: Routing stops on 5304 after 5min.

HP tends to use Cisco commands for their stuff so try (from the command line)

clear arp

also try

show arp

Try changing the arp cache timeout to a larger number and see if it will route for a longer time. If so then put a static arp in for the router.

Ron

Timothy Ste. Marie
Occasional Visitor

Re: Routing stops on 5304 after 5min.

How long does routing stop? It actually sounds like Spanning-Tree has kicked in and is recalculating L2. Wait 45 seconds and then try again. You may need to do portfast on those end-device ports.