Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

STP blocking edge ports!!! Excessive CRC/alignment errors!!! PD Other Fault indication

ELMoussa
Occasional Contributor

STP blocking edge ports!!! Excessive CRC/alignment errors!!! PD Other Fault indication

Hello,

 

I'm facing problems and seeing errors as follows:

 

STP blocking edge ports

Excessive CRC/alignment errors

PD Other Fault indication, 

 

I'm using the HP 2610 as the edge switch (access Switches)... our design is based on a Core - Edge design (no distribution layer in between). every edge switch has 2 uplinks, one to the first core switch and the second is for the second core switch (2 core switches  8212zl in total). the network is 32 edge switches and 2 core switches.

 

basically the network is for CCTV surveillane IP cameras and lift management system for elevator control.

 

some cameras are going off line, the blaming game has started some engineers blame it on the cameras other blame it on the network.

 

what are these errors and how to solve these issues, letme know if you needed any more info.

 

Regards,

Ahmad El Moussa

3 REPLIES
Vince_Whirlwind
Trusted Contributor

Re: STP blocking edge ports!!! Excessive CRC/alignment errors!!! PD Other Fault indication

Configure admin-edge-port on the edge ports so they come up instantly with no STP blocking.

 

Check the errors stats (CRC etc...) and see if they are accumulating or if it's just a few packets when the port comes on line. If they are accumulating, you will need to check your port configurations. Try to make sure they are set to auto/auto, and the edge devices the same. If that doesn't work, you may need to fiddle with them, but if auto/auto gives you a failed negotiation, try to get whoever manages the cameras to look into it to see what is wrong with them.

 

 

ELMoussa
Occasional Contributor

Re: STP blocking edge ports!!! Excessive CRC/alignment errors!!! PD Other Fault indication

Hi, I'm facing the problem with couple of systems not only Cameras (e.g. Lift Management)... below is the configuration for the switch. I've attached the Show Tech file aswell.

 

i will onfigure the admin-edge-port and see the result, but i do believe there is more to the problem.

 

show running-config
; J9087A Configuration Editor; Created on release #R.11.98

hostname "Level7_CCTV_SW1"
console inactivity-timer 15
ip default-gateway 192.168.1.10
snmp-server community "public" Unrestricted
vlan 1
name "management"
untagged 25-28
ip address 192.168.1.62 255.255.255.0
no untagged 1-24
exit
vlan 7
name "Level7_CCTV"
untagged 1-14,23-24
no ip address
qos priority 5
tagged 27-28
jumbo
ip igmp high-priority-forward
ip igmp forward 27-28
exit
vlan 2
name "sms"
no ip address
qos priority 5
tagged 27-28
ip igmp high-priority-forward
ip igmp forward 27-28
exit
vlan 700
name "Lift-Mgmt"
untagged 15-22
no ip address
tagged 27-28
exit
power pre-std-detect
spanning-tree
spanning-tree config-name "B10"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 3-7 10-13 15-18 21 22 25 27 30 32 36 39 42 46
spanning-tree instance 1 vlan 48
spanning-tree instance 2 vlan 2 700
password manager
password operator


show config status

Running configuration is same as the startup configuration.

 

thanks

Vince_Whirlwind
Trusted Contributor

Re: STP blocking edge ports!!! Excessive CRC/alignment errors!!! PD Other Fault indication

I see you have two cores, 5412s, right?

 

Do they form a VRRP pair for all VLANs?

DO they have different spanning-tree priorities configured on them?

 

I see the querier seems like it's probably OK, but I don't see no IGMP querier configured on this access switch. How do you get the "Core" to be the querier without telling the edges not to be, out of interest? I've seen networks like your VLAN7 that were all screwed up because the querier was popping up in the wrong place.

 

Otherwise, you say you are gettign interface errors, but I don't see any in the port stats. I don't think there is a problem there.