Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

STP root with STP disabled on AP530 ?

J Vesterdahl
Regular Advisor

STP root with STP disabled on AP530 ?

Hello all.

I have a network made from 2824 switches, and using RSTP, the network has been humming along nicely for a couple of years. Until now, most "users" have been static, ie. digital video and telemetry, but now I'm expanding the network with a number of AP530s to allow a mobile users access to the internet through a dedicated VLAN. So far so good.
I am monitoring the network with PCM+ 2.2 and Mobility Manager 1.1, and for some reason I get a message in PCM+ from one of the AP530s, saying that "The sending agent has become the new root of the spanning tree". It's not one AP in particular, but either one.
Spanning tree is disabled in all APs, and my normal STP root reports that it is still the root. So why do I get the message in PCM+ ?
There is always one more bug ...
10 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: STP root with STP disabled on AP530 ?

Hi

Normally in any Spanning-Tree environment it should be planned in a good way, so you choose a ROOT and Backup Root then do the following commands:

On the root::
Switch1(config)# span priority 0

On the Backup Root:
Switch2(config)# span priority 1

So now, if somebody connected an Old Switch with OLD MAC address, and spanning-tree was enabled on that switch, you will be sure that it won't take over your ROOT switch.

Check also Topology Changes in show span,
see the fields: Topology Change Count: , Time Since Last Change :
If Topology changed a lot, then use
Show Span Detail
and look port by port, and see the (TC) field for top values, try to disconnect it or investigate whats connected to this port.

Good Luck !!!
Science for Everyone
J Vesterdahl
Regular Advisor

Re: STP root with STP disabled on AP530 ?

Oh yes, the root selection goes by MAC adresses - that's right.
In my wired network, the span priority of most switches is left at default 32768. My root has priority 4096 and my backup root 8192. I will try to lower these to 0 and 1 as you say.
There have been topology changes, but this is expected, and the network is designed to handle it, which it does. The last topology change as reported by the root (and others) is five days ago, but the message from the AP is from yesterday. So the root says it has been root for five days, but PCM tells me that "The sending agent has become the new root of the spanning tree" yesterday.
WDS and STP is disabled on all APs.

Could it be that my AP and my STP root both think they are roots? There's not much STP info in the CLI on the AP530.
There is always one more bug ...
Mohieddin Kharnoub
Honored Contributor

Re: STP root with STP disabled on AP530 ?

Hi

I'm sure IF you don't have Wireless bridges by using the 530s,
I'm sure that it doesn't matter if the 530 thinks its a root or not.

But if you have wireless bridges, then you have to enable Spanning_Tree there.

Good Luck !!!
Science for Everyone
J Vesterdahl
Regular Advisor

Re: STP root with STP disabled on AP530 ?

I changed the root and backup root priorities to 0 and 1 (0 and 4096), and a different AP reported that is was now the new root (oops - STP was enabled on that one). My wired root still knew it was the real root, however. Disabling STP on the AP caused a message in PCM+: "[TopologyChange]sent by a bridge when any of its configured ports changes between learning and forwarding states". So something happened.

Does an AP530 use the MAC address only to contend as STP root?
I fear this could be related to some bandwidth problems I have when connecting portables using WPA.
There is always one more bug ...
J Vesterdahl
Regular Advisor

Re: STP root with STP disabled on AP530 ?

For the record: I don't use wireless bridges.
There is always one more bug ...
J Vesterdahl
Regular Advisor

Re: STP root with STP disabled on AP530 ?

Oh ... the whole STP business on the APs - is that related to wireless only?
There is always one more bug ...
Mohieddin Kharnoub
Honored Contributor

Re: STP root with STP disabled on AP530 ?

Hi

Its recommended to turn on the Spanning-Tree on the 530s when you have WDS.

Since you don't, so i believe turning of is a good choice because you have it on from the LAN side.

Also, the 530s has the old legacy STP version, and you are running the RSTP in your LAN.

Be sure you have STP is disabled on all the APs.

Hope that solves your problem.

Good Luck !!!
Science for Everyone
J Vesterdahl
Regular Advisor

Re: STP root with STP disabled on AP530 ?

I'll leave it here for now and see what happens.
But is STP on the AP530s for wireless only or can the AP530s participate in the wired spanning tree also? If the STP messages from the APs in PCM+ are related to the wireless domain only, I can safely ignore them, which was my original concern.
There is always one more bug ...
Mohieddin Kharnoub
Honored Contributor

Re: STP root with STP disabled on AP530 ?

Hi

I'm not sure about the WLAN domain STP, but you can test setting up a low priority for one of the APs and see what kind of messages you will get in the PCM+

ProCurve Access Point 530(config)# stp priority 255

Note:
This setting will affect the Ethernet port.
don't forget to assign points to posts helped you to rank it.

Good luck !!!
Science for Everyone
J Vesterdahl
Regular Advisor

Re: STP root with STP disabled on AP530 ?

Hmm.
When I enable STP I get the usual message saying that the AP is now the root. No change when I disable STP afterwards.
My normal root is totally unaffected and says it's root all the time. Strange, that.

Well ... I'll settle with disabling STP on all APs.
There is always one more bug ...