Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Server 2012 Nic Team HP 2920 problem

madmax81
Occasional Contributor

Server 2012 Nic Team HP 2920 problem

Hi!

 

I have a hyper-v 2012 cluster with two hosts. Every host has 4 nic ports. On each host the 4 nics are in a switch independent network team (Team Server A and Team Server B). On top of each team is a vSwitch with the cluster, management and livemigration network. 

 

The physical network configuration is as follows. There are 3 switches (A, B and C).

 

Switch A = HP 2920-24G

Switch B = HP 2920-24G

Switch C = Netgear

 

Ports 1 and 2 of Team Server A are connected to ports 1 and 2 of Switch A

Ports 3 and 4 of Team Server A are connected to ports 1 and 2 of Switch B

Ports 1 and 2 of Team Server B are connected to ports 3 and 4 of Switch A

Ports 3 and 4 of Team Server A are connected to ports 3 and 4 of Switch B

 

The crossover cabling is for fault tolerance if Switch A or Switch B dies.

 

Port 24 and 23  on Switch A and Switch B are trunked uplinks to Switch C which is the production network.

Spanning Tree is active on all switches

 

If I connect the network teams in the crossover configuration the whole network goes down. Not even a ping to any PC or Server is possible.  If all ports of the network teams are attached to one switch (A or B) everything is ok.

 

A guy on Microsoft Tech Net verified my Hyper-V configuration and said, that it must have something to do with the switches. He mentioned "switchport nonegotiate".

 

Is there anything wrong with my cabling or do I have to configure something on the switches to get the fault tolerant network team working?

 

Hope anybody can help!

 

Thank's in advance

 

Madmax

1 REPLY
Vince_Whirlwind
Trusted Contributor

Re: Server 2012 Nic Team HP 2920 problem

I don't see any obvious reason why connecting it all up the way you plan should bring the whole network down.

 

A couple of things:

 

1/ Have you reduced the spanning tree priority of Switch C to 0 (or something lower than the default 32k)?

 

2/ Have you got the trunks from Switch C up to A & B each configured as a working LACP trunk?

 

3/ Have you got the trunks from each switch (A & B) to each Host configured as working LACP trunks?