Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Server Needs to Bridge/Access Two vLAN's - 2610-48

Matthew Butt
Occasional Contributor

Server Needs to Bridge/Access Two vLAN's - 2610-48

Hi All,

Hope you're all well - a quick question if I may.

We currently have a very simple network setup, one physical HP 2610-48 switch with two vLAN's each with their own Uplink to the router and their own external IP Subnet range.

I need to put a management server in place on that switch that can communicate/access with both the vLAN's. What would be the best way to configure this?

Thanks in advance for your time on this.

Matthew
5 REPLIES
Natasha Samoylenko
Trusted Contributor

Re: Server Needs to Bridge/Access Two vLAN's - 2610-48

You can place server on one of this VLANs and then just route traffic on router when you need to access different VLAN.

Or you can create tagged port in both VLANs on switch and connect server to this port.
But your server must be configured to support 802.1Q tagging. In this case server will have two IPs in different VLANs and will be in both VLAN in the same time.
But first way is easier to configure.
Matthew Butt
Occasional Contributor

Re: Server Needs to Bridge/Access Two vLAN's - 2610-48

Hi there,

Firstly many thanks for your reply, much appreciated.

I have now resolved the issue but I feel I wasn't clear enough in the first post. Basically I had a DHCP server that needed to communicate/lease addresses to both vLAN's. I have now done this by adding a IP-Helper Address to the vLAN that the server is not situated in and I believe this should have solved the issue, fingers crossed!

Thanks again for your help and it would be great if someone could confirm that I have configured the switch correctly with the above line of code.
Kind regards,

Matthew
Natasha Samoylenko
Trusted Contributor

Re: Server Needs to Bridge/Access Two vLAN's - 2610-48

I think that you did all right.
A little example to be sure.

Your DHCP server, for example, is in VLAN 10 and has an IP address 10.0.10.100/24.
All clients an this VLAN can receive addresses from DHCP server.
If you need to assign addresses for client in other VLANs (vlan 20 and 30 in example), you need to configure ip helper address on device which do routing between VLANs.
If your switch doing routing, than you will have config like this:
!
ip routing
!
vlan 10
# VLAN ip address will be default gateway for clients in VLAN 10
ip address 10.0.10.1 255.255.255.0
#and also some untagged/tagged ports...
!
#vlan for clients
vlan 20
# VLAN ip address will be default gateway for clients in VLAN 20
ip address 10.0.20.1 255.255.255.0
# IP address of DHCP server
ip helper-address 10.0.10.100
#and also some untagged/tagged ports...
!
#vlan for clients
vlan 30
# VLAN ip address will be default gateway for clients in VLAN 30
ip address 10.0.30.1 255.255.255.0
# IP address of DHCP server
ip helper-address 10.0.10.100
#and also some untagged/tagged ports...
!
Matthew Butt
Occasional Contributor

Re: Server Needs to Bridge/Access Two vLAN's - 2610-48

Hi Natasha,

We aren't getting the DHCP requests through from the second vLAN unfortunately - I think this must be down to a routing issue.

The two vLAN's currently communicate with each other which is what I need, have I missed anything obvious from the config below:


; J9088A Configuration Editor; Created on release #R.11.25

hostname "NHE10010"
interface 1
name "NHS10010"
speed-duplex auto-10
exit
interface 2
name "NHS10011"
speed-duplex auto-10
exit
interface 3
name "NHS10012"
speed-duplex auto-10
exit
interface 4
name "NHS10013"
speed-duplex auto-10
exit
interface 5
name "NHS10500"
speed-duplex auto-10
exit
interface 6
name "NHS10501"
speed-duplex auto-10
exit
interface 7
name "NHS11000"
speed-duplex auto-10
exit
interface 8
name "NHS11500"
speed-duplex auto-10
exit
interface 49
name "UPLINK 2"
exit
interface 50
name "UPLINK"
exit
ip default-gateway ***.***.***.161
vlan 1
name "UPLINK"
untagged 1-2,4-5,7-48,50-52
ip address ***.***.***.162 255.255.255.224
no untagged 3,6,49
exit
vlan 2
name "UPLINK2"
untagged 3,6,49
ip helper-address ***.***.***.189
exit


Thanks for your time on this, really appreciated. Have a good day.

Matthew
Natasha Samoylenko
Trusted Contributor

Re: Server Needs to Bridge/Access Two vLAN's - 2610-48

Hi Matthew,

You say that devices in VLAN 1 and 2 can see each other.
What device did you use to route traffic between this VLANs?
As I see from your config this is not switch NHE10010.

You need to configure command ip helper-address (or something like that if this device is not a HP switch) on device which doing routing between VLANs 1 and 2.

In my previuos example I write a config with assumption that your switch doing routing.

I read your first post once again.
You doing routing on router. So you need to configure command ip helper-address on router interface there is attached VLAN in which you don't have DHCP server.