Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Setting up Vlan on ProCurve Switch 2900-48G?????

Adam Conerly
Occasional Visitor

Setting up Vlan on ProCurve Switch 2900-48G?????

I am wanting to know the correct way for hosts currently on the default vlan of the switch to be able to communicate to hosts on the second vlan which I have created. I have minimal experience with setting up vlans and just want a little point in the right direction. Here is the configuration.

Startup configuration:
; J9050A Configuration Editor; Created on release #T.12.51

hostname "Procurve Switch 2900-48G"
module 3 type J90XXA
ip default-gateway 192.168.1.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-A4
ip address 192.168.1.3 255.255.255.0
exit
vlan 2
name "HFCTimeclock"
ip address 192.168.30.1 255.255.255.0
tagged 15
exit
spanning-tree



The port which I have tagged for the second vlan is the port which I will be plugging in a timeclock that I want on the second vlan. Is this correct??
3 REPLIES
Matt Hobbs
Honored Contributor

Re: Setting up Vlan on ProCurve Switch 2900-48G?????

You probably want to untag 15 in VLAN2 instead. Usually it's only your switch-to-switch links that you'll need to use tagging.

Other than that your config looks right.
Adam Conerly
Occasional Visitor

Re: Setting up Vlan on ProCurve Switch 2900-48G?????

Now that I have that port untagged on vlan 2, how do I route traffic from and to that vlan? I put my laptop on that port with a static address of 192.168.30.5, subnet of 255.255.255.0, gateway of 192.168.30.1 and I could ping the 192.168.1.3 which is ip address of default vlan but I could not ping anything else. What should I do?
Pieter 't Hart
Honored Contributor

Re: Setting up Vlan on ProCurve Switch 2900-48G?????

>>>
ip default-gateway 192.168.1.1
ip routing
<<<

if you enable "ip routing"
the "ip default-gateway 192.168.1.1" is ignored
you should use "ip route 0.0.0.0 0.0.0.0 192.168.1.1" instead.

Pieter