Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Setup VLAN on Procurve 2626

kwilke
Advisor

Setup VLAN on Procurve 2626

Hello all,
I am a newbie to VLANs on Procurve switches so I will need some big time help.
I have a Procurve 2626 J4900A switch that has the capability to do VLANs.
The current IP address of the switch is 192.168.10.1 with a class C subnet mask. Currently everything plugged into all ports are on this subnet.
In port 17, I currently have a Cisco device that is being used as a NAT device (yes - extreme overkill). It has an IP address of 192.168.10.70 and the other side of the Cisco is IP address 192.168.172.99.
What I would like to do is take port 17, (and let's give it an ID of 172 and name it VLAN-172), to have the IP address of 192.168.172.99. I have figured out how to create a new VLAN and give it an ID and a name. After that I am lost as to what I need to do so that I can get rid of the Cisco and plug what was in the other side of the Cisco into this port 17.
Any help will be greatly appreciated.
Thank you,
Kelly W.
13 REPLIES
kwilke
Advisor

Re: Setup VLAN on Procurve 2626

Hello all,
I hope that this isn't too tough of a question or that it is too basic that no one wants to answer.
Thanks,
Kelly W.
cenk sasmaztin
Honored Contributor

Re: Setup VLAN on Procurve 2626

hi
please send me your network topology map

I can't understand other side cisco device section
cenk

kwilke
Advisor

Re: Setup VLAN on Procurve 2626

Hello,
Other side of Cisco just means that point A is on the 192.168.10.x network and point B is the other side of the Cisco. A different network of 192.168.172.x.

I guess I don't know how to explain it any better than this:

192.168.10.x network where switch is 192.168.10.1
|
|
Cisco is plugged into port 17 - has an IP address of 192.168.10.70 on one port on Cisco
|
|
Other port of Cisco has an IP of 192.168.172.99 and goes to that 172.x network.

I want to do away with the Cisco and tell this switch that port 17 has a VLAN going to 192.168.172.x and that the IP address on port 17 is 192.168.172.99

Does that help?
Thanks,
Kelly W.
cenk sasmaztin
Honored Contributor

Re: Setup VLAN on Procurve 2626

if you have one inbound port on cisco router
you can create sub interface under physical interface

copy and paste my procurve config on your switch and connect int 17 with router

interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 2
ip address 192.168.10.70 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 3
ip address 192.168.172.99 255.255.255.0


and


vlan 1
name "DEFAULT_VLAN"
untagged 16-28
ip address 192.168.20.1 255.255.255.0
no untagged 1-15
exit
vlan 2
name "VLAN2"
untagged 1-10
tagged 17
exit
vlan 3
name "VLAN3"
untagged 11-15
tagged 17
exit

vlan 2 for 192.168.10.0 network so 1 to 10 ports 10.0 network member
vlan 3 for 192.168.172.0 network so 11 to 15 ports 172.0 network member
vlan 1 only managemet
no need vlan 2 and 3 ip address
vlan 2 member default gateway must be 10.70 ip
vlan 3 member default gateway must be 172.99 ip
cenk

kwilke
Advisor

Re: Setup VLAN on Procurve 2626

Hello,
Okay I lost you.
I want to get rid of the Cisco completely since it is failing and I do not want to have to purchase another one, especially if this Procurve switch can do VLANs.
So, can we do a VLAn where port 17 is contacting the 172.x network on this switch?
Thank you,
Kelly W.
cenk sasmaztin
Honored Contributor

Re: Setup VLAN on Procurve 2626

create on hp switch vlan


ProCurve Switch 2610-24(config)# vlan 5
ProCurve Switch 2610-24(vlan-5)# untag 20-24
ProCurve Switch 2610-24(vlan-5)# ip address 192.168.10.70/24
ProCurve Switch 2610-24(vlan-5)#

untag port member port
cenk

kwilke
Advisor

Re: Setup VLAN on Procurve 2626

Hello,
I am very lost.
I want only port 17 to go to the 172.x network and all the rest of the ports to remain working on the 10.x network.
Thanks,
Kelly W.
cenk sasmaztin
Honored Contributor

Re: Setup VLAN on Procurve 2626

ProCurve Switch 2610-24(config)# vlan 172
ProCurve Switch 2610-24(vlan-172)# untag 17
ProCurve Switch 2610-24(vlan-5)# ip address 192.168.172.99/24
ProCurve Switch 2610-24(vlan-172)#wr mem

ok.
cenk

kwilke
Advisor

Re: Setup VLAN on Procurve 2626

Hello,
So I don't tag port 17?
Do I run GVRP on the switch or not? Currently am not running it.
IP routing is currently disabled on the switch, do I want to enable it?
Remember that I have been using this as a standard switch and want to start using its full functionality.
Thanks,
Kelly W.
cenk sasmaztin
Honored Contributor

Re: Setup VLAN on Procurve 2626

hi Kelly

I send to you two config config one one inbound interface router and two network runing

tag port no shuch thing gvrp
tag port so tagged port carying many vlan id on same port

my frist config one router interface cary two network to switch

other config for example create vlan on hp switch

I hope you understand me

if you want create vlan on hp switch
must be write this command

ProCurve Switch 2610-24(config)# vlan 172
ProCurve Switch 2610-24(vlan-172)# untag 17
ProCurve Switch 2610-24(vlan-5)# ip address 192.168.172.99/24
ProCurve Switch 2610-24(vlan-172)#wr mem



cenk

kwilke
Advisor

Re: Setup VLAN on Procurve 2626

Hello,
Okay I will do the create the VLAN on the switch.
I will have to wait until tomorrow morning to do this since the switch is being used the rest of today.
I will let you know how it works.
Thank you,
Kelly W.
Pieter 't Hart
Honored Contributor

Re: Setup VLAN on Procurve 2626

>>>
In port 17, I currently have a Cisco device that is being used as a NAT device
<<<
probably you only need routing between two networks ?
if you really need NAT, text below is not sufficient.

if so you need to
- create vlan
- select subnets for each vlan (192.168.x.0/24)
- give switch ip-adress in in each vlan (192.169.x.1)
- enable routing
- assign ports as "untagged" in respective vlan
- configure connected host to use switch ip-adress as default gateway


like Cenk sayd use vlan-1 only for management

vlan 1
name "DEFAULT_VLAN"
ip address 192.168.1.1 255.255.255.0
untagged 1
no untagged 2-28
exit
(only port1 can reach this management vlan directly)

vlan 10
name "localhosts"
untagged 2-16, 18-26
no untagged 1, 17
ip address 192.168.10.1 255.255.255.0
exit

vlan 172
name "oldCiscoport"
untagged 17
no untagged 1-16, 18-26
ip address 192.168.172.99 255.255.255.0
exit
ip routing

the localhosts must use 192.168.10.1 as gateway to reach the 192.168.172.0 network
if there are other subnets behind this port
the switch also needs a default-router on this subnet.
ip route 0.0.0.0 0.0.0.0 192.167.172.x

and offcourse the devices in 192.168.172.0 network must know a (default) route back to reach 192.168.10.0 devices
kwilke
Advisor

Re: Setup VLAN on Procurve 2626

Hello,
Well this failed miserably so I guess I need to call tech support to figure out what to do.
Thanks,
Kelly W.