Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Simple VLAN Trunking Problem

Lenny Davis
Regular Advisor

Simple VLAN Trunking Problem

I have setup a 4 port VLAN on a 2524 and 2915 Procurve switch (same name & VLAN ID). When I setup a static LACP trunk on 2 ports of each switch, devices on the other 2 ports of each switch are unable to communicate. Tried setting the VLAN ports as tagged and untagged but makes no difference. GVRP disabled on both switches. However when I setup trunking on the default VLAN, devices on other default VLAN ports are able to communicate.

There must be something simple I need to do but I can't work out what I have done wrong despite hours of reading the documentation. Do I need to enable the Spanning Tree Protocol?

Any suggestions would be gratefully received as there must be a very straight forward solution.

Thanks

Lenny
13 REPLIES
Drew Redman
Valued Contributor

Re: Simple VLAN Trunking Problem

VLAN configuration on the ports is lost when you put them into a trunk, because the ports are now part of a "virtual port" called trk1 (or trk5 or trk30, or whatever you named the trunk).

After creating the trunk, you need to go back through and add trk1 as a tagged member of your vlan(s) on each switch. (ProCurve Switch(config)# vlan 2 tagged trk1) This will allow vlan traffic to traverse your trunk at layer 2.

And just to make sure there's no confusion... trunking = link aggregation. Many people are confused by this because Cisco uses trunking to define 802.1Q tagging.

And no, you don't need to worry about STP.
Tijl van der Steeg
Valued Contributor

Re: Simple VLAN Trunking Problem

If you do *anything* serious with a port, it gets reset to default settings. Make it member of trunk, or delete the membership, but also if insert a fiber module in a dual-personality port, it goes back to default setttings
Lenny Davis
Regular Advisor

Re: Simple VLAN Trunking Problem

Thanks Drew. I take it I need to use the command line interface as in your example, because I have been using the menu options, and when you allocate ports to a trunk they become unavailable to add to a VLAN which is what you're suggesting I need to do?

Thanks

Lenny
Drew Redman
Valued Contributor

Re: Simple VLAN Trunking Problem

That's correct. You now need to add the trunk group to your vlans, not the individual ports in the trunk group.

You can continue to use the menu interface for configuration. In the VLAN port assignment window, you'll notice that the ports in your trunk group are not listed, but you should see your trunk group at the very bottom. This is where you will add the trunk to your vlans.
Lenny Davis
Regular Advisor

Re: Simple VLAN Trunking Problem

Drew, I have done EXACTLY what you have told me to do and it doesn't work. I'll have tio explain in full detail.

I have a 2524 switch with IP address 192.168.20.33 and a 2913 switch with IP address 192.168.20.38. A PC with IP address 192.168.20.2 us connected to the 2524. A PC with IP address 192.168.20.1 is connected to the 2913. Switches are connected with a single cable. PC's can ping eachother.

I create a trunk using the end 2 ports of each switch, same name and VLAN ID. I then create a VLAN using the last 4 ports of each switch, by selecting the Trunk (which appears at the bottom as you say) and 2 more ports creating 4 ports total. I select options No for default vlan and Tagged for my new VLAN, as you suggested. I link the trunked ports and plugged the PC's into my new VLAN. They can't ping eachother. I decided I might need to change the network address of the PC's to get this to work, so change them to 192.168.30.1 and 192.168.30.2. They still can't ping eachother.

This should work in my opinion as it is setup exactly as you have described. So there must be some other hidden setting(s) somewhere that I need to change.

If someone could tell me what else I need to change I would be grateful.

Thanks

Lenny
Tijl van der Steeg
Valued Contributor

Re: Simple VLAN Trunking Problem

sounds ok, Can you send your config?
Lenny Davis
Regular Advisor

Re: Simple VLAN Trunking Problem

I appear to have fixed this but I'm not sure why it works now and not before. I replaced the Tagged setting with Untagged on my VLAN and it just kicked into life. Then I changed it back to Tagged and it stops working.

I thought you could still set ports as tagged even if they belong to only one VLAN? Maybe this is not the case. If someone could confirm that would be great.

Thanks

Lenny
Tijl van der Steeg
Valued Contributor

Re: Simple VLAN Trunking Problem

which port did you tag? where your pc is connected? PC's don't understand tags.

Remember
- A port can only be an untagged member of ONE VLAN
- A port can be a tagged member of many VLANS's(use this for interswitch links)
Lenny Davis
Regular Advisor

Re: Simple VLAN Trunking Problem

I just changed the 2 tagged ports in my VLAN and the tagged VLAN trunk to untagged and it worked.

Lenny
Tijl van der Steeg
Valued Contributor

Re: Simple VLAN Trunking Problem

Well you should definitely tag the trunk, if you want to be enable to communicate. Don't tag the access ports, you're just communicating over the default VLAN now, that's why it's working
Lenny Davis
Regular Advisor

Re: Simple VLAN Trunking Problem

I've just tagged the trunk and it still works so I guess that's now the correct configuration.

Thanks for all your assistance guys.

Cheers

Lenny
Drew Redman
Valued Contributor

Re: Simple VLAN Trunking Problem

Tijl is right.. untag the access ports (ports connecting to your PC's) in the vlan that the PC's are supposed to reside in. Then, tag the trunk group on each switch for that same vlan.

PC's, printers, servers, etc generally don't understand tagged traffic. Ports connecting to these non vlan-aware devices always need to be untagged.
Lenny Davis
Regular Advisor

Re: Simple VLAN Trunking Problem

Sorted now thanks to Tijl and Drews explanations.

Lenny